Dma problem

Hi everyone,

i have a DMA problem with some DVDWriters which i find quite annoying. Maybe some of you have encountered this problem and can help me.

I own a Sony DW-Q30A and LG GSA-H55N (lg model may be wrong) and i have some problems about enabling DMA with these drives.
When try to enable DMA with these these drives didnot enable DMA. (looking with Nero Infotool)

I updated windows (XP) with some patches , tried to unplug-plug the drives , removed from the device manager and reinstalled but DMA never is enabled for Sony and LG . I upgraded the firmware of LG and now it is DMA enabled but Sony is dma disabled even if i upgrade the firmware with yys7 (i think this is it, it was yys2 or sthg like that before upgrade).

  • tried physically unplug-plug
  • uninstalled in device manager and reinstalled (xp automatically installed)
  • checked always the IDE channel’s DMA option.
  • upgraded the firmware for Sony and LG (lg is DMA enabled now but sony is not)
  • my computer have only 1 ide cable (1 for dvdrom and 1 for harddisk) so i cannot plug both dvd drives. but when i find a cable i will try.
  • google also didnot help me much. Maybe not specific for Sony, i believe it has some kind of software or XP related problem.

Why Sony is never DMA enabled i dont understand. If you can suggest something new i would be grateful.

Thanks

Hi,

at first, get a new IDE cable and rearrange your drives so they won’t be paired with the HDD. Preferably, that should be a 80wired, 18" (46cm) flat ribbon cable.

In the meantime, make sure, that your drives (including HDD) jumpers are properly set to master/slave configuration, since any mix of Cable Select and Master/Slave settings will cause issues. Also, some optical drives don’t like to be set to CS.

Michael