DMA problem with LiteOn sohw-1693s

Hey everyone,

 I've got a problem with my LiteOn sohw-1693s drive. Whenever i enable DMA for the drive it freezes when it tries to read any kind of media. And i mean anykind, dvd's; burned or bought, cds; burned or bought. The computer recognizes the drive by its self, but when i try and read any kind of media it freezes. I have a dragon 2 motherboard with a 2.4 P4 processor. I think it is on its own IDE channel but i'm not sure, i'm at school so i cannot check. if it isnt it is sharing a connection with a 40 GB hard drive. Please help becase the 1.1-2.1x read speed is really slow.

What IDE drivers do you have? Standard microsoft or nVidia or Intel or Via or other?

i’ve got standard microsoft drivers

I have checked and the drive is on its own IDE connection set as master for sure. Any help would be appreciated.

I’ve got windoze xp pro if that helps any.

I don’t know if can be useful, but some mainboards require to enable DMA also in bios.

i’ve got dma enabled in the bios, but thanks for your input, anyone else is encouraged to submit any and all ideas.

Maybe can be useful to check your IDE cable: are they 40 wire or 80 wire?

Hi. I am new to all of this can some one help please i have a liton 1653sx external, and it has stoped burning cds, but will read and burn dvds, it will not read the cds i have tried all kind of cds but will not work

Hi dave1950. Welcome to the forum

DVD burner have two lasers, one for CD and one for DVD. It’s possible that your burner have a damaged laser, so if your drive is in warranty go for a substitution.

Anyway, a little suggestion :wink: : this is the wrong site to post such a question. In this thread we are discussing about DMA. Next time open a new thread :bigsmile:

Thanks for your help Dave

not really sure, i’ll check when i get home, whats the easiest way to tell?
thanks

Take a look here: there is a good explanation, but I’m not sure that this can solve your problem. It’s only an hypothesis

yeah, i’ve got the 80 wire cables, dont know why i had a problem telling, just too simple i guess. anyways i’ve got the 80

could it be a windows problem because i know DMA worked fine in another computer, thanks.

No: DMA is a hardware thing. WIndows cannot enable DMA if your hardware don’t allow it.

However, only very old mainboard don’t allow to enable DMA; a 2 year old mainboard should be able to manage DMA.

What sometimes helps is to uninstall the drivers for the IDE channel & reboot. Windows will then redetect the device & re-install what’s necessary.

There’s this link which takes you through the steps necessary to correct DMA.

BTW DMA is not affected by whether you have 4 or 80 wire cables other than you won’t get ATA66 + throughput with 40 wire cables…

tried to re-install the ide channel but that didnt work. it didnt install right untill i disconnected the dvd drive, then installed the channel, and then put the dvd back on. back to where i was now. thanks for your help, anyone else have any ideas?

Some mainboards require to activate DMA also in BIOS: check your BIOS to see what settings there are.

my bios has these settings

IDE DMA transfer access-Enabled

IDE
Primary Master PIO
Primary Slave PIO
Secondary Master PIO
Secondary Slave PIO

setting for these is mode 0-4 or auto, i have it set to auto

IDE
Primary Master UDMA
Primary Slave UDMA
Secondary Master UDMA
Secondary Slave UDMA

Setting for these is either disabled or auto, i have it set to auto.

hope this helps, thanks

by the way, its a Dragon 2 sy-P4I875P Platinum Edition motherboard with a 2.4 P4 and 1 GB of ram.