DMA/PIO Transfer Mode problems

vbimport

#1

Hi, I bought my 1620Pro about two mths back, and patched it using The Dangerous Brothers’ B7U9 RPC-1 patch. Everything worked well until recently, when, while burning with Nero, the computer gets really unresponsive. According to friends, I should enable DMA on this PC, which I tried, but XP refuses to reset the burner’s transfer mode to DMA, but PIO mode. (Running Windows XP Pro SP1). I tried switching back and forth between normal and ATA-100 cables (the only thing that I changed during the entire time of using the burner, but to no avail). Anyone has any ideas on how else can I enable DMA transfer on the burner? It’s disheartening to see the computer freeze for long bouts of time while burning. I’ve already tried enabling DMA under Device Manager, Primary IDE Channel (burner’s a Primary Slave), by selecting DMA if available transfer mode, but it still goes to PIO mode regardless.

Thanks in advance for your time.


#2

Welcome to cdfreaks :wink:

Please specify your compu motherboard and the chipset used.


#3

It’s an old Asus A7V266, VIAKT266


#4

Are you on windows or VIA IDE drivers right now?

Anyway, I suppose you have your HDD on Primary IDE-channel. BenQ likes best to be at its own on Secundary master.
Remove your IDE-channel in device manager. Turn off compu. Jumper your burner as master, connect one end of IDE-cable at mobo Sec IDE-channel and the other end to your burner. Restart.

Hopefully now Windoze will install default windows IDE drivers. But if you use VIA Miniport drivers then it’s a complete different storry.


#5

I’m on VIA Busmaster IDE drivers at the moment. Thx for the advice, I’ll keep it in mind. However, earlier, another friend pointed to me the root of (what I think is the actual) problem, which is related to XP (Drives reverting to lower transfer mode/rates upon failed reading of media) : http://www.michna.com/kb/WxDMA.htm . So far after following the steps there, everything seems to be ok. If there’s anything else, I’ll post back, thank you again.

PS : So it’s best not to install any VIA mobo drivers then?


#6

No just not the IDE drivers if your using a DVD writer, you should also consider updating to XP service pack 2 as some of those IDE/DMA bugs were fixed.


#7

I see, thanks for the clarification :). I’ll do that then.