Dma Off/on?

vbimport

#1

If i go to my Device Manager, and select all of my IDE’s, and set all of them to DMA if Availabile, my DMA should be on for my DVDRW burner right?

Yet, if i run Nero Info Tool, it tells me my DVD burner’s DMA is off. :confused: I think this is the reason it has been burning at under 1x for a week now! :o

What do i do?


#2

Hi - Welcome to the forums. :slight_smile:

Some details of your drive etc would be helpful - Any chance you can post a copy of Nero Infotools text (Please remove serial numbers before you post).


#3

Here’s a thread that might help you. Look here


#4

TimC, i did that thread to a T, still doesn’t work i get a PIO mode only for one of my drives, which i’m assuming is the DVDRW.

My burner is a DVDRW IDE1008, which is a Emprex. Yeah, i know its a crappy burner but it was working fine until recently.


#5

I’d recommend that you uninstall the burner in device manager, if you haven’t already tried this…probably secondary IDE channel and reboot and let windows reinstall. If that doesn’t do it, check your cable connections and maybe swap it out if you have another one.
Hope this helps.


#6

Is it reporting dma mode 2 or multi word dma mode 2 in windows? If so it is probably running pio and windows is falsely reporting dma. You need at least ultra dma (udma) mode 2. Check your bios during startup. Sometimes you have to enable dma there.


#7

Ripit, how do i go about checking and forcing it on through bios?

I focused it onto the Secondary IDE, device 1, not 0. It says current transfer mode is PIO, and its set to DMA if available. I reset the computer and thats what is popping up.


#8

Doing it is not hard but telling you how to do it might be a little harder. The reason is that there are many diffrent bios screens so it is hard to tell you where to go. When your computer is first starting, hitting the del key (you can usally sit there and tap it as soon as you turn the power on) will usally get you into the bios. Under the first few options, there should be a dma setting. Just about every bios I have seen has a saftey function that you have to save and exit for changes to take place. If you think you acidentally changed something you shouldn’t, chose the exit without saving option. If you find something that looks like it but are unsure, post what it is and we can probably tell you.
Fyi use cdspeed to test the burst rate to verify that it is infact enabled, reguardless of what anything is reporting. It has to be at least about 22MBps. You could check it now to see what it is if you like.


#9

I almost forgot. You can look in your motherboard manual and find instructions for your bios settings. What motherboard do you have?


#10

I went into my BIOS and found my way to the Secondary Slave, DVDRW IDE1800, my dvd drive. I found the PIO and DMA channels, i set the DMA to UDMA 2 and the PIO to Auto. The PIO also had 0,1,2,3,4,5… but i set it to auto. My burst rate is still coming out at 4mbs!

My motherboard according to Nero InfroTool is a Intel D865GBF.


#11

Update: I uninstalled both of my Secondary IDE pieces and with that my DVDRW IDE1008. Upon restart it detected and reinstalled the drive. My burst rate is at 25Mbps, and Nero InfoTool is reading that my DMA is on.

So far so good! I am going to burn and test it out now!

I do have a question… In my Device Manager, under DVD/CD-ROM drives, i have my CDRW and DVDRW, as well as two SCSI CdRom Devices. They also appear in My Computer, but i don’t know what they are. When i click on them and press the eject button, nothing happens, so they aren’t tied into the other drives.

That goes along with my question. I have two Primary IDE Channels, and two Secondary IDE channels. Is that wrong? I have two hardrives and two burners, but that’s it…

By the way, Thanks EVERYONE for helping me out.


#12

Have you installed any virtual drives recently?

Daemon Tools, Virtual Clone Drive, Nero imagedrive or Alcohol?

This would account for the scsi devices :wink:


#13

Debro, your right it was my virtual drives.

After about 4 burns, my dvdrw ide1008 went back to its old ways of writing under 1x. I belive i will have to reinstall my IDE driver every few days now!


#14

I would suggest that you try the standard Microsoft PCI IDE driver, or download the latest version of your specific drivers.

There must be a reason that the IDE is turning DMA off. It’s either corrupted drivers, or a hardware fault.

If it’s hardware, you can try removing the other device from your burners cable. If there is no other device, replace the cable.