DMA just won't Enable?

Hi i bought my BTC 1008IM a couple of weeks ago. I burnt 1 successful dvd+r, and 3 dvd-r’s … after that my computer restarts while burning, just like that. And another thing…i’ve tried’ to enable DMA, it just won’t Enable, anyone knows why ??? I’ve tried to Uninstall the IDE-channel that my DVD-burner is on, but no success, it shows PIO mode anyway, and yes i checked the box: “DMA if available” . I have my DVD-burner in secondary channel as slave, and my Harddrive as master. Any suggestions ? Thx in advance!

SYSTEM CONFIG:

256 SDRAM
40 GB HD, SAMSUNG
1.5 GH Pentium 4
Nvidia Geforce MX 400 64 MB
CD-Burner 16X-CD-R/ 10-CDRW

Try uninstalling the nvid drivers (IDE) and let windows install the MS drivers. Then try to set DMA.

hi what do you mean nvid drivers (IDE) ?? does nvidia have it’s own IDE drivers as well ? and where can i download it ? thx

I do not use Nvidia products strictly ATI here.Since coming to cd freaks so many people have had problems with the NVid drivers and certain configurations. The drivers are installed with the Nvid software. Depending on your OS (I use win2000 for my media PC) what I do is in device manager just open IDE controllers, uninstall the ide that the drive is on and reboot. windows should install its own IDE Controller.

Unless I’m very much mistaken, nmpaulcp is actually talking about nVidia chipset, i. e. including IDE, drivers.

Yep.

nVidia comes to mind, of course… But you probably don’t really want to know, because you should get rid of those drivers, not install them. There’s a good chance they’ll screw up your system, unless they already have.

Regards, Martin A

well in the list of ata/atapi controllers i don’t see the Nvida IDE controller…and i tried to uninstall the drivers…still didn’t work. hmmm…DMA for my CD-Burner, CD-Rom, HD all are enabled except for the DVD-Burner…straaaange

setting a dvd writing device as slave from a hd is really not good, this may cause your probs

try to set your hd on primary master, set the 1008 as master on sec. channel and the cd writer as slave.

this works maybe.

i had my dvd-burner as master on sec channel & dvd-rom as slave, hd was on primary as master so i didn’t change it…no success :((

the way i got this to work was too go into bios setup and instead of letting pc auto select drive i set it to dvd/player and this cured the problem it now is dma enabled!!! here is the post i sent earlier :-http://club.cdfreaks.com/showthread.php?t=89538 :-
in your startup by pressing F2 you will get into the bios setup
there you can select your ide settings for your dvdr.
when mine was on auto it would go to PIO mode
i selected CD/DVD which was right down second to last on the list
this worked and now my dvdr runs in ULTRA DMA 2 mode

Exactly WHERE in the BIOS setup can i do this ??? I Only see the options: “Disabled” & “Auto” for the dvdr…in the UDMA…

you are on the right way. by pushing enter you can only select from disabled and auto??? there should be a list with the dma modes.

http://club.cdfreaks.com/showthread.php?t=87806

what mobo and bios version do you have???

I got MS-6391 Motherboard, and the latest version of the bios which is 1.5 …it’s very weird :((

http://club.cdfreaks.com/showthread.php?t=90055 this could also be help for you

It didn’t help man, why oh why ??

have you also looked under integrated peripherales in your bios???

i found this in the MS 6391 manual



As you can see yourself in the pictures you posted, the only options i got for UDMA are “Auto” & “Disabled”. hmmmmmmmm

uuups, sorry i was looking under the pio part, must´ve been drunk when i was reading :stuck_out_tongue: sorry again.

what ide cable are you using, if the cable is longer than 40cm this could also cause your problem.

are you using the cable came with your drive? if not give it a try.

Golly, are you still fighting this problem after a whole month?

Take a look at Q817472 in the Microsoft Knowledgebase. It covers a situation where the OpSys locks a channel into PIO mode after it once incurs a number of hard I/O errors. Warning, this fix requires editing of the registry. Unfortunately, if this is what’s causing your problem, this is the only way to fix it. See the article at:
http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

d.

I would suggest getting a brand new 80 wire UDMA IDE cable.