DMA Enabling - How do I do this?

Hi I have a Sony CD-RW CRX160S SCSI Cd-Rom Cd-Burner etc. running on a Supermicro Server Motherboard… with Dual P3-1GIG’s.

Anyway, I have had the Buffer_Underrun (as mentioned in precious post’s) problems when I copy cd’s.

I use NeroBurn 5.5.10.7 Burning Software.

I have seen previous posts saying that maybe turning on DMA for all CD-Rom devices will fix the problem. At the moment I have a print out of Nero Report, after this error occurs, and it says that none of the CD-Rom device DMA’s are turned ON. They just have a ‘?’ (question mark) there.

How do I turn DMA ‘ON’ ??

Windows 2000 5.0
IA32
WinAspi: -
ahead WinASPI: File ‘C:\Program Files\ahead\Nero\Wnaspi32.dll’: Ver=2.0.1.50, size=131072 bytes, created 25/06/2002 4:34:54 p.m.
Nero Version: 5.5.10.7
Recorder: <SONY CD-RW CRX160S> Version: 1.0a - HA 4 TA 1 - 5.5.10.7
Adapter driver: <adpu160m> HA 4
Drive buffer : 4096kB
Bus Type : default (0) -> SCSI, detected: SCSI
CD-ROM: <SONY CDU5211> Version: YYS2 - HA 1 TA 0 - 5.5.10.7
Adapter driver: <atapi> HA 1
Bus Type : default (0) -> ATAPI, detected: ATAPI

=== Scsi-Device-Map ===
CdRomPeripheral : V386 STEALTH DVD 1.0h Stealth Port 0 ID 0 DMA: ?
CdRomPeripheral : V386 STEALTH DVD 1.0h Stealth Port 0 ID 1 DMA: ?
CdRomPeripheral : SONY CDU5211 atapi Port 1 ID 0 DMA: Off
DiskPeripheral : IBM DDYS-T36950N S96H adpu160m Port 3 ID 0 DMA: ?
CdRomPeripheral : PIONEER DVD-ROM DVD-305 1.00 adpu160m Port 4 ID 0 DMA: ?
CdRomPeripheral : SONY CD-RW CRX160S 1.0a adpu160m Port 4 ID 1 DMA: ?

AutoRun : 0
Excluded drive IDs:
CmdQueuing : 1
CmdNotification: 2
WriteBufferSize: 83886080 (0) Byte
ShowDrvBufStat : 0
EraseSpeed : 0
BUFE : 0
Physical memory : 1023MB (1048044kB)
Free physical memory: 752MB (770264kB)
Memory in use : 26 %
Uncached PFiles: 0x0
Use Static Write Speed Table: 0
Use Inquiry : 1
Global Bus Type: default (0)
Check supported media : Enabled (1)
Wizard: Off

12.5.2003
CD Copy

8:14:16 p.m. #41 MMC -1013 File Writer.cpp, Line 331
Buffer underrun

8:14:16 p.m. #42 Text 0 File ThreadedTransfer.cpp, Line 219
all writers idle, stopping conversion

8:14:16 p.m. #43 Text 0 File ThreadedTransfer.cpp, Line 213
conversion idle, stopping reader

8:14:16 p.m. #44 Phase 34 File dlgbrnst.cpp, Line 1653
Simulation failed at 8x (1,200 KB/s)

8:14:16 p.m. #45 Text 0 File Scsicmd.cpp, Line 406
SCSI not using temporary buffers
20 out of 20 temporary buffers allocated

My computer, right click> manage,device manager>ide/atapi controllers,open and find controller the drive(s) are on, open and go to advanced settings.:slight_smile:

I am running Windows2000 Proffessional.

I right click My Computer, and go to IDE ATA/ATAPI controllers and find a Primary Secoundary and Standard Dual Channel PCI IDE Controller. My Sony-52x CDROM is running off my Primary IDE Channel but my PIONEER DVD-ROM 305 SCSI CDROM AND SONY CD-RW CRX160S SCSI CDROM are both running off my Adaptec AIC-7899 Ultra160/m PCI SCSI Controller.

When I go to SCSI & RAID Controllers in my Device Manager, there is no option in the Properties, which allow me to Enable DMA.

I have a Silicone Image pci contoller that my hdds are running on. My software has a controll panel that my DMA settings can be accessed through. Yours ?

I have no clue how or where to access my DMA.

Upon going into properties of my Primary Controller and Secoundary Controller, there IS in actual fact ‘advanced settings’ section. Which looks like something as below:

IDE ATA/ATAPI controllers

‘Primary Controller’
Advanced Settings Tab:

Device 0: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - PIO Mode

Device 1: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - Not Applicable

‘Secoundary Controller’
Advanced Settings Tab:

Device 0: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - Not Applicable

Device 1: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - Not Applicable

looks like you found it:

IDE ATA/ATAPI controllers

‘Primary Controller’
Advanced Settings Tab:

Device 0: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - PIO Mode

Device 1: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - Not Applicable

‘Secoundary Controller’
Advanced Settings Tab:

Device 0: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - Not Applicable

Device 1: Device Type - Auto Detect (Set) OR None
Transfer Mode - DMA If Available (Set) OR PIO Only
Current Transfer Mode - Not Applicable

you can set dma its right there.

Check your bios. Set all the devices(primary/secondary master/slave) to Auto.

i believe some users have deleted the drive from device manager, which makes windows autodetect it on reboot, and enables dma…but im not 100 % on this. have you searched the forum at all?

I actually don’t know where to enable DMA in this section. I’ve looked everywhere and cannot find this.

Is it not already enabled, by the information I’ve type out?
enabled = (Set)

From your IDE devices description it is clear that Windows cannot run this drive in DMA mode although its trying to do so. Try the following:

  1. Reset the ‘Use DMA if available’ mode. Set to PIO mode, reboot and then set it to ‘Use DMA if available’ mode and reboot.

  2. If 1 doesnt work, check your drive jumpers. An incorrect jumper can cause this problem. Open the case, check the master-slave settings and set the jumper correctly. It should be set to Master since its the only drive on that channel.

i have the same problem !!!
it’s possible for the drivers?

First off a nice guide on Enabling/ Checking DMA written by some lovely chap.

Second if you have Intel Application Accelerator installed then DMA options may not be seen as shown in the guide. These can be found under the IAA application software. I see that you did find them.

Sometimes by uninstalling the IDE controllers and resetting. This forces Windows to reinstall them which can fix many problems.

nVidia IDE drivers installed?

Probably more but I think they have been covered.

Hi I have a Sony CD-RW CRX160S SCSI Cd-Rom Cd-Burner etc. running on a Supermicro Server Motherboard… with Dual P3-1GIG’s.

If I’m not mistaken SCSI doesn’t have PIO-mode at all.
//Danne

Hi

I’m new to this forum and am currently working an a family history of slide shows to be burned to DVD.

This thread interested me, and I have tried to enable DMA on my CD-RW drive
without success.

I have my main HDD on IDE 1 Master, my DVDRAM as IED 2 Master and my CD-RW as IED 2 Slave. My two ATA connections are configured as IDE 3 with another HDD as Master and IDE 4 (unused).

I have DMA enabled for the DVDRAM but cannot enable it for the CD-RW. Despite doing all the actions suggested in this thread, it keeps reappearing as PIO mode. Might this be due to the fact that it is the secondary device on this IDE channel? Or is there some other explanation?

I might add that both units appear to work fine.

Eric :confused:

What is your CDRW make and mdoel. Some older devices were PIO only.

i have a old pc p3 600 bus sis 5513

Womble i saw http://club.cdfreaks.com/showthread.php?t=101616

but in windows98se my dma works perfectly and i have a transfer of 18mb/s
with w2k 2mb …