DMA enabling for 4163B

vbimport

#1

Hi, Im new to this forum. The forum helped me greatly when i was facing problems with buffering in nero, and now i hope someone can help me with the problem i’m facing.

I actually have no problems burning dvds, though there’re occasional coasters, but i want a much better speed than what my dvd burner is offering now - 2x. As i was searching on the internet i found many articles stating the importance of DMA in increasing speeds. I then went to check my DMA settings in System -> Device Manager. I realised that my “Current Transfer Mode” was indeed the dreaded PIO mode.

I then went to change it to DMA hoping it’ll work. Unfortunately it didnt. So i looked around for an answer and found one tried and tested formula, which was the reinstalling of the IDE channel. I then went to do it, but it did not work. Then i tried the registry fix (the checksumid thingy) but it also did not harbour any results. I’ve upgraded my firmware to A104 and my dvd burner is the secondary master drive. Following advice i tried to update my motherboard’s driver, but gigabyte (the motherboard’s manufacturer) did not provide any driver for IDE ATA controllers (FYI my motherboard’s model number is GA-8IK1100). I’m running Windows XP.

I’m really at a loss now, since there’re no more articles offering further advice on this. Would really appreciate any help on this matter. Thanks.


#2

device manager configuration isnt the only factor affecting dma
bios configuration & chipset driver also matters,if drive/ide channel is configured to pio in the bios no windows settings will help so have a look in the bios ,if you dont know extactly where to look then get the motherboard pdf manual from the motherboard manufacturer website,also get latest chipset driver

is the drive connected stand alone on the ide cable?


#3

I just downloaded the manual… My motherboard seems to be a little strange. There are no direct options to enable or disable DMA. What i can do, however, is to select a DMA channel, and i can only select the channel if some option called “Parallel Port Mode” is set to ECP. Up till now i still don’t know whether DMA can actually be enabled or not. My bios is Award Bios, and i’ve only recently flashed the bios due to some other reasons… Can’t be because it is outdated right? Or am i wrong?

Im not sure what you mean by standalone, but my dvd drive is the only drive on the secondary IDE cable. There’s no slave drive. I’ve installed the chipset driver as well. Im really quite tired after 3 hours of trying… So i may only reply to any suggestions tomorrow… Thanks for your time anyway.


#4

that configuration you found is printer port related,no it cant be because its outdated,thats extactly what i meant regardin stand alone as if its the only drive on the ide cable,i might be more helpfull if youll give me the motherboard model so ill look at its manual

edit : my bad didnt notice you alredy puted out the model name in first post
ill get on it


#5

I had a look at the motherboard manual for your motherboard and it should indeed support DMA. So yes, you should be able to turn that on. About the only drivers you probably need to install are the chipset drivers. Since you already installed that, it’s a moot point.

However, I don’t think that the burn speeds you are getting have anything to do with burning in PIO mode. I also have an LG GSA 4163B (I am guessing that is what you have from your firmware version) and even with PIO mode, successfully burned discs at 8x.

What brand/mid of blank discs are you using? Also what burning software?


#6

that dma is printer port related,anyway i checked the manual and couldnt find anything to do with drive/ide channel dma however in gigabyte motherboards there is a hidden bios and it might be there, you can get into it by pressing ctrl+f1 (dont remember if you should press it right away or after your alredy in the regular bios so try it both ways)


#7

Wow i didnt even know there was a hidden bios… Yes the DMA setting is there, but its set to auto already… The thing weird is that my hard-disk’s transfer mode is UDMA mode 5 but my dvd-burner (or secondary IDE channel, dunno which is the culprit) just can’t get the DMA setting… Im using a disc that has max speed 4x and the manufacturer is Sky, which is printed on the disc itself. If i’m not wrong its actually a cheap brand, but nero says its an AML disc. This forum also has tests for AML discs if i recall correctly, and it seems that the disc is much more reliable than expected (by me). So i’m tempted to believe that the disc actually can run at 4x. Im running Nero 6.6.0.8 by the way.

Nero accepted a burn at 4x, but it seems that the 4x burning speed is slower than the 2x burning speed, and much slower, probably because of the buffer underrun protection i guess. The drive buffer keeps shifting from 100% to 20+% and back again throughout the whole process, tho the read buffer is constantly at 98%-100%. And i ended up with failed burns, and the best result was a disc fully burnt but with data verification errors throughout.

Dunno what is wrong… My options have really run out after the BIOS thingy. Guess i’ll go play around with the cables and try to hope that the DMA thing is caused by impropoer cable plugging (not much of a chance tho).


#8

remove the ide channel the drive is on from “ide/ata atapi controllers” in device manager and restart and see if its still the same,i think 4x is slower due to pio then again it might be a firmware issue maybe it got problems with that media code you should try another brand


#9

I tried that again and still it doesn’t work. I already followed the solution that’s posted on the net about this many times already. Strange how the solution works for everyone but doesn’t work for me. But anyway i’ll keep trying with something else and see what happens. Anyway will any motherboard or drive pin settings affect DMA?


#10

Found this in some forum… Wow it seemed quite a small fix but worked like a charm…

Open registry editor. Go to “HKEY_LOCAL_MACHINE\SYSTEMS\CurrentControlSet\Control/Class{4D36E96A-E325-11CE-BFC1-08002BE10318}”
The Default Value should be “IDE ATA/ATAPI controllers”
Go to “0001” key if your device is on Primary IDE Chanel or “0002” if your device is on Secondary IDE channel
and change the MasterDeviceTimingModeAllowed or SlaveDeviceTimingModeAllowed to 0xffffffff depending if your device is master or slave, close registry editor.
Go to device manager select “IDE ATA/ATAPI controllers” and the corresponding IDE chanel go to “Advanced Settings” Tab and Set Transfer Mode to PIO and then to DMA if available again. That’s should do it.

Now i end up with multi-word DMA mode 2 or something like that. Am i supposed to get that? Or am i supposed to get some UDMA thingy? Anyway i have something quite irrelevant to ask. Why is my secondary IDE on 0001 in the registry editor and my primary IDE 0002? Is it supposed to be like that? I thought it was the other way around?


#11

multi-word dma 2 - 16.7 mb/s
udma 2 - 33.3 mb/s
and the drive does support udma2
so no that isnt good i suggest youll configure it to udma2 in the hidden bios it might help if it wont then change ide cable and see how it goes,regarding the irrelevant q ask microsoft yeah primary should be before secondary but after all microsoft are responsible to how it is on their os registry so cant answer that one


#12

Hmmm there’s a slight problem now… Everything seemed fine till i did a check with nero toolkit… It hanged the computer. So i restarted. And the old problem was back again. Reinstalling the ide cable and using the reg hack pushed it back to DMA, but nero toolkit hanged again. Actually i tried to read from the file using windows explorer. It hanged as well. I couldn’t do anything about it.

I tried another method which changed the transfer mode to UDMA 2 without touching the device manager, but strangely with nero toolkit the drive reads DMA off. Seems quite a tough problem… And no the hidden bios doesnt contain any command for turning udma 2 on…


#13

get the latest nero which is 6.6.0.15,seems your dma ‘methods’ make some problems undo em ,in the hidden bios where you said earlier is defined on “auto” you cant change that value to anything else? (it usually gets done by pressing - + or enter incase you arent aware),what do you mean by “Reinstalling the ide cable”? im not sure you understood what i meant in my previous reply i meant youll replace the ide cable and not disconnect/reconnect the current one


#14

If you’ve already installed the Intel INF drivers and flashed the BIOS to the latest, try resetting the BIOS defaults if you haven’t yet. Sometimes a BIOS update doesn’t clear the CMOS data and the data contained in the CMOS doesn’t correlate properly to the latest BIOS selections and causes weird issues. Or even better yet, buy an ASUS board instead of a Gigabyte because Gigabyte BIOS’s always lick in comparison anyway :wink:


#15

I have also seen an issue like this on Dell PC’s where if the BIOS is not set to scan the IDE port for devices, DMA will refuse to enable. If you set the BIOS to tell it that there is indeed a device connected to that port, then DMA will enable properly. Newer BIOS versions did not fix the problem, but manually forcing the BIOS to recognize that a device was connected to that IDE port did resolve the issue.


#16

Hmmm just found a permanent (hopefully) solution. At first i removed the jumper on the back of the drive, hoping to find something new. Strangely the computer marked it as a slave drive instead of a master drive. When i went to check the DMA settings, without any manipulation, the drive was already set to UDMA 2 transfer mode. I then went to put the jumper setting back to master, and the UDMA status was gone again. Now my jumper setting is on slave, and yeah the system marks it as UDMA 2. Even nero toolkit doesnt hang and gives the status as UDMA on.

I find it quite strange to know that this actually caused the event. FYI i used to plug the DVD drive to slave together with the hard-disk in the primary IDE channel, with my old CD-RW drive in the secondary channel alone. Now i sold my CD-RW and my DVD is standalone on the secondary IDE channel. Has that initial setup got anything to do with it?

I find it strange also that when the jumper is off, the comp assigns the drive to slave instead of master. Even when the jumper is on CS (i guess that’s cable select), it’s still assigned to slave. Gives me the feeling that this drive naturally IS supposed to be a slave. Does being a slave affect its performance anyhow? Thanks for everybody’s help, especially phil anyway :slight_smile:


#17

Welcome to CDFreaks. :slight_smile: Just Windows driver problems perhaps. I encounter some DMA-related problems on this PC as well related to either the onboard ICH4 or PCI Aralion controller chipset. A few weeks ago, this machine couldn’t play something on DVD disks connected to the PCI PATA card properly. Now no problem (installed again after clean Windows installation.) The ICH4 also reports no DMA problem.

The drive is supposed to run as Master if there’s only one drive per channel according to LG’s official recommendation. I can’t remember if I ever installed a DVD writer without a jumper. I haven’t ever experienced any performance lagging due to slave/master selection. Just to save a few seconds, I usually don’t change jumper settings either for HDDs or ODDs whether the previous setting is master or slave (this PC right now has 18 ch. of USB + SATA + PATA, total able to accept up to 20 PATA ODDs and 8 SATA HDDs at once.)


#18

Which connector on the secondary IDE cable did you plug your 4163B? A typical IDE cable looks like this :

||=======||====||
||=======||====||
M…A…B

Connector M is plugged into your motherboard’s secondary IDE port. Is the drive connected to the middle connector A or the end connector B? There is a chance that if you connected it at A, it might think it is always slave. I have never seen this before, but you never know. If you did indeed connect it to A, switching it to B might let you run it as master.


#19

I tried both ways… Still was slave… Hmmm actually it does not really matter whether its slave or master right? Some article i read says tat slave does not actually mean like it is inferior to the master… Its just a way of numbering devices… Is that so?

Anyway jus another small unrelated question. If i have an older cd-rw device, and i plug it with the computer, will its speed affect the speed of the other drive in the same ide channel? If for example it runs in multi-word DMA 2 or maybe even just PIO, will it affect my dvd burner if they are in the same channel? And can i do a disc to disc copy successfully using one drive as source and another as destination?

Anyway my burner can finally burn discs rated 4x with speed 4x :slight_smile:


#20

Hooking the 4163B up with a CD-RW should not affect the speed of your burner I think. You can do a disk to disk using the CD-RW as source and 4163B as target burner(Nero calls that on the fly burning). It is only recommend however, if the CD-RW drive reads as fast as or faster than the burner burns CDs. For example, if your CD-RW reads CDs at 52x (the 4163B burns at max 40x for CDs), then it should be ok. If your CD-RW drive reads slower than 40x, the burner run out of data to burn and will have to constantly wait for the CD-RW to read more data. That slows down the whole burn process.

Oh and as for why your system recognises the drive only as slave, one of your posts sort of gives a hint I think :

I’m guessing Windows has gotten a bit confused somewhere. Typically formatting and reinstalling Windows should fix that, but don’t bother because the drive seems to work fine now and it’s really not worth the effort. It’s something to keep in mind if you ever need to reinstall windows on the thing in the future.