Display too "bright" problem

Not CD related, but I’m sure someone on the forum will know what I’m talking about.

Have had an issue with Jedi Knight 2 game for a while where if I alt tab out of it windoze appears to be “bleached” - everything is ultra bright with the colours present but faded. If the computer crashed while in the game requiring reboot, windows would then display these wrong colours / brightness until you went into the game and exited properly.

Recently it has started to do this with Diablo2 as well, and now it won’t go away. The colours in the two games are fine, as they are in lots of other games (warcraft3, unreal, half life) but when I get back into windows the colours don’t go back to being right. It’s a real pain on the eyes.:frowning:
Everything else functions fine, it’s just the display.

Colours and display all normal and fine if I switch to 256 colours.

My question:
Does this sound like a video card problem or a monitor problem?
Currently don’t have 2nd PC to test switch stuff around.

Win 98
s3 savage 2000
Taxan multivision 875+ monitor

Thanks for any suggestions!

fairly sure it’s not a hardware problem, same thing has happened to me before with several games, to reset the screen I just go into the screen settings and it resets itself…

I never worked with such a video card, but you might want to take a look at the drivers of the card, as quite some cards have all kinds of brightness/gamma settings that can be controlled from drivers. Sometimes, these values can be changed any way you want (in games, desktop use etc)…

Lots of games raise the gamma(brightness) value automatically so you can see the game in question especially with 3D games that have dark graphics.

When you exit the game the value is not reset the windows default sounds like it could be a driver error.

The S3 savage 2000 is no longer supported and S3 has pretty much exited the 3D buisness.

Your best bet is to try Savagenews a site that was/is a S3 fan site and has a catalog of drivers for most S3 products.
Savage News
Savage News Driver Section

Hope that helps.

Thanks guys for your helpful comments.
Yes rocky gamma is the best way to describe it but I have now got rid of the problem by getting a spanking new driver from savagenews, which I didn’t previously know about. :bow: :bow: :bow: :bow:

Funny, having the display all wrong except in games has been a sort of mental excuse for three days to do no email/ work, just play games. Now I have to go catch up.:frowning:

I had this card for my sister. Finally found drivers for it that worked well in XP. Leave me an e-mail and I can send them to you. They are 3rd party drivers but I have had much success with them. Let me know. See how well the new drivers you have now work.

This is a directx problem. It’s quite common that when you use a 3d application and “alt-tab” to the desktop , that it goes horribly wrong.

What usually works is starting another 3d application that will reset/re-initialize the directx settings.

I have this all the time when playing unstable mods in Quake III Arena.

Thanks for more comments. It is working fine now with new drivers. Should I feel ashamed to use the same video card as xtacydema’s sister?
Thanks for the elucidation on the directx cause Mr Belvedere.

If you run games windowed, does this impact on performance and could it solve the gamma bleaching issue? Alt tabbing out is quite a common thing in a lot of games.

Does anyone know of applications to use Direct x to set gamma in windoze?

I had this problem before when a game crashed. You can goto nvidias colour correction in display properties and it will make it go right.

lucky you! i had the same problem but the other way around. lol. my screen was so dang dark and i had to use a program + drivers + game settings just to get it around normal brightness!! :stuck_out_tongue: