Disk Speed problem with Taiyo Yuden DVD+R 8X and Pioneer DVR-108

I have a pioneer DVR-108 running 1.20 official Pioneer firmware. I just received some Taiyo Yuden (JVC) 8X DVD+R white hub printable disks (j-DPR-WPP-SK8). I looked at Disk info with Opti Drive Control and Nero 9 tools and they reported a Disc Speed of only 4x with no other options. I placed another disk in and it showed Disc Speeds of 16X, 12X, 8X, 6X, 4X. I check a few more and they also show the 16X-4X range of speeds. Then I place the first disk that showed only 4X back in and it now shows all of the speeds from 16X-4X. Then another disk from the middle of the 100 pack will show only 4X. I never had this issue with other media (Ty Valye line and Verbatim 8X DVD-r Data Life Plus). I have a Asus DRW-24B1st firmware 1.04 that consistently show 8X 6X for every disk so I don’t think it’s the disks.
I did have a problem with the Pioneer drive and Imgburn just before this happened. I was burning a Verbatim 16X DVD+R AZO disk and I wanted to try bit setting on my Asus with Imgburn. However I mistakenly had the disk in the Pioneer drive and went to change book type in imgburn. I tried the differnt manufacture tabs and the BenQ tab caused the drive to spin and eventually hang. I could not exit imgburn or end the process. Even when I tried to shutdown the drive kept spinning and Win 7 x64 would not shut down. Eventually I got tired of waiting and did a hard reset. Could this have screwed up my drive? Sorry for the long post but any help is appreciated.
It seems if a disk shows as 4X only in the Pioneer then I put it in the Asus for disk info, when I return that disk to the Pioneer it now shows all the speeds. I want to use the Pioneer drive and the Ty DVD+R disk to burn archival backups at 8X. I’m going to burn a disk and will post the scans, but I’m nervous about my archives now.
What do you think is causing this? Is there a way to check the health of my Pioneer 108 drive?
Thanks.

Here are scans from the Ty DVD+R (YUEDEN000 T02) at 8x. This is the disk that showed initially as only 4X then when inserted later showed 16X-4X speeds. I accidently scanned with the Pioneer first so I threw that one up as well.




Well now even if Image burn or nero show that the 8x disk speed is available and I select it, the disk only burns at 4x. I re-flashed the DVR-108 firmware but is solved nothing. Something is wrong though. The YUEDEN000 T02 are 8X +R disks. The available write speeds come up as 16x, 12x, 8x, 4x. But the Pioneer website states that the TY 16x media has a max write speed of 12x so there is no way the 8x media should be showing a 16x write option. I feel that either:

  1. I got a bad batch of disks - though they burn fine at 8x in my Asus DRW-24B1st (only available speeds 6x, 8x which I think is normal)
  2. The firmware is not handling the media correctly - though it seems that othesr with this drive have not had problems with this media when I did a search.
  3. The drive is not working correctly - though it is fine with the TY value line -r and Verbatim +r 16x media I use.

I guess I will just burn my backups with the 24b1st at 8x. Should I be wary of the media? Is it time to retire my beloved DVR-108?

What do you guys think?

It is quite possible that the drive is worn out and/or dirty. I believe I have read of others’ Pioneer drives doing similar things as they begin to age with no resolution.

True, its related to heavy usage and overheating at some stage.