Disc Recognition Problem

vbimport

#1

Hi everyone,

I have a dvd +/- dl rw in my laptop that’s only about 2 months old, but is acting up. (More specifically it’s a HL-DT-ST DVDRAM GSA-4084N from HP) Whenever I put a blank dvd (+r) in the drive Windows sees it as a cd. I attempted to solve this problem with the troubleshooting guide on these forums but had no success. I also tried using several different types of disks: Phillips, TDK, and Memorex. Everything was working fine until a couple weeks ago. Does anyone have any idea how I can make the drive recognize dvd’s again? I attached a full Nero InfoTool reading (done with a bland dvd+r in the drive).


#2

Have you actually tried burning one of the problem DVD+R discs using a burning application such as Nero or DVD Decrypter?

If you got an error message with one of these burning applications when attempting to burn then you need to post it here. Only then can I make a more informed diagnosis.

The only thing I can say for sure at the moment is that older versions of Windows XP can sometimes show a DVD Rewriter drive as a CD drive. This is a bug. Your drive my still be working as it should.

According to your Infotool attachment, your blank DVD+R is recognised as a blank DVD+R. Like I said, just try burning a DVD using one of the burning applications I named above.

If you encounter an error message then post it here.


#3

I tried and there was no error message. The problem is no application will burn more than 700MB to the dvd. All applications (and Windows) show the dvd as a cd and treat it as one. When there is no disc in the drive Windows does show it as a DVD-RAM, the problems start when I try to use any dvd.


#4

I think that you should maybe try to see if your drive can still read DVDs ok.

Does your drive read and playback original DVDs? How about DVD Video backups - they might also be worth trying.


#5

An original dvd read fine. A backup dvd +rw read fine. A previously burned data dvd +r read fine. I guess something must specifically be wrong with the burning interface which causes only a cd’s worth of data to be burned to any dvd. I tried using several programs. I even tried using InfraRecorder and setting the option to ignore medium capacity. I noticed when a blank dvd is inserted the disc isn’t just recognized as a cd, the whole drive is recognized as a cd drive rather than a dvd-ram.


#6

I’m thinking it’s a firmware problem now. The only other alternative is that maybe it could be an ATA/IDE controller problem but I doubt that this could be the problem as the drive still works with other types of discs.

If your drive can read and playback original DVDs and DVD Video backups fine but can’t recognise blank DVDs, then I’d definitely say that this is classic ‘firmware-acting-up’ behaviour.

I’m saying this based on problems that I had when atempting to read a specfic type of DVD-RW disc. Couldn’t read that disc until I upgraded the firmware.

So, upgrading or re-installing your firmware might be the best thing to do at the moment. I can post instructions on how to do this if you’ve never installed firmware for an optical device before.


#7

I’ve flashed new firmware once before (a long time ago). I searched though and there are no firmware releases for my drive. I couldn’t find a tutorial on how to reinstall my existing firmware either. If you could post the instructions that would be great.


#8

Hi and Welcome!

So you can’t write data onto DVD media using Nero?

I noticed when a blank dvd is inserted the disc isn’t just recognized as a cd, the whole drive is recognized as a cd drive rather than a dvd-ram.
This seems to be a flaw in Windows Explorer, nothing to be worried about. Also, Windows integrated burning module only supports CD media.

Michael

P.S.: Going back to earlier firmware is easy with LG drives. Just run the firmware flasher of the old version - if you have it.


#9

Actually, I’ve never carried out a fresh firmware install on a laptop DVD/CD drive.

I [I]do[/I] know that as ageneral rule, you have to have your drive set as Master and you should run the firmware flasher in Windows Safe Mode to ensure that the flasher doesn’t encounter any problems.

But I’m not sure how the jumper settings work on a laptop CD/DVD drive.

You should follow mciahel’s advice. Try downloading an older firmware version for you drive.

mciahel, how does flashing firmware for laptop CD/DVD drives work? Is there a setting for Secondary and Master? Or is this set automatically? :confused:


#10

This problem is discussed in many threads.
My advice, try opening your computer with a clean DOS disk, floppy or 256mb flash drives. (1gb drives are not recognized by bioses so as to boot)
Than, get an OAKCDROM.SYS file, an MSCDEX.EXE file.
Edit a Config.sys file. Write the line:
DEVICE=OAKCDROM.SYS

Than, after your comp. boots, look at the lines where your drive is recognized.
Than write the line:
MSCDEX /d:12345678 /l:f
that 12345678 is the name given to your drive by OAKCDROM.SYS. May be different.
You can get that label at the boot, where your drive is recognized.

Than, try your DVD-R’s. I bet you’ll see all of them cleanly.
But won’t be able to copy, because DOS can’t see 2+ GB HDD Drives…

If you can see your disk that way, carry the subject to my post.
Because it is about Windows not recognizing DVD-R’s. Not the computer or drive…