Disc drive not accessible (and USB ports) - Windows VISTA

Hey guys

I’ve just signed up to this forum because I have a really urgent problem with my laptop…I am [u]VERY VERY VERY VERY[/u] sorry if this thread is on the wrong place or has already been discussed or whatever lol…

(Also, I’m no good at all this clever computer stuff)


I’m having a problem with my disc drive and my USB ports. Everytime I put a disc into my disc drive, the computer reads it and knows there’s a disc inside but doesn’t play it…not even CD’s, DVD’s, CD-ROM’s nothing!

And with my USB ports, when I try to open the file on AutoPlay it says “F:/ is not accessible. Access is denied” yet it can recognise what the USB is connected to (ie my iPod)…This is also the same with my memory stick slot.

I go into “My Computer” and there is a red cross through the CD Drive icon.

My computer gets scanned every day and 2 weeks ago a trojan horse was found and distroyed…could this be the course?

Is there a way to fix it or will I just have to reformat my laptop?

Thanks guys!! If you need anymore information, please let me know and I’ll try to tell you.

Thanks again :slight_smile:

Go into Devise Manager and uninstall the drives in question and reboot the computer and let Windows reinstall them and if that does not work check to see if you have a conflict with resources.

problem solved!

it was all down to acer’s e-locker

damn you shakes fist

Hi DarkHorseKing,
I have exactly the same problem that you experienced with your computer.
Mine was even returned to Acer, and sure enough, they didn’t fix that problem either.

Please let me know what exactly you did with the Acer e-locker, so I can try if this works on my machine too.

Many thanks for your help :slight_smile:

Hello dear Acer eLock co-victims!

I have been fighting with this problem for 3 days and nights - even re-installed vista on my existing vista installation (no help)

The problem is Acer’s !!! utility !!! Acer eLock Management!

I have never had this damned eLock management installed, but after reading this thread I installed the utility.

Running the utility and changing the locking options solved the problem! None of the drive type options was locked in the first place but just changing the locking status to locked and back to unlocked did the trick!

You can download the eLock Management utility from here http://support.acer-euro.com/drivers/downloads.html

I have Acer Travelmate 8200

Seppo RK

Hi guys

I had the same problem of getting this ‘File not Accessible … Access Denied’ message.

Just found the solution in my case and its really a simple one too. If your USB device is installed and you can’t just access it, follow this thread as it turns out to be a security/permission issue.

It worked well for me and hopefully works for you.


Good Luck

@ Seppork, u nailed it!
I completely forgot that i played around the e-lock utility tool n shut my cd rom down cos i had a cd i didn’t want jumping into my face each time i restart.
Thanks a bunch man. :iagree: