Disable USB autostart in Windows XP / 2000

vbimport

#1

Hi!

When I connect my external USB 2.0 HDD, Windows has an autorun option enabled and opens Windows or starts software.

Do you know how to disable this option for USB devices?


#2

You can try this, but it also disables the autoplay for CD and DVD drives:

Start -> Run -> gpedit.msc

Go to “Administrative Templates” -> “System”. Next, doubleclick “Turn off Autoplay”, check “Enabled” and select “All drives”.


#3

If you hold the shift key down the software in any CD/DVD drive won’t attempt to start. If you insert an external drive don’t you want it to be recognized?