Disable Auto Scan in DVDfab Plat?

vbimport

#1

Is it possible to disable the auto scan feature in DVDfab? I have USB “magicjack” which installs itself as a drive and requires autoplay. Every time I launch DVDfab it finds magicjack and thinks it’s a source. Basically it makes DVDfab impossible to use. Any tips appreciated.


#2

Does this thing look like a disc drive (Mass Storage Device) in My Computer? Does it have a drive letter?


#3

Some memory sticks have a dvd emulator or something on them to be more user friendly, my cruzers have that. I would just hit cancel when it pops up and then select the correct source.


#4

I have USB “magicjack” which installs itself as a drive and requires autoplay. Every time I launch DVDfab it finds magicjack and thinks it’s a source. Basically it makes DVDfab impossible to use.

now this i am very interested in knowing the solution. i am thinking about ordering a magicjack myself.


#5

The quick solution would be to unplug it before starting DVDFab. This kind of multi-tasking is probably not a good idea when ripping, burning or converting anyway. I guess Fengtao could add an “Ignore Source” checkbox with a dropdown to select the drive letter where this thing has attached itself. Probably not likely unless a lot of users start asking for it. I don’t understand why it needs a drive letter–Skype doesn’t. It may also be claiming a big allocation of the available USB bandwidth, which would not go well external optical/hard drives.


#6

Thanks for the replies so far! Yes, magicjack is similar to Skype in that it is a voip app. But unlike Skype, magic jack uses a USB hadware interface. It looks something like a flash drive but has a USB port and and RJ11 port which allows the user to connect any type of corded or cordless telephone. Also unlike Skype, it is not software based. When you plug it in, the device configures itself (and might download a few files as needed) and voila, instant incoming and outgoing voip complete with a local telephone number.

It uses 2 drive letters, one of which has no effect on DVDfab. The other contains autorun.ini and autorun.exe so basically the device reinstalls itself each time the user reboots. For whatever reason, when DVDfab is launched it locks on the magicjack “drive” and will not unlock no matter how many times you attempt to cancel the “no disc” error message. Until now, my only solution was to either unplug magicjack prior to launching DVDfab or manually configure magicjack as a Windows service (which is a somewhat tedious hack).

Anyway, after posting my original question I discovered what seems to be a workable solution. I installed the free Microsoft “Tweak UI” utility. Using the utility’s file tree, I went to My Computer > AutoPlay > Drives, and deselected the offending magicjack drive in the checklist. So far magicjack and DVDfab seem to be coexisting in peace and both are fully functional. Overall, I think the ability to disable auto scan would be add good functionality to DVDfab but as someone pointed out, the developer isn’t likely to implement it unless more complaints appear. If I run into any further unexpected problems (or find additional solutions) I’ll post them here since the info might benefit others.


#7

Just a thought: look at the magicjack drives with devfilter.exe and see what registry filters are installed. If you delete all of them except the one(s) it installed, DVDFab might not see it as a Source. Seems to me it would be better if it looked like some kind of streaming device rather than a DVD drive. Maybe a good question to ask the inventor or his daughter. :slight_smile:


#8

[QUOTE=troy512;2117190]now this i am very interested in knowing the solution. i am thinking about ordering a magicjack myself.[/QUOTE]off topic:

I had a Magicjack months ago. I got a refund. The problem i had with it i could not get a local number which meant everyone in town (my doctor,wifes doctor,wifes mother,friends, etc…) would have to call me long distance. Be great for someone that is out of town all the time or for someone overseas from USA.

If and when they can give me a local number then i’ll get another one or two.


#9

If anyone is taking votes, I’ve purchased a MagicJack and it’s working very well until I start DVDFab. Then it’s a worthless piece of @#$% because it constantly loses connection. When I close DVDFab, it’s back to being a wonderful money saving solution to MaBell. I’m raising my hand for the “Don’t scan these drives” check box(es). For now, I’ll give a try to the solution mentioned above with the “Tweak UI” option.


#10

Well, I just gave it a try and it still happens. The way I test it is with MagicJack in and working, by checking dialtone, I start DVDFab. Now the dialtone keeps cutting out like it has the studders. As soon as I shutdown DVDFab, dialtone is back to steady and constant. This is with Autorun turned off for both drive letters associated with MagicJack. <heavy sigh>


#11

[QUOTE=bobw56;2268179]Well, I just gave it a try and it still happens. The way I test it is with MagicJack in and working, by checking dialtone, I start DVDFab. Now the dialtone keeps cutting out like it has the studders. As soon as I shutdown DVDFab, dialtone is back to steady and constant. This is with Autorun turned off for both drive letters associated with MagicJack. <heavy sigh>[/QUOTE]This is not a DVDFab problem, it is a conflict between the magicJack driver and windows SPTI. ImgBurn has the same effect if you have it set for SPTI I/O control. A workaround (at least with XP) is to put DVDFab in the ASPI I/O mode (which may have problems of its own).


#12

bobw56
You have a PM([B]P[/B]rivate [B]M[/B]essage) with a possible fix :smiley:


#13

Maybe your apparently secret fix could benefit other users too.


#14

[QUOTE=StormJumper;2268311]bobw56
You have a PM([B]P[/B]rivate [B]M[/B]essage) with a possible fix :D[/QUOTE]

I’d definitely be interested in the details of your solution :slight_smile:


#15

Thanks StormJumper.

He suggested changing the Network setting to manual proxy. Not sure if that’s going to help but figured I’d give it a go. The eariler comment, however, that the problem is with the MagicJack driver and Windows SPTI seems to be spot on. The workaround is to switch DVDFab from Automatic to ASPI I/O mode and so far, that seems to be working. I’m getting a solid, steady dial tone, now, while I’m running DVDFab V6.0.0.2.


#16

>> [I]The workaround is to switch DVDFab from Automatic to ASPI I/O mode and so far, that seems to be working…
[/I][COLOR=Black]
Makes sense. Thanks for the update :)[/COLOR]


#17

Glad this worked for my fellow magicJack users.


#18

just started looking into Magic Jack.

[B]If your magicJack service is not available:[/B]
Click here and save this upgrade to your desktop. Once the download has completed, double click the upgrade icon on your desktop.[U]
[/U][I][B]If that does not work:[/B][/I]

Please disable any antivirus that may be running on your system and try again.
If you are behind a network/external firewall or router, please open port 5060-5070 UDP. Also make sure that the firewall on your router is disabled.

Disable my firewall on my router, I don’t think that would be a sound practice.


#19

[QUOTE=snagel;2288468]just started looking into Magic Jack.

[B]If your magicJack service is not available:[/B]
Click here and save this upgrade to your desktop. Once the download has completed, double click the upgrade icon on your desktop.[U]
[/U][I][B]If that does not work:[/B][/I]

Please disable any antivirus that may be running on your system and try again.
If you are behind a network/external firewall or router, please open port 5060-5070 UDP. Also make sure that the firewall on your router is disabled.

Disable my firewall on my router, I don’t think that would be a sound practice.[/QUOTE]

You posted this here then you turn around and start a thread with this very same statement :doh: have you not read the forum rules about crossposting :frowning:


#20

Sorry for the crossposting. Because of the concern of the disabling the firewall and the this one about disabling auto run I thought maybe alot of people would not see the this one. And maybe it really don’t belong in the DVDFab area but rather general computing area.