Did Herries Ritek DL firmware RUIN my 2510

vbimport

#1

For three months my NEC 2510 worked fine burning both CD-Rs and Hundreds of DVD-Rs.

I upgraded to Herries Ritek DL firmware and it still worked fine for about a month after, then I noticed each and every DVD-R burn fails within 2 seconds without writing with a POWER CALIBERATION error - CD-Rs and DVD RWs seem to burn fine though.

This is very weird, can anyone help? Is herries firmware to blame. Because I flashed my drive with it I dont have a leg to stand on do I should I need to return my drive to the supplier.

PLEASE HELP!


#2

As I see it, the firmware has not ruined the drive. Probably, this is a normal failure after you used your drive intensely. Flash the original firmware and send the drive in for repair.


#3

The drive is NEW - Less than 4 months old. my other drive (a pioneer 106) continues to work perfectly and thats years old!


#4

every DVD-R burn fails within 2 seconds without writing with a POWER CALIBERATION error - CD-Rs and DVD RWs seem to burn fine though.

i had this problem with my liteon 411s, it turned out to be the media i was using… have you tried different media? as well as +R?


#5

as i said - cd-rs work. cd-rws work, dvd-rws work but dvd-rs of any brand dont work. i use ritek dye discs only


#6

as i said - cd-rs work. cd-rws work, dvd-rws work but dvd-rs of any brand dont work. i use ritek dye discs only

However I upgraded to the original Firmware - Still gave same power caliberaion problems. Now when I try to burn 4x on a 4x disc, I get problems, but when I burn at say 2x or 1x it works.

Any suggestions?


#7

#8

Yeh I checked my IDE connection - checked if DMA was enabled. Swapped power cables and tried again, still the same.

Im not happy about this as its a new drive. (Bought in early July)

Anyone got any suggestions?


#9

Not a good comparison only trying dvd’s with ritek dye… they all could be crap try some other brands and see if it works…


#10
  1. Those firmwares aren’t official and there’s no warranty. You chose at your risk to use it, so there’s no one to blame.
  2. There’s someone to thank for his hard work and for bringing us excellent firmwares.
  3. I don’t think a firmware could ruin your drive. btw this sounds weird. May be it’s only a bad batch. Are the not working discs from the same batch? Did you try another?

#11

sorry let me clarify
I simply said this situation was frustrating and dint make sense, I was not putting down the work of the writer of the firmware.

Secondly, I bought a spindle of 100 rikek dvds and while my burner was working i must have used 60 sucessfully at 4x. now none work, i even tried some leftover frm another older spindle 1x only, different brand but still gives power caliberation error.

this makes no sense


#12

Try cleaning the lens.


#13

i bought the thing only in july and it needs cleaning???

how do i clean it?


#14

Hello. I don’t think that this problem needs laser lens cleaning. The recorder writes DVD+R/RWs and CD-R/RW’s as mentioned before. If the laser lens were dirty then the recorder should have had problems with DVD+Rs too. The drive is brand new. I think the problem has to do with the writing strategy used in Herrie’s Ritek DL firmware for DVD-Rs combined with this specific ND-2510 drive. What i can’t understand is how the drive worked well for a month and then failed.

Possibility 1:
This problem happens with a small number of recorders after many-many burns in a row without letting the drive rest for a while. Temperature increases during burns and may harm servomechanisms inside the unit. Also, bad ventilation inside your PC case can cause laser lens failure in some drives.

Possibility 2:
This could also be a lens alignment problem. Wrong insertion of a disc or violent vibrations or shocks from outside factors may cause laser lens misalignment and this requires drive replacement or service from a specialised NEC service.

Possibility 3:
Not all NEC drives are the same. For example, some ND-2500 drives write DL discs perfectly, while other ND-2500 produce coasters or discs with a lot of PI/PIF errors. This is due to different electronic components used during production from drive to drive. Maybe your ND-2510 doesn’t work with Herrie’s Ritek DL firmware. My ND-2500 works perfectly with the same Ritek DL firmware.

Recommended actions:
(1). Use a cleaning disc WITHOUT the special liquid (the liquid destroys the organic surface of some plastic laser lens used in many recorders). This action is to eliminate the possibility of dirt on the laser lens. But i am 99.9% certain that this isn’t the real cause of the problem.

  1. Try flashing with an original/official firmware version designed for ND-2510 and try again.

If you have news, questions or extra information about the problem, let us know. Good luck.


Now as for the misunderstanding that i noticed before in this thread, my opinion is this:

Darthbane2k, some people may misunderstand the title of this thread, about Herrie’s firmware ruining your drive, some may find it offensive and some may get the impression that you blame Herrie for your drive’s failure. I know that this wasn’t your intention but try to use different titles for your threads in order to be sure that no one misunderstands it. By the way, i know how it is to find out that after flashing your drive, it is almost ruined.

Evilhead, all of us know Herrie’s work and we thank him very much. Try not to misunderstand things said in the forum. If you were at the same situation as Darthbane2k, you would react in a very similar way as a natural person. Personally i would do a lot of damage to the drive because of my anger before i could think to ask help from people in the forum! :bigsmile:

Now let’s try to focus in the problem rather than discussing about who put the blame on who. :smiley: :smiley: :smiley: