Diagnostic tool for DVD ROM

vbimport

#1

I have one of those “generic” DVD burner with a Toshiba chip in there. I believe the model number is SD-R5272. The drive was only able to burn 4X DVD medium so I installed a Samsung firmware SH-W08A to enable it to burn 8X medium as per instruction elsewhere on this web site. It’s been working well without incident, until this past 3 days. The DVDs burned no longer works properly, and the DVD drive can’t quite read other DVDs. Some of the data burned would fail verification afterwards. But some of the video DVDs would still work ok with it. I ran Nero’s drive speed and some “unrecoverable read error” came up. I vaguely remembered there may have been a power surge this past week, but I have a surge protector on the electrical outlet.

To make a long story short, I am trying to find a tool to determine if the drive is indeed damaged behind any means to repair, before I rush out to buy another one. I already checked the software section under “diagnostic/utility”, but found no suitable software for this. Any suggestion?


#2

This tool would be not really a tool, but you’d have to connect the drive into or on another computer to test it out.
Additionally, you could try to clean the lens/drive.

What media(type) have you used?


#3

Here is what I have tried so far. I cleaned it but didn’t make any difference. It burned a couple of 4X DVD+RW and one failed data verification, HOWEVER, the same media failed on another DVD drive, so it may not be the fault of the drive. It burned some 8X DVD+R, ones with data failed verfication. But those burned with videos worked when tried on another DVD drive; it has trouble reading these video DVDs it burned, usually towards the final 1/4 of the DVD it starts to experience trouble, freezing and crashing PowerDVD. The video DVDs otherwise play ok on the other DVD drive. I also noticed when it’s burning a DVD, the speed is about 5X, but towards the end of the task it speeds up to 8X. That seems to coincide with the area that it has trouble reading.

Frankly I am not sure what it means when a DVD drive can’t quite read what it’s burned, when the end result DVD is otherwise working.


#4

If I understand correctly you used a 4x burner to burn @8x with a modded formware, isn’t it? If so, maybe you damaged the hardware.

Anyway, what media are you using? Can you post mediacode? You can find mediacode with cd-dvd speed.


#5

The drive is a 8X burner, but it could not utilize some of the newer 8X media, so someone came up with the idea of using a Samsung firmware for it. Here is the link on this:

http://club.cdfreaks.com/showthread.php?t=102201

I used DVDInfo to check the media, which says “OPTODISCTOR” for media code. On the DVD disc it prints “Samsung Pleomax”. Nero’s DVD Speed can’t read blank discs.


#6

:rolleyes:
I have not seen that media code yet. Are you sure you read everything correct?

Anyhow, your drive is aged and firmware updates for this type of drive are almost non existing. Not much that can be done if you are not able to find older 4 and 8x media.


#7

With the updated firmware, I have been able to use almost all the 8X DVD+R so far. Things have been working well, I have not done anything new. I have used Samsung Pleomax DVD+R discs for months without problems. Everything started falling apart only about 1 week ago.

As for the media code, I am not sure if I am reading them correctly to be honest. There is whole bunch of binary codes which I did not think it meant anything.


#8

I have used [B]Samsung Pleomax DVD+R[/B] discs for months without problems.

Expect to get issues soon. These are real crappy media.


#9

:iagree:

Try quality media and the drive will write @8x.