DH-20A3H Wont burn

vbimport

#1

Hi can someone help? I have a lite on DH-20A3H it hasnt been burning since it came installed on my pc, in my useless attempts to fix it i have tried to flash it with firmware from the lite-on site using the correct firmware for to my burner ( as far as i knew) the flash failed and now my burner wont open or play ball in any way,I have tried again to flash the firmware but it keeps telling me that there is “no matched drive detected” It just tells me that i have a DH-20A3H op55. So does anyone know how i can put it right?

My O.S is Vista Home premium BTW if that helps.


#2

The FlashFix utility in the last “Read First” sticky of this forum might help. Try running FlashFix on the firmware, and then flash drive with the FlashFixed firmware. Remember to have upx.exe in same folder with Flashfix.exe for FlashFix to function.


#3

Hi thanks, i tried that but flash fix didnt recognise the firmware. sorry im a real noob at this.
maybe if i fill in the back story it may help.Its a new PC i havent tried to burn anything since i got it in september, when i did try to burn something using Nero 7, about 20 seconds in it came up with the message “device error (403712) could not write to disc (LBA:0 length:26 Power on, reset or bus device reset occurred-0x062900” this happens every time i try to burn. i tried windows media player it doesnt recognise that i have a burner. i have been sent another burner by my pc supplier which gives the same result (the replacement drive is also an LG in black and my case is silver so i dont really want to keep that), which left me to assume it was software not a hardware issue so i know all my drivers are up to date so i thought i would try the firmware. I got a message after the firmware update got to 100% that it was unable to update and to contact my vendor but since then the drive tray will not eject. Entire model name on my burner is DH20A3H06C if that helps.
I am reluctant to use MtkFlash as i am worried that i may missundertand what i am doing and make this issue worse, after all the the firmware update was such a success:).
since then i have uninstalled nero as i was told that it had been known to cause some issues but this hasnt worked even with the replacement drive. so any simple/noobproof help getting my original drive working again would be helpfull or a miracle you decide.


#4

I had similar issue, flashed it with a beta firmware that made the stand alone player not to want to play the burned discs. Then tried to reflash it with latest official firmware and just got a window stating that the firmware installer was for a Lite-On DH-20A3H and that it couldn’t find such a device, despite the fact that I do have such a device.

So I installed a very old firmware and then after restarting the PC, I installed the latest official one and this time it worked.

The old one I used is this one:

http://www.webfilehost.com/?mode=viewupload&id=7056425


#5

Thanks I have tried that firmware tonight, i got the same message it said it was unable to update and to contact my vendor whatever that means.I am wondering if i am following the correct procedure or if i need to use any software as all i am doing at the moment is opening the file.


#6

Have you tried to flash the writer with the EEPROM utlity and just load the binary file and then flash it? The flasher can be found here:

http://club.cdfreaks.com/f44/eeprom-utility-liteon-sony-cd-dvd-writers-v3-8-3-a-112103/?referrerid=65105

Attached is the binary firmware ver YY11 (the latest public one).

Start the program and hit the button ‘Restore Eeprom’ and load the attached file (after you have extracted it).

ATAPI_DVD_A_DH20A3H_YY11.zip (2.43 KB)


#7

I forgot to mention FlashFix doesn’t work on newer firmwares. Try FlashFix on an older firmware from http://codeguys.rpc1.org/firmwares.html, and then retry flash with current firmware if FlashFix on older firmware works.

cynthia_old, can you tell me how to search http://www.webfilehost.com/?mode=viewupload&id=7056425 for other firmwares? How would I find firmware for LiteOn LVW-5005 recorder for example? This link shows ID number for firmware you used, but I don’t see any other way to search besides by ID number. How does one determine ID number for a particular firmware, or is there another way to search?


#8

It’s only a file sharing service.
Can only search on upload files.
Never know what to find on such places.
You can use other tools to search.
Google.
I Googled.
Found this link.
Don’t know if it is latest.
Other might have better luck to find more recent firmwares.
Here is the link.
http://www.pumapeople.com/liteon/UK-LVW5005%20(0098)%20Firmware/Drive%20update/


#9

That link is for UK firmware, and US firmwares that used to be available from pumapeople site as well as ILO site have disappeared. Even LiteOn’s site gives “Page cannot be found” message when attempt is made to download any LVW-5005 firmware. By “Can only search on upload files” do you mean one could search if one were to upload a firmware file, and what kind of search is available if that’s the case?


#10

Perhaps send a mail to Lite-On and tell them that the link on the web page is broken.


#11

Ok, being a PATA drive, I would use MKTFLash in pure dos. Get the firmware from the CodeGuys. If the drive is toast now, wont really hurt anything…


#12

MTKFlask doesn’t work with these new drives. I believe you use XSF.