Dev c++

vbimport

#1

Im having a little problem with dev c++. Installation and everything is great, but then i get this error (see below) I think it means that i have to change settings somewhere, but i am not sure where. Any help would be much appreciated.

Thanks

Ciggy


#2

this is saying that you have to change your environment variable within windows or the Bin path of Dev-c++. I dont have dev-c++(or windows) on this pc, so lemme google a little for yas.

it looks like sometimes having a space in the path to dev-c++ messes it up, so if its c:\program files\dev-c++ - that could be a problem. it also looks like sometimes the compiler is not downloaded with the program (did you get the full version?)

from http://aditsu.freeunixhost.com/dev-cpp-faq.html -

2 (some path)\2 unable to run program file
Update: this problem should be solved completely in Dev-C++ 4.9.9.2.
If you don’t want to upgrade, or somehow you still get the error in 4.9.9.2, read on.

This happens when the IDE can’t find one of the programs needed for compiling your file/project (usually it is make, gcc or g++).
The most common cause is a nasty BUG in the Dev-C++ installation system: the uninstaller doesn’t remove the Dev-C++ configuration files, and the installer doesn’t overwrite them. So if you try to install Dev-C++ in a different folder without following these instructions, you will most likely get this error for everything you try to compile.
To solve this, you can try my automatic Dev-C++ maintenance tool, and if it doesn’t help (or you prefer doing it manually) then there are two ways you can fix it:

  1. The “blind reinstall” solution: uninstall Dev-C++ cleanly (pay special attention to the devcpp.ini and devcpp.cfg files if you have Dev-C++ 4.9.x.x), then reinstall the full latest version (see top of this page) in a folder with no spaces in the path. It should work afterwards.
  2. The “smart fix” solution: read the compile log to see which program it tried to run; go to Tools - Compiler Options - Programs and see what file it is looking for and in which folder (click the “…” button) and check if it is found in that folder. If the specified file is not there, then select it from the Dev-cpp\bin folder (or wherever you installed your compiler).
    It might also help to set Tools - Compiler Options - Directories - Binaries correctly.
    Note: if you downloaded the IDE-only version (~2 MB) and you didn’t install a gcc compiler (e.g. the mingw package), then you won’t find the necessary programs; refer to solution 1.

#3

waaaaaaaaaaa… i had no idea you replied to this… cheers for that i will be giving it a go :wink:


#4

im having trouble viewing exe files… and have no idea why :sad: any ideas… i c an think of anything to be more specific than i cant view them… heres an example of what i cant run (its safe… just the hello world program)

cheers for any help

ciggy

Project1.zip (129 KB)


#5

ok then how come this works (launches)


#include <iostream.h>

main()
{
      for(;;)
    {
        cout << "Hello World! ";
    }}


however this doesnt


#include <iostream>

int main()
{
    std::cout << "Hello, world!
";
}


#6

Does #include <[B]iostream[/B]> need .h

It’s been too long since I have done this.