DEUHD doesn't work anymore after Windows 10 1709 update


#21

Timeline:

  1. DeUHD worked. Secure Boot enabled or disabled didn’t matter.
  2. Microsoft released an update for Windows 10 1709 that broke DeUHD. The driver failed signature requirements and could not be installed at the time of installation, period.
  3. Microsoft released 1803 and the problem remained.
  4. Arusoft released an update to DeUHD (1.0.2.9) that supposedly resolved the driver installation problems. This was only half true.
  5. The DeUHD driver could now be successfully installed on the system regardless of Secure Boot setting but the driver only loads at boot-time if Secure Boot is disabled. This was never previously necessary and absolutely nowhere are users informed of this; not in the changelog and not on the DeUHD website. Nowhere. Even a few weeks on. It’s a pretty significant piece of information.

Given the above timeline and how things worked the previous issues never got as far as Secure Boot being part of the problem. The driver couldn’t even be installed so Secure Boot limitations never even kicked in. Now, since the “fix” the driver can be installed but not loaded at boot-time when Secure Boot is enabled.

It’s important that people keep making other DeUHD users aware of the Secure Boot issue. Unfortunately, it would seem not many people make use of Secure Boot - which is rather problematic - but that doesn’t change the situation. It’s a limitation that simply is not being addressed enough and users are not being adequately informed about. I have yet to even see acknowledgement of the issue by Arusoft.


#22

im getting A request for the USB device descriptor failed. can someone help me plz asap