Dell Inspiron 1545 laptop - battery problem

vbimport

#1

Dell Inspiron 1545 laptop - battery problem
This laptop had not been used for several months, during which time the battery went dead. When I first plugged it in, it refused to charge past 10%, and the power light cycled 4x Red and 1X White, over and over. As there were no settings for the Battery in the bios, and I had heard that some similar models had a ‘training’ option in the bios, I decided to upgrade the bios, thinking the battery option may be added to the bios. As the battery was below 10% charged, I had to run the dell (.exe) bios upgrade from the run menu with a ‘/forceit’ switch, to get by the low battery restriction. That was 55 minutes ago, and now the power light is steady white, and the battery is up to 66% on the dell battery meter in control panel\power options, and appears to be charging normally.
If you have the same problem, and have already upgraded the bios to the latest version, you may be able to reflash to the same version to get the battery out of the ‘loop’ that mine was in, and if your bios version is older, a reflash to the latest version may solve the problem and save your battery.
I wonder how many batteries have been needlessly discarded as a result of this glitch…assuming that mine will work properly when finished charging… X my fingers!


#2

that is awesome! so I have a inspiron 1526 Dell and I tried forceit technique and was not successful.

I am new to all this flash bios thing and I tried running the upgrade in dos and still did not work. I tried creating a boot cd that did not work. Could you advise as to what I might be doing wrong?

thanks


#3

The update for the Dell 1545 is entitled 1545_A14.exe It is intended to be run under Windows, not DOS, so that will explain why you did not succeed with running it in that mode. What Windows OS are you running on your 1525? The one I updated is running Vista, and there is some complication in running the update in Vista. I would imagine that your update is labelled 1525_A14.exe?


#4

Thanks that for the insight and the Dell 1526 is running on Vista’s as well. There were several bios downloads and A14 was one of them and did read about the A14, that it would not work. I tried the A16.


#5

On Vista you 1st have to create an Elevated Command Prompt with Administrator Privileges, the instructions for which are here: http://www.mydigitallife.info/2007/02/17/how-to-open-elevated-command-prompt-with-administrator-privileges-in-windows-vista/
When you have achieved this, ask me for further instructions.

BTW, Please go into control panel (Classic View)-Power Options-Dell Battery Meter and see if you have over 10% of your battery charged and [I]let me know.[/I] You only have to use the forceit switch if your battery is holding 10% or lower of full charge.


#6

Jesse–
Make darn sure if you are flashing the BIOS with a dead battery that there is NO chance that your house power can go out–otherwise you end up with an expensive paperweight.

I just found an easier way to do this, from http://club.myce.com/f7/how-update-bios-dell-laptops-without-battery-260714/index2.html
Originally Posted by [B]radioburger[/B]
[I]
Man you guys really know how to make something harder than it needs to be. There’s a simple two-step solution that doesn’t require command prompt:
#1. Create a shortcut to the BIOS update executable.
#2: Right-click shortcut, go to Properties and simply add " /forceit" (without quotations of course) at the end. Make sure you put a space between the file path’s end quotation and the /forceit command. Hit OK then just double-click the magical shortcut.

For example:
“C:\Documents and Settings\User1\My Documents\FlashBIOS.exe” /forceit

Once you’re done, read this.[/I]


#7

Ok I was able to achieve your instructions. Now what?