Dell does not recognise my 6650A

vbimport

#1

I have updated the Liggy’s firmware 2.23 to my 6650A on my Dell 6400.
However, after I rebooted the laptop. It’s doesn’t recognise the driver.
Dell’s BIOS said the drive have problem. The drive have no reponse now even I press the eject button. Can anybody help me? :sad:


#2

When I reboot, the bios detect the drive. The drive LED will light up and I can press the eject button and tray eject. I think BIOS has powered down the drive as it does recognise the drive. I have put in a disc and found that the drive stopped spinning after the warning. Please give me some idea how to deal with it.


#3

What was the original firmware version before the update?

If it was 2.xx then you’ve used the right firmware and I’m not sure whats wrong.

If you updated from 1.xx then you needed to use the 1.23 firmware.

I believe the difference is in master/slave settings required by your system.


#4

When I download the firmware, the web site does not mention about 1.xx need to use 1.23 firmward. After problem happened, I found that this requirement in Liggy’s web.
As the my laptop is new, I haven’t installed the software to check the firmware before flashing the drive.

I just found that if I remove the drive when booting up XP and then let it Standby. Then plug in the drive. Turn on the laptop again. XP would be able to recognize the drive. However, when I tried to flash it back to the original firmware. Error occurs…


#5

BIOS is still failer to recognize the drive. It is very problematic. It is not possible to reinstall the OS if I need to boot from DVD drive. Please help me!


#6

u might find some things to try if ya read though this thread :slight_smile:
http://club.cdfreaks.com/showthread.php?t=175398

also u might try a converter to hook it up to a PC and flash from dos. just a thought though, good luck :slight_smile:


#7

I have to figure out where to get the convertor. but I can’t find a dos flash tools for 6650. Can anyone told me where to get them?

I use Binflash gui 1.27 to flash. I saw that post Liggy said that lastest version Binflash should not allow 1.xx flash to 2.xx. But what happened to my drive?


#8

deleted


#9

Thanks for you kindly help! I saved my semi-bricked DVD drive!
That’s how I work it out:

  1. Pull out the drive
  2. Turn on the laptop
  3. After boot up, turn it to standby mode
  4. Plug in the drive
  5. Turn on the laptop again. XP would be able to recognize it.
  6. Use binflash gui to flash it to the original firmware. Error occurs and LED non-stop flashing. XP would unloaded the drive.
  7. Rescan new hardware in Device manager of Control Panel. XP would detect it again even the drive LED flashing.
  8. Use binflash gui again to flash with the original firmware. This time would have no errors occurs.
  9. Completed flashing firmware and reboot.

If anyone got a bricked drive should try to see whether this method will help you to save your drive!


#10

And now please tell us which version your original firmware was.


#11

My 6650 firmware is 102c and I flashed with 2.23.


#12

1.23 would have been better in this case


#13

Will my Dell recognize it?


#14

At least it should, but I cannot 100% guarantee it.


#15

I see. Thanks!


#16

C.F.,

Thank you so much for posting the steps for recovering the NEC 6650-A drive. I had the same problem, and the steps worked perfectly on my XPS Gen2 system. I now have my original firmware.

I now have a question for everyone: I tried to update my firmware because my NEC drive stopped being able to recognize CDs or DVDs. It makes a strange grinding sound when it tries to read discs, and it can’t read anything. I’ve only had the drive for a few weeks, and have only put it through light or moderate use.

Would updating firmware likely fix this problem? Or is it more likely that the hardware has just gone bad?

Strangely enough, this is the second drive that has had this problem on the XPS laptop. The NEC replaced the Sony DW-D56A drive, which also stopped being able to recognize discs. Dell tech support put the drive through a whole battery of system tests, then decided to send me the NEC drive. Strange that this same problem has occurred in a different model drive.

Any thoughts extremely appreciated!

Ben


#17

bpstein,

It’s so good to hear that my experience helped you.

Did the two optical drives been able to read the DVD or CD before? Did they stop functioning suddenly?

If both drives never function, it may be the problem from your mobo. If you know someone have similar laptop, just swap your drive with other computer to see whether the drive really have problem.


#18

C.F.,

Thanks again–the solution was a work of genius. It prevented the inconvenient BIOS error at startup.

To answer your question, the Sony Drive could read discs for about 8 months before it failed, and the NEC drive read discs for just three weeks before it experienced problems.

Ben


#19

Ben,

I just luckily discover this tricks only. Thanks for you praise. :slight_smile:

For your case, it is really weird. I am sorry that I can’t help you in this case.