Dell CD/DVD drive problem

vbimport

#1

Dear fellows

I have just bought a Dell Dimension 9150 in Nov 2005. Last Thurs it suddenly gave me problems. I tried to burn a data CD from nero 6 and 7 and it gave me errors. Also sometimes it cannot autoplay when i insert a blank Sony CD ROM.

The troubleshooting team at Dell told me to reformat my PC!! I have trusted them so much in terms of quality and service. THing is i have calibrated my monitor and printer after so much time and heart ache. I just don’t want to go through that. And furthermore i have lots of important data.

Please tell me i dont have to do that. They changed another drive for me and i still get the same error. This is my hardware hl-dt-st dvd±rw gwa4164b. Where can i get a firmware update? I downloaded the NEC one from Dell’s site and it can’t detect the drive.

The error log is as follows (basically “track following error”). I pray someone could help a noob like me soon! Thank you so so so much!!!

Justin

Windows XP 5.1
IA32
WinAspi: -
ahead WinASPI: File 'C:\Program Files\Ahead
ero\Wnaspi32.dll': Ver=2.0.1.59, size=160016 bytes, created 29/01/2003 22:37:36 
Nero Version: 5.5.10.20 (Nero Express)
Recorder:             <HL-DT-ST DVD+-RW GWA4164B>Version: D108 - HA 0 TA 0 - 5.5.10.20
 Adapter driver:      <atapi>                   HA 0
 Drive buffer  :      2048kB
 Bus Type      :      via Inquiry data (1) -> ATAPI, detected: ATAPI 
 Connected to MMC as unknown drive with class-nr : 1
CD-ROM:               <HL-DT-ST DVD+-RW GWA4164B>Version: D108 - HA 0 TA 0 - 5.5.10.20
 Adapter driver:      <atapi>                   HA 0
 Bus Type      :      default (0) -> ATAPI, detected: ATAPI 

=== Scsi-Device-Map ===
CdRomPeripheral      : HL-DT-ST DVD+-RW GWA4164B        atapi Port 0 ID 0  DMA: Off
DiskPeripheral       : Maxtor 7L250S0                  iaStor Port 1 ID 0  DMA: On 
=======================

AutoRun : 1
Excluded drive IDs: 
CmdQueuing     : 1
CmdNotification: 2
WriteBufferSize: 83886080 (0) Byte
ShowDrvBufStat : 0
EraseSpeed     : 0
BUFE           : 0
Physical memory     : 2046MB (2095196kB)
Free physical memory: 1585MB (1623048kB)
Memory in use       : 22 %
Uncached PFiles: 0x0
Use Static Write Speed Table: 0
Use Inquiry    : 1
Global Bus Type: default (0)
Check supported media : Enabled (1) 
Wizard: Off

18.3.2006
CD-ROM (ISO)
22:52:12	#1 Text 0 File Isodoc.cpp, Line 7579
	Iso document burn settings
	------------------------------------------
	Determine maximum speed : FALSE
	Simulate                : FALSE
	Write                   : TRUE
	Finalize CD             : FALSE
	Multisession            : TRUE
	Multisession type:      : Start multisession
	Burning mode            : TAO
	Mode                    : 1
	ISO Level               : 1 (Max. of 11 = 8 + 3 char)
	Character set           : ISO 9660
	Joliet                  : TRUE
	Allow pathdepth more than 8 directories : TRUE
	Allow more than 255 characters in path  : TRUE
	Write ISO9660 ;1 file extensions        : TRUE
	
22:52:12	#2 Phase 90 File dlgbrnst.cpp, Line 1655
	Buffer Underrun Protection activated
	
22:52:13	#3 Text 0 File Reader.cpp, Line 115
	Reader running
	
22:52:13	#4 Text 0 File Writer.cpp, Line 125
	Writer HL-DT-ST DVD+-RW GWA4164B running
	
22:52:13	#5 ISO9660GEN -11 File geniso.cpp, Line 4563
	First writeable address = 0 (0x00000000)
	
22:52:13	#6 Text 0 File Burncd.cpp, Line 3726
	Turn on Track-At-Once, using CD-R/RW media
	
22:52:13	#7 Text 0 File ThreadedTransferInterface.cpp, Line 672
	Setup items (original item values)
	 0: TRM_DATA_MODE1 (CTransferItem)
	    2 indices, index0 (150) not provided
	    original CD pos #0 + 46486 (46486) = #46486/10:19.61
	    relocatable, CD pos for caching/writing not required/required, no patch infos 
	--------------------------------------------------------------
	
22:52:13	#8 Text 0 File DlgWaitCD.cpp, Line 215
	Last possible write address on media:   359848 (79:59.73)
	Last address to be written:              46485 (10:21.60)
	
22:52:13	#9 Text 0 File DlgWaitCD.cpp, Line 220
	Write in overburning mode: FALSE
	
22:52:13	#10 Text 0 File DlgWaitCD.cpp, Line 1657
	Recorder: HL-DT-ST DVD+-RW GWA4164B;
	   CDR code: 00 97 24 16; OSJ entry from: SONY Corporation
	   ATIP Data:
	     Special    Info [hex] 1: D0 00 A0, 2: 61 18 10 (LI 97:24.16), 3: 4F 3B 4A (LO 79:59.74)
	     Additional Info [hex] 1: 00 00 80 (invalid), 2: 00 80 00 (invalid), 3: 00 00 00 (invalid)
	
22:52:13	#11 Text 0 File ThreadedTransferInterface.cpp, Line 824
	Prepare recorder HL-DT-ST DVD+-RW GWA4164B for write in TAO
	DAO infos:
	==========
	MCN: 
	TOCTYPE: 0x0   Session Closed, CD not fixated
	Tracks 1 to 1:
	   TRM_DATA_MODE1, 2048/0x0, ISRC "", FilePos 0 307200 95510528
	
22:52:13	#12 Text 0 File ThreadedTransferInterface.cpp, Line 852
	Removed 2 run-out blocks from end of track 1.
	
22:52:13	#13 Text 0 File ThreadedTransferInterface.cpp, Line 672
	Setup items (after recorder preparation)
	 0: TRM_DATA_MODE1 (CTransferItem)
	    2 indices, index0 (150) not provided
	    original CD pos #0 + 46486 (46486) = #46486/10:19.61
	    relocatable, CD pos for caching/writing not required/required, no patch infos 
	    -> TRM_DATA_MODE1, 2048, config 0, wanted index0 0 blocks, length 46484 blocks [HL-DT-ST DVD+-RW GWA4164B]
	--------------------------------------------------------------
	
22:52:13	#14 Phase 24 File dlgbrnst.cpp, Line 1655
	Caching of files started
	
22:52:13	#15 Phase 25 File dlgbrnst.cpp, Line 1655
	Caching of files completed
	
22:52:13	#16 Phase 36 File dlgbrnst.cpp, Line 1655
	Burn process started at 40x (6,000 KB/s)
	
22:52:13	#17 Text 0 File ThreadedTransferInterface.cpp, Line 1978
	Verifying CD position of item 0 (relocatable, CD pos, no patch infos, orig at #0): write at #0
	
22:52:13	#18 Text 0 File Mmc.cpp, Line 17693
	Set BUFE: supported -> ON 
	
22:52:43	#19 SCSI -1119 File Cdrdrv.cpp, Line 1412
	SCSI Exec, HA 0, TA 0, LUN 0, buffer 0x02590000
	Status:     0x04 (0x01, SCSI_ERR)
	HA-Status   0x00 (0x00, OK)
	TA-Status   0x02 (0x01, SCSI_TASTATUS_CHKCOND)
	Sense Key:  0x04 (KEY_HARDWARE_ERROR)
	Sense Code: 0x09
	Sense Qual: 0x00
	CDB Data:   0x2A 0x00 0x00 0x00 0x2F 0xC0 0x00 0x00 0x20 0x00 0x00 0x00 
	Sense Data: 0x70 0x00 0x04 0x00 0x00 0x00 0x00 0x0E 
	            0x00 0x00 0x00 0x00 0x09 0x00 
	
22:52:43	#20 DVDR -1119 File Writer.cpp, Line 333
	Track following error
	
22:52:43	#21 Text 0 File ThreadedTransfer.cpp, Line 219
	all writers idle, stopping conversion
	
22:52:43	#22 CDR -201 File WriterStatus.cpp, Line 194
	Invalid write state
	
22:52:43	#23 TRANSFER -18 File WriterStatus.cpp, Line 194
	Could not perform EndTrack
	
22:52:43	#24 Text 0 File Mmc.cpp, Line 12699
	<HL-DT-STDVD+-RW GWA4164B> start Close Session
	
22:53:05	#25 Phase 38 File dlgbrnst.cpp, Line 1655
	Burn process failed at 40x (6,000 KB/s)
	
22:53:05	#26 Text 0 File Scsicmd.cpp, Line 406
	SCSI not using temporary buffers
	20 out of 20 temporary buffers allocated
	

Existing drivers:
File 'Drivers\ADPU160M.SYS': Ver=v3.60a (Lab01_N(johnstra).010529-2218), size=101888 bytes, created 17/08/2001 14:07:32 
File 'Drivers\atapi.sys': Ver=5.1.2600.2180 (xpsp_sp2_rtm.040803-2158), size=95360 bytes, created 03/08/2004 22:59:44 (Adapter driver for rec)

Registry Keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option)

#2

Hi and welcome to the forum :slight_smile:

Before to reformat all try to enable DMA

and edit your post to remove your nero serial number :wink:

See here
http://club.cdfreaks.com/showthread.php?t=101616


#3

Hey geno

Thanks for your reply.

Do not know what DMA does, the link seems to say that it is for HDD?

Also can you please tell me how to edit my post?

THanks!


#4
  1. Turn off Windows burning service. (admin tools - services)
  2. enable DMA on all drives (Device manager - IDE controller) You may accomplish this also by simply uninstalling the IDE controller in device manager and rebooting.
  3. If problem not solved, Download and run Nero’s cleaning tool. You will need to re-install Nero and all serial numbers after this.

For the sake of testing, do not burn in multisession mode, but in DAO mode.


#5

Hi,

This is my hardware hl-dt-st dvd±rw gwa4164b. Where can i get a firmware update? I downloaded the NEC one from Dell’s site and it can’t detect the drive.

Your drive is made by LG. Be glad, that the NEC tool refused to work.
But I don’t think, that a firmware update would solve your problem. I am sure, that you broke something in your windows installation.

Nero Version: 5.5.10.20 (Nero Express)

And that old version works with your burner? Strange.

I would recommend to uninstall Nero, then download the Nero Clean Tool and run that. You may check your registry for Ahead and Nero related entries and remove them too. After rebooting you can try to reinstall Nero. Use the software version, that came with your PC.

Michael


#6

Thanks for all your replies. Try using the clean tool but not much help.

Blank Sony CD still can’t autoplay :frowning:

Will try the DMA thingy.

Sorry i am being such a noob.

Thanks!


#7

DMA is enabled. Still not success :frowning:

Guess i might have to restore? or reinstall windows? I really can’t afford to do that…

Will starting at another safe point help?


#8

Please ask a mod to remove the serial number!!


#9

Under warrenty/keep up wiith Dell service for help! They will send someone out to fix it or replace it!
But other than that, you need to go to the Dell site and update your Bios!
Then boot into your Bios/F2 and check all your settings for IDE and drives.
Check the back of your burner that it is jumpered to master and check in device mgr that it is DMA and the master.
Go to windows update and update all your stuff!
Nero 6. update .18 is the best out there so far!


#10

ps/ 9150 is a fine box!


#11

My problem is that the DVD burner (HT-DT-ST DVD+ -RW GWA4164B) is NOT seeing CD’s. This is a brand new Dell Dimension 9150 computer. Has anyone experienced the same problem? Can anyone help? Any suggestions?
Help! Help! Help!!!


#12

then ask DELL.


#13

Read the threada on this issue! Please go into your BIOS and check all your settings! Update everything from BIOS to FW and software for everything! Run one and only one copy program/remove Sonic DLA and INCD


#14

Check your settings in Device Manager


#15

I am having the same exact problem. I was on the phone with Dell for almost two hours running tests and reinstalling the newest drivers, but they finally broke down and said that they would mail out a new dvd-rw, but they would have to install it. Did you ever get the problem resolved?


#16

Let’s not forget this is a Dell… Uninstall Sonic DLA!


#17

i uninstalled sonic DLA, but it still won’t read any cd-rom, just dvds. any other suggestions?


#18

Disable Multisession!


#19

Did you do everything in this thread? Dell ships all drives as CS. Make it the master with the jumper and run only one drive at first. Check your BIOS settings. Dell ships with channels turned off. be sure you only have one master and it is your burner. The Sony 1615 will work fine as a slave.


#20

i have done everything in the thread except disabling multisession. where do i do that? as far as changing master and slave… i know where the jumpers are, but i do not know what is what.