Defective drive?

vbimport

#1

Hi. I’m new here. I’ve been using a cd-rw drive for many years and I thought it was about time for me to upgrade to a dvdrw drive. So I bought a Nec ND-3500A from newegg. I am experiencing extreme slow speeds with the drive. Burning at 8x it takes 21 minutes! That cannot be correct because I am told that it is supposed to take about 8 minutes. What is wrong? I even upgraded my firmware to the latest 2.18 and this problem still persists. I am using Maxell 8x DVD+R discs. I am also burning data files. Please help! If I cannot fix this problem, maybe a format and reinstall of my OS would. or I will return this and buy something else.

look here:

thanks


#2

This is usually a IDE driver issue or a non enabled UDMA 2… check if UDMA2 is enabled or try to roll back IDE drivers to MS IDE in device manager…


#3

Hey thanks for the reply but I am a little bit confused on what you just said. how can i check for this? I think i’m already using microsoft’s drivers:



#4

are those windows blinds from stardock? Take those off and try it, I had lots of troubles with those when I used them quite a while back, even with this stuff. It cloggs some stuff down sometimes.


#5

Before you do anything I’ll write next tell me what mother board do you have…

You have to go into Control Panel/System/HardWare/Device Manager :wink:
Then find IDE ATA/ATAPI controllers… and go to properties on the channel you have your Nec on ( Primary, Secondary)… then find If you have your Nec in Ultra DMA 2 transfer mode. If it’s in Ultra DMA 2… then go out here… and in the IDE controllers hit properties on your controller… And in Driver tab hit roll back driver.


#6

Hm… you have… what about your Controller drivers…


#7

this is what i see:

My nec is the master drive.


#8

That’s probably your harddisk.

My guess is that your NEC is master on secondary channel.


#9

Here is another screenshot.


#10

Have you enabled DMA for secondary channel in your bios. Check in your bios if it says Auto or PIO mode.

At the bootscreen you should be able to see the mode of yoyr drive too.

Try to delete the Via Busmaster Controller in the Device Manager and reboot. Windows will then find your drives again and the problem is solved.


#11

Ok I went to my bios and secondary master. my nec drive is displayed there. here is what it says:

Type : Auto
Multi-sector control : disabled
LBA Mode control : disabled
32 Bit I/0 : enabled
Transfer Mode : FPIO4/DMA 2
Ultra DMA mode : Mode 2
Hide Mode : Disabled

Are these correct? If I change the Type to “User” instead of Auto, it allows me to change some of the stuff. Like transfer mode can be FPIO 3/DMA 1, Fast PIO 4, fast PIO 3, fast PIO 3, fast PIO 1, Standard. Ultra DMA mode can also change to Mode 1, Mode 2, Mode 3, Mode 4, Mode 5, and Disabled.


#12

Your bios is correct.

Haved you deleted the Via Busmaster Controller in the Device Manager and reboot.

Windows will then find your drives again and the problem should be solved.


#13

No it did not work. I edited my registry for nero6 so that it shows the actual speed of burning. I burned a dvd+r at 8x. It showed 2.4x - 2.7x the entire time of burn for 20 minutes. What the heck!?! This drive has got some serious problems. I did not pay 70 bucks for a 2.5x speed dvd burner. I am really considering refunding this…


#14

Alright this is what I did. I went to my bios and I changed the Transfer Mode from FPIO4/DMA 2 to Standard. Now it works! Under my device manager, it says Ultra DMA Mode 2 instead of Multi Word DMA Mode 2. I burned a dvd+r at 8x and it took around 9 minutes. It started burning at 4x, then at around 50% of the burn, it went 6x, and then a couple of minutes later, went to 8x. This is normal right?

Screen 1
Screen 2


#15

Yep, that’s normal. :slight_smile:

Your prior BIOS setting was forcing the drive to DMA Multiword 2, which has a transfer rate of 16 MB/sec. (same as PIO Mode 4). Changing to Standard in Transfer Mode enabled Ultra DMA Mode 2, which allows transfer rates of 33 MB/sec. and lower CPU utilization.


#16

how can you change that setting if you are using the dvd burner in a usb 2.0 external enclosure, and it doesnt appear in the bios?


#17

Thanks :wink: I guess I’m all set now and I don’t need to change anymore settings. This have been giving me headaches :Z

Also my computer boot time seems to have increased by about 20 seconds :sad:


#18

Fine you found the solution.

Transfer Mode : FPIO4/DMA 2

I’ve learned that the F in FPIO4/DMA 2 means Force PIO4 and not the drive support both modes.

Which motherboard do you have.


#19

You can’t change setting for a external enclosure.

It’s the external enclosure internal chipset, which determine transfer rates.

My enclosure only support 8x.

Have a look here http://club.cdfreaks.com/showthread.php?t=119149


#20

would this enclosure:

be better than this enclosure: