Dear god.. I'm stuck with a GWA-4164B

vbimport

#1

Okay, so I stoopered my way into a little trap with this here GWA-4164B. I attempted flashing this thing over to GSA-4166B, thinking I’d be helping myself out. Instead, things are worse. Now, I’ve done some reading and I’m familiar with a lot of things reguarding this drive, but I am now unable to even return the drive back to its normal state of moderate failure as the 4164B model. The GSA-4166B is not reading music or blank disks.
And, I can’t simply rollback the driver as I’d hoped.

So my question is, how can I change my drive back to the drive it was before, the GWA-4164B?


#2

ask tdb


#3

Which disks does it read ? Can you still boot from a bootable cd ?

So my question is, how can I change my drive back to the drive it was before, the GWA-4164B?

Which GWA-4164B firmware revision did you use before ?


#4

It does not read any disks at all at the moment. It shows up as a DVD-RAM drive also. I am not sure what revision I had originally, I’m sure any will due as long as they let me change it back to the GWA instead of GSA.


#5

For some reason I thought that xFlash worked,will it let you reflash it ?what 4166b s/w did you use? some people had truble with 1.01(I think) can you try 1.02 or the other way around?
Bruce


#6

I am not sure which revision I have, but I remember it did work when I first flashed it over to the GSA-4166b. At some point after trying to flash it back to GWA, something must have went wrong. Anyway, whether or not it reads is not the reason I started this thread. I want to get it back to its original driver, or at least to have the driver to put it back to normal if any future flashes go wrong. If anyone has any links for either gsa-4166b or gwa-4264b drivers, please let me know.


#7

Those “drivers” you have been experimenting with are firmware updates. Firmware updates write to a chip the writer itself in order to change certain properties of the drive itself. If something goes wrong when one of those firmware updates is writing to the chip in your drive, you can end up with a drive that doesn’t work properly. This may be what happened in your case when you tried to flash the drive back to a GWA-4164B, particularly if you interrupted a flashing process before it completed.

I can give you links to GWA-4164B firmware but the flashing programs inside usually will check to make sure that they are only run on a drive with the same model number. So if you try to run GWA-4164B firmware on your current drive, it will probably identify your drive as a GSA-4166B and refuse to work. The firmware program you originally used to cross flash your GWA-4164B to a GSA-4166B was special because it did not perform that check. So it may not be possible to go back to a GWA-4164B.

These two links may have firmware for the GWA-4164B which you can try to use. The firmware updates may or may not work as I mentioned above :

http://drivers.softpedia.com/get/FIRMWARE/LG/
http://www.cdrinfo.com/Sections/Firmware/Home.aspx


#8

Looks like you do not read your PM.


#9

The HBLoader.exe flasher of the GSA-4166 1.01 package can be used for crossflashing back as it does not check the current firmware id. It only checks for a GWA-4164 string that occurs in the GWA-4164/4166, GSA-4166 and HP 740/840 firmwares.


#10

Ok thanks ala. That hopefully can help this poor guy here.


#11

Never heard of it.

Sounds great, but where exactly is that?


#12

When you originally cross flashed your GWA-4164B so it became a GSA-4166B, you had to have used a special GSA-4166B firmware version 1.01. I think it came as a zipfile. HBloader should be inside that zipfile.


#13

[quote=“DellisTehSuck”]

Never heard of it.
[/QUOTE]
PM is short for Private Messages. If you have a look at the upper right part of this page you will see that did not read your post box.


#14

I don’t have the file that I used to crossflash to 4166B. And, the bin file in my PM is just going to sit there unless someone gives me some idea what I am supposed to do with it. This was the first time I’ve ever crossflashed a drive.