Ddump/fireburner & safedisc 2.8 (sims unleashed)

Wondering if anyone has any ideas.
Copying safedisc 2.8 (the sims unleashed) using ddump and fireburner 1.06 on a 5224A fw 1.0. Play disc will not install automatically - just hangs. Can force a manual install from the setup menu, but it still hangs when trying to playafter install.
Tried burning the same ddump image on a liteon 52327s but have the same results.
Have successfully backed up the sims superstar (safedisc 2.9), the sims makin magic (safedisc 2.9), and lord of the ring - return of the king (safedisc 3.10) and earlier versions of Safedisc with the same setup.

Discdump seemed to struggle with the process, think it took the better part of an hour, much longer than any other safedisc image.

Any ideas?

Thanks
HROX

have you tried remaking the image, and seeing if it was a buggy first ímage? It could be that some glitch in the system at the time you made the image caused it not to get read well. If it dont take so long the second time, then you can bet it didnt get read right the first time.