Data rate problems when playing a DVD (SH-S182D)

vbimport

#1

Hey Guys!

I’m really desperate… I’ve bought a new pc containing a Samsung SH-S182D burner. This is my problem:
Every time I copy any data from a dvd to a directory on my hard disk, the data rate is about 1.2 MB per second… quite little for a new drive. Same thing happens during watching films, it’s lagging like hell.
Trying to solve this problem, I’ve installed new mainboard drivers (Abit AB9) and I’ve updated the firmware to version SB04. But the problem is still present.

I’d be glad if someone could help me! :sad:

Greets
Le Chiffre


#2

Welcome to the forum :slight_smile:

This drive is not a very fast ripper.

However, very often playback problems are due to a bad quality media. Is this playback problem only with burned discs or also with pressed ones? Have you checked if discs are dirty or scratched?


#3

Thx 4 welcome :slight_smile:

It’s also with pressed ones and they’re neither dirty nor scratched. Perhaps further information could help: I’m using win xp home sp2 and my RAM is a 1gb corsair ddr2-800 bar.


#4

hmmm Check if DMA is enabled: this is another frequent cause of slowings :slight_smile:

http://club.cdfreaks.com/showthread.php?t=101616


#5

Hm… I guess it was enabled. To be sure, I enabled every DMA mode which is available (primary and secondary IDEs). Didn’t work. :frowning:


#6

Can you do a simple test? Download latest version of cd-dvd speed here. then run it, select the burner, insert a disc that give you reading problems and select menu Run test --> Transfer rate.

When the test is completed, can you post the graph here?

Another useful test is the Burst rate test. Can you post also this result here?


#7

Ok, I’m running cd-dvd speed… strange, since 2 minutes it shows “0.86x”… quite alarming I’d say. And my CPU (Core 2 Duo @2,81) seems to be affected… I can hardly type this reply…

Where do I find this Burst rate test?


#8

Menu Run test --> Burst rate


#9

Well I don’t understand the way of posting pictures, but here’s an external link:
http://img299.imageshack.us/my.php?image=graphui4.jpg

I hand to abort the test, it would take another hour to finish it and I’m too tired atm. Tomorrow I’ll run it again and post the complete graph. Ty so far. :slight_smile:


#10

This graph is typical of a disabled DMA. Check again :slight_smile:


#11

Ok, I’ve checked again… each IDE is set to DMA. One of them showed “PIO” and another one “Ultra-DMA-Mode-5”. I set PIO to “DMA if available”, but the PIO-Mode is still activated in the field below. It doesn’t show DMA. But the graph changed a bit, now it looks like this:
http://img170.imageshack.us/my.php?image=graph2xb9.jpg

The Burst Rate is 1.3 Mb/s.


#12

You must “Uninstall” the IDE Channel in Device Manager to get out of PIO Mode.


#13

Yea that’s what I did today, but when I ran the installation of the channels the channel was automatically set to PIO Mode again, same problem as before. I installed the drive in another pc and there it works perfectly under win2k… so I guess there must be some trouble with my mainboard or any other settings in win xp. =/


#14

Is the SH-S182D sharing the same IDE channel with the hard drive? If so, try installing it in the other channel instead.


#15

No, it isn’t. I could deinstall all channels and then windows didn’t show my drive. Then I installed the channels again cuz my hard disk was working properly.


#16

Do you have installed Intel or nVidia or VIA IDE drivers? Usually are these the cause of PIO problems. I suggest to uninstall these and let windows install standard M$ IDE drivers

Take a look also to this article: maybe it can help you to find a solution :slight_smile:


#17

Check also the cable you used to install the drive.

The most far connector should be put on the motherboard, and the other two connectors should be used for devices.

Look at the cable this way:

|--------|—|

1--------2—3

The far connector is the first pipe | symbol is the motherboard connector (number 1), while the other two connectors (number 2 and 3) are dedicated to devices.

BTW, try to test the drive with both the device connectors, and each time uninstall the IDE device and then reboot.
Once I had a problem like this one with an old NEC drive: when connecting the drive with connector no. 3, I always got DMA disabled.
I tryed to connect the drive with connector no. 2 and things went fine.


#18

If it’s going back to PIO even after you uninstall the channel…the next thing I’d try is a brand new IDE cable :slight_smile:

(Welcome to the forum ;))


#19

I received my SH-S182D last Thursday, and had similar problems with it.
Turned out the drive was running in UDMA 0.

I don’t want to be a Clever Trevor, but uninstalling the channels(s) in device manager is not going to help you.
In Device Manager, you need to uninstall the controller (not the channel) that your ODD is connected to, AND reboot.
(The controller is one level up in the bus hierarchy.)
When you delete the channel, there is no actual re-detection taking place.
The installed controller will only repair the channel to what it was before. And in your case it made a mistake.
And it will keep making that same mistake because, well, it is in control.
You have to kick the controllers butt to do a proper job.
So sack it, and let it re-apply for the job.

Uninstalling will take about 15-25 seconds, so don’t fret.
After the reboot and login, everything which was connected to the controller you uninstalled will be re-detected.
All drives, primary and secondary channels, and the controller itself.
Let the yellow balloon text popups on the right-hand side of your taskbar finish. (XP might want you to reboot again, don’t ignore it.)
Then check the transfer mode in Device Manager.

http://forum.imgburn.com/index.php?showtopic=59&pid=967&st=0&#entry967 (Wait to let your browser position to the correct posting.)


#20

@DVDlover

The odd thing is: I’ve 2 controllers…
"Intel® ICH8 2 port Serial ATA Storage Controller - 2825"
and another one with “ICH8 4” and “2820” at the end… which one should be deinstalled?