Data on Formatted DVD+RW becomes Read-only

vbimport

#1

Hello, I’m new to CDFreaks and to burning DVDs.
I have a Lite-on SOHW-1213S +/-RW recorder, and XP and have tried to use InCD4 and Sonic DLA to format Sony DVD+RWs (I uninstalled InCD4 before trying DLA). Both these programmes will format the disc, then I can drag and drop, or copy and paste data(.jpeg and .psd files of digital images off my hard drive). When I have finished , before I take the Disc out of the recorder, I can delete or rename them. BUT, after the disc has been removed and re-inserted, all the files are then Read-only and I can’t delete or alter or add anything else to the disc. I have no idea where I’m going wrong. I should be able to delete part of the data shouldn’t I? And I should be able to add more files, providing there is room on the disc?

Please help me to sort this out. I thought by having RW DVDs I could off-load my big stack of photos onto them, but still be able to alter or delete them whenever I want without putting them back on the hard drive.

Thanks, Ruth


#2

try right clicking on the incd icon on your tray and then find the load function and see if that helps


#3

Thanks for your response. I have replaced InCD with Sonic DLA, but I still have the same problem.Once I’ve added data to a formatted DVD+RW, when I put it back in the drive to look at it or add to it, all the files are 'read-only, and the disc won’t accept any more data.
What I really need someone to tell me, yes or no, is Can you use a formatted DVD+ RW like a floppy, add, delete, change and save the changes? Once I know I’m not trying to do something that can’t be done, then I can start to find out why I’m not managing it.
I’m going to put my first post in another of the CDFreak forums,as I think the people most likely to know the answers are not very likely to be reading the Newbie’s forum, hope this is allowed.
Thanks For anybody’s help.


#4

You’re SUPPOSED to be able to use it in the manner which you describe.

My experiences, however, with packet writing have been uniformly terrible. The programs are touchy and temperamental, and seldom do what they’re intended to do.

Others will undoubtedly flame me, saying that I’m being alarmist and that there’s nothing WRONG with those programs. They’re entitled to thier opinion. I feel, however, that oftentimes mysterious problems with having to run DVD’s before the drive will decrypt them, or having to insert and reinsert discs, etc. - are due to the packet writing drivers that are installed on their systems.

But seriously - discs are 10 cents apiece now for QUALITY CD media. Just burn 'em normally like the rest of us.


#5

'‘Just burn ‘em normally like the rest of us.’’

Yes, that’s the easy solution, but I want to keep all my images from one shoot all together on one disc,and re-name or change them without having to make a copy each time.
So how do I stop the disc becoming Read-only? Come on guys, someone must know.


#6

Check the Roxio forum and search for Sonic. There is a setting where you can tell it that you want the disk to be multi-session. That SHOULD make it to where you can modify it later. Many burning softwares have this option. Sorry I can’t be of more help, but so far I haven’t done much with rw media.


#7

Well I have no problems using inCD with CD-RW media but havent tried it with DVD-RW media yet… I’ll have a go this evening an post back


#8

I’ve used Roxio Drag2Disk/Direct CD without any problems, do exactly what you should be able to do. My only experience of Incd was with Sony Cd-RW media that got set to read-only just like your problem.
RW media written by these apps does not use multisession as far as I know as you can (or should be able) get to the files originally wreitten & delete/modify them. Not possible with multisession (I think). I don’t used it so I can’t be sure.
I guess you might need to look at the unload settings, maybe the default is to close & prevent further usage. I think this is an option on Roxio, but not the default.
You should be able to reformat these disks though & if you can it would suggest a settings problem like I speculated about.


#9

It might be better to remove Sonic DLA & reinstall Incd ( the latest version) as there is probably more expertise available for Incd.

I’ve just installed the latest version of INCD. Took a dvd+rw , formatted it, added files. Ejected it. Inserted it, added more files & deleted existing files.
Just as it should be.
There aren’t any options on the eject as I thought so nothing to fiddle with there.

You haven’t done anything with the Imapi service in Services have you?

Bring up the task manager, what processes named Incd… have you? If you reinstall Incd.


#10

Ruth

This isn’t going to be very helpful but I just uninstalled Incd & installed Sonic DLA.
Guess what?
It all works fine , just as it should.
I don’t have autoplay set at all, could it be that some other bit of software has grabbed it & prevent DLA/Incd getting a lock on it? Autoplay has caused me the odd problem with device locking before.


#11

You haven’t done anything with the Imapi service in Services have you?

Thanks Tim for trying both programmes on my behalf.I’m glad they work for you. Now that I’m reassured that I should be able to use a formatted disc like a hard drive or floppy, I’ll keep trying.
I don’t understand at all what the part of your post that I have quoted above means. Can you explain please. And I’ll disable Autoplay, see if that helps.
And I’ve discovered there is a Firmware update for my Lite-on Drive, which I thought I should install. Does anyone have any warnings or tips about this, firmware can be tricky can it?


#12

Yeah, here are some tips:

  1. DO NOT fiddle with the drive. Make sure it’s empty, and wait until the program says it’s done.

  2. Reboot immediately.

  3. Make sure it’s the right firmware for your drive, although Liteon firmwares are good about checking.


#13

Ruth

I’m not going bother explaining about imapi as I think I’m able to reproduce your problem.

There’s a system function called “Auto insert notification” which detects that a new disc has been loaded. It then enables the right things to happen to it.

I always have this set so my tests were fine. Now I’ve switched this off & suddenly I can’t delete files from or add files to the disk. It also takes a long time to detect the disk.

This can be switched on/off by editing the registry which is not without risk. I used DVD Decrypter, which if you’ve not heard of it is used in the process of copying DVD movies. This is the link to download it:- http://www.afterdawn.com/software/video_software/dvd_rippers/dvd_decrypter.cfm.
Run the app , choose tools-> settings-> device & check the auto insert notification box & reboot.

DVD Decrypter is also my choice for burning images so it’s very handy to have even if you don’t copy DVDs.

Hope this does it for you.


#14

You can enable/disable auto-insert notification from Explorer as well, no need to regedit. :slight_smile:


#15

You guys are being so helpful, trying so hard to help me sort this out.

Gurm,you say I can get to Auto insert Notification in Explorer. Where do I find it?. I got the dog to search for it but it couldn’t find anything called that, including in hidden files and folders. (Thanks for your note in the Nero forum too. I’ll stick to here for now.)


#16

Just get DVD decrypter , you won’t regret it.

BTW I’ve no idea where this is in Explorer either.


#17

Tim, I got DVD Decrypter, and found that the Auto insert Notification box is already checked, so I’m afraid that’s not the reason for my problem.
In an earlier reply you said you had used Roxio, Direct CD, does it work for DVD RW’s? I thought there was some conflict between WinXP and Roxio software? Should I try it? I’ve read that other people have trouble with it?


#18

Ruth

I’m running Roxio 7 with drag2disc (as & when I need it). I think versions before 6 might have had a problem with XP but 6 & 7 are definitely OK.

I’ve just tried to “break” it like I did the others (auto insert off) & I can’t. I think the difference is Imapi in that the others use it & Roxio doesn’t.

Maybe it’ll work for you too. I don’t think there are demo versions from Roxio but there’s always other ways to get a “trial” version.

If you go into control panel , administrative tools & services. Scroll down to IMAPI CD burning COM service. It should be set to manual.

The other thing on my systems is that I disable Microsoft CD recording. This is My computer, right click on the burner & properties. Look at the Recording tab. As I said mine is not enabled.

The final thing is that my user (Tim strangely enough ) has administrator rights.

If none of this works I’m out of ideas.

Btw where in the world are you?

Tim


#19

I’m in the Isle of Man, middle of the Irish Sea, very pretty, but dead short of computer shops or people who know stuff.
I’ve checked that the IMAPI setting is on Manual, and Microsoft CD Recording is not enabled. I’m the only user on my pc so I don’t think admin. status matters does it.

I think I’ll try Roxio,the newest version is 7.5. Trouble is I don’t need or want all the stuff that’s in it, maybe you don’t have to install all of it.You really have been /are being very helpful, thanks.


#20

Best just to check the rights that you have. Some of these services are a bit sensitive.

Selective installation of apps is allowed in Roxio so you can limit what you get.

I rather like some of the Roxio apps, like Classic Creator (Audio & MP3 CDs) , label creator, drag to disc & disk copier. I find them much better than Nero.

Let us know how you get on, and it’s been my pleasure - I like a challenge. And if I have any further thoughts on this I’ll let you know.

As Zebadee says “It’s time for bed”