Dark blue/purple screen with CyberLink PowerDVD 7

vbimport

#1

Hi.
I have been using Cyberlink Power DVD for quite some time to watch various DVDs.
I watched a few (via power DVD) DVDs I burned last week, and it went fine: they loaded from the beginning, I could go to the different menus, change my setup, and so on.
Today, however, those SAME dvds will NOT play in Power DVD. Every single one, when started from the beginning, gives a very dark blue/purple screen and just stays there - no sound, or any animation. I can’t get to any menu. I checked for visible scratches, and saw none. I changed NOTHING about my system/OS and never upgraded my Power DVD. I find it very unlikely that EACH dvd that worked fine last week, today won’t work at all, and the symptoms are EXACTLY the same when I try to play any of those DVDs.

Can anyone tell me just what the hell happened to Power DVD or my system that made Power DVD just not play anything it could before? I have also tested with images that are on my HD. Had a few images, tested them last week, worked fine. Those same images, today, still on my HD, won’t play in Power DVD (same symptoms as above). I have no idea what is going on.

Before anyone suggests using a newer version, I would like to know what/how/why Power DVD played everything just fine a few days ago, and now, those same things, don’t play at all.

I’d appreciate if anyone could shed any light, or provide me with any help.
Thanks!!

PS – the DVDs that don’t play in PowerDVD, play fine in WMP and my home DVD player


#2

Newer version? I still use PowerDVD-4. :iagree:

Definitely sounds like a software or codec problem. Un-install and re-install PowerDVD, see if that helps.


#3

Re-installing helped, thank you!

Does this mean if I get the same problem again, I have to re-install again?


#4

Most likely, installing or un-installing some other media player or video application messed up your DVD player codec. Re-installing PowerDVD simply over-wrote the codec and fixed it. Shouldn’t happen again unless some other software hoses it for you.