DAO/RAW problems on External (ieee1394a) A09XL

hello,

because i don’t have enough ide channels, i decided to use a09xl as an external burner.

everything works fine except when i try to burn disc images as dao or dao-raw mode…the application (alcohol120% said illegal address for writing)

this applies to both dvd & cd medias

firmware: a09xl is 1.58 official
os: winxp home sp2
interface: ieee1394a on audigy 2
external box: hp 640e

any ideas how to enable dao/dao-raw mode??

thanks

Use a better burning app like DVDDecrypter.
Alcohol is known for trouble…

i tried on nero 6.6 & dvd decrypter; both failed.

on plextor 716a, i got same result; must be either winxp sp2 or the ide to ieee1394a converter problem

should i install aspi driver?

SAO works without any problem on alcohol & nero
i think dvd decrypter failed to burn on the external a09xl because decryptor only burn the image through dao

ok, i borrowed a cdrw drive from my friend, sony crx220e1, and i could burn any cd images using dao & dao/raw without any problem from nero & alcohol (have not tried from dvd decrypter)

i guess both plextor 716a & pioneer a09xl have either some sort of firmware bug(s) or bug(s) on ide to ieee1394 converter.

very sad situation :frowning:

i tried this on few drives with different applications

pioneer a09xl v1.58–>all failed (no writing at all & hung; had to do the hard reset)
plextor 716a v1.08–>same as a09xl
benq 1620 b7w9–>same as a09xl
hp 650i benq 1625 bbia firmware–>all stalls @65%
sony crx220ee liteon 60sf–>all worked

it seems like most dvdrw drives have serious problems with ide to ieee1394 converter units

Such converters are not supposed to work with ODD.
No surprise about the outcome.

chef thanks for your input, but the converter i am talking about is from hp dvd640e (benq 1625 hp oem with ieee1394a & usb2 interface external) module that my friend sold me. even with the drive that was included did not work.

except lg & nec, i tried most popular current dvd burners with the lastest firmware, but no dvd burner worked right.

maybe, it is the ide to ieee1394a converter problem, but i doubt that it is the problem of the converter as crx220ee worked correctly without any problems

unfortunately, i don’t have other external enclousers available to test, i think most current dvd burners do not have firmware suit for external units as pioneer stopped to produce external version of dvd burner as of a08xl

I think that’s similar to results with some PROMISE controllers and ODD.
CD drives can be used, but it’s impossible to use any DVD drive with them…

Most firmware updaters are unable to address external cases (usb/firewire), that’s correct. :frowning:

this is for the enclosure with prolific pl-3507 controller only; mine has a “c” revision chip; updating firmware can damage your equipment; follow it at your own risk

i think i found a solution to this problem though i have not tested throughly.

i ran & across the big external enclosure thread @ cdfreak & found that there are some firmware updates available for prolific ieee1394 & usb combo conrtroller; unfortunately, the controller i have is infamous pl-3507 chip known to have many problems, but fortunately for me that there are updates for the chips

mine had most upto dated firmware until few weeks ago & new one fixed dao/raw problem for my plextor 716a & pioneer a09xl

here are links
http://tech.prolific.com.tw/visitor/v_fileBrw.asp
find pl-3507->firmware
download both the firmware programmer program & firmware dated 2005/09/06 with checksum of a480

connect the enclosure via usb & run the programmer & update the firmware
do the power cycle & see if that fixes tha problem

i read from “big external enclosure” thread & other threads from different forums suggested from that big external enclosure;

some suggested that the latest build of firmware (2005.09 would cause “delay write errors” but from my brave experience with my 250GB hdd, i did not find that is true.
delay write testing program (WARNING delay write test program can cause big data loss)
http://www.bustrace.com/delayedwrite/

strange thing is that dao/raw works on both usb & 1394 but 1394 takes long time for the lead-in

i hope this solve the problems for many

just in case for those who is brave enough to test their luck with important data
parition recovery tool (freeware)


file recovery (registered for raid sonic customers…and other who pretend to be one :wink: )
http://www.raidsonic.de/de/pages/service/support.php
—>Treiber download—>File Scavenger 2.1