DAE probs in EAC and CDex - sony CRX220A1/E1

just got a Sony CRX220A1/E1 - 52x24x52 - liteon chipset i think

firmware 6YS2

i connected an analog cable to it but started hearing hardware noise - clicking when cd was

spinning at all, so i disconnected it. by default i have “Enable Digital CD Audio” checked

since i run winxp sp1. Reads fine through jetaudio. I can rip all the tracks through the IDE

cable as digital audio just fine through Cool Edit Pro 2.1 with Extract Audio From CD, and

with nero’s “Save Tracks”

however…CDex and EAC refuse to rip it at all, i enabled the "enable digital cd Audio

playback" in CDex, still can’t hear anything, although it looks like it is trying to read

it, but it reads it abnormally, since the green light is a constant on, instead of blinking,

like it is when i read it from nero, jetaudio, or cool edit. same thing with EAC.

i tried to see if analog ripping would work through eac and cdex, so i connected the cable

back up, and disabled digital cd audio in winxp for the drive. that didnt work. so i

disconnected the analog cable, and tried playing it back, oddly enough, i still heard the

tracks play, with digital cd audio disabled in winxp and the analog cable disconnected. it’s

like it never turned it off even after i unchecked it.

i have a 6 channel Iwill superaudio soundcard with SPDIF, should i get the 2 pin-2pin spdif

cable and hook it up to the digital cd output on the drive?

also, both eac and cdex have problem detecting the drive features, and accessing the drive.

i figured it might be the ASPI, i tried both forceaspi 1.7, and adaptec aspi 4.71.2, neither

made a diff. also tried using the nero aspi with cdex and eac, still no go - eac freezes.

also nero cdspeed gives me a “parameter value invalid” error. although the infotool is fine

at detecting everything

suggestions?
thx,
Leon

Please do not crosspost. I have deleted your identical topic in General Hardware. I also see you have another topic in Lite-On subforum and the firmware forum…please stop.

More like triple crosspost. There’s another one in Lite-On forums.

You know, having crossposts can be very very irritating and makes people don’t want to help you at all.

sorry, just wasnt sure where people would most likely help.

Well EAC and CDex’s inability to rip CDs is not related to whether you have tha analog cable or not. In EAC, digital cd audio is called “Use alternate CD play routines”.

i switched on the alternate routines, and now it gives me a can’t detect read command, try to set autodetect (which was set the whole time)

i tried mmc, didnt work, although thats what Cool Edit Pro says it uses for extraction…and works.

also updated the 6YS2 firmware, which i cant find anywhere on web…should have prolly backed it up first, but i updated it to 6S0F…sony edited ver. now drive lacks the turbo boost feature that sony’s firmware came with, but was really annoying anyways, i just turn off smartburn for the drive in nero if i wanna burn faster than 40, but 40 for me is more than enough, considering i switched from 4x TEAC with no burnproof/buffer underrun protection. heh.

anyone else care to take a stab? (at the problem, not me : )
thx

fixed it, stupid DMA stuff, my bios set up an ALi PCI Bus Master IDE controller, so i redetected it and it added the primary and secondary controllers, and now everything is ok. sweet, best drive ever, flawless, every time. thx, i forget who you are for posting the solution in another thread : )

i suggest the sony edited 6S0F firmware, activating f***ing turbo boost every time is a pain in the ass.