DAE problems with PX-760A in PL-3507 external enclosure

vbimport

#1

I recently bought a Plextor PX-760A to be used inside an external enclosure with a Prolific PL-3507 USB2/FW controller. I have a large CD collection which I want to convert to FLAC files, and needed a drive with good Digital Audio Extraction (DAE) capabilities. Since I have a laptop, going for an external enclosure was my only option.

The external enclosure works like a charm with my old NEC ND-3500A DVD-recorder, but it won’t cooperate with the PX-760A. DAE fails with both PlexTools 2.35 and Exact Audio Copy 0.95 beta4 (the program I use for DAE). This happens no matter whether the drive is connected via USB2 or FW. PlexTools does however handle the two connection types differently:

When connected via USB2, DAE in PlexTools halts with a “Disc Read Error” message. But when connected via FW, PlexTools actually gets to read the disc, but every sample is treated as an error. In addition, the read speed is very slow, and it eventually hangs close to the end of track 1. I’ve tried different Audio CDs, and none of them are read by the drive.

Firmware info:

  • The PX-760A has fw 1.06
  • The PL-3507 is updated with latest fw (dated April 20th 2006)

So, does anyone have experience with DAE on PX-760A in an external enclosure? I’ve seen other posts stating that PX-760A operates smoothly with PL-3507 based enclosures. So why won’t my drive behave?


#2

Hi Mahesh78a, welcome to CDFreaks! :slight_smile:

I can try with my PX-760A in an PL-3507 based enclosure when I get home. I haven’t tried to use DAE with this drive yet.

I am having some problems with CD scanning with this setup, however, if you’re interested:

External PX-760A and Scanning for C1/C2?


#3

Thanks! Looking forward to reading your findings! :slight_smile:


#4

I think it Doesnt support optical drives with 2.0 Amp power input like the plextor 716A and 760A which has 2.0 AMP output , the Nec 3500A only has 1.8A max power output which this enclosuer Support.


#5

I can confirm this problem. My PX-760 fw 1.06 in an external enclosure based on Prolific PL-3507 (fw 2006.04.20.149) connected by USB doesn’t work with the DAE feature in PlexTools 2.36 (reports Read Error) and it also doesn’t work with “Secure Mode” ripping in Exact Audio Copy 0.95 beta 3; it does work with fast and burst mode ripping in EAC, however.


#6

I checked the power rating on the power supply for my external enclosure: it delivers 2A into both 5V and 12V. The PX-760A draws 2.4A from 12V and 1.7A from 5V, so insufficient current for 12V might be a problem here.

I hooked the PX-760A’s power socket up with an ordinary PC power supply, which has plenty of amps on both 5V and 12V, enough to keep the DVD-burner purring like a kitten. The enclosure power supply now only powers the PL-3507 circuit board. With this setup the same DAE errors as mentioned above occurred. So the current doesn’t seem to be causing the problem.


#7

Thanks for reporting back! So, it seems that I can just forget about using the PX-760A for DAE… Secure ripping is the only option for me!

I checked the possible insufficient current issue reported by mentor, but that didn’t help at all. Tested C1/C2 error testing in PlexTools, and it seems to work in all speeds (4X, 8X and 10-24X).

Has anyone out there been able to do secure mode DAE with a PX-760A in an external enclosure? If so, I would love to hear from you! :slight_smile:


#8

I’ve been using a enclosure with 1.5A/5V and 1.8A/12V with no apparent problems so far (admittedly not heavy duty but only occasional use, sorry i didn’t try DAE so far and right now the enclosure is used otherwise). Remember that the indicated values are PEAK values. Plextor in their excellent manual say the 760/755 use an average of about 22 Watts while burning. You’ll find detailed power ratings in the manual.

Also Prolific has the PX-760 on their latest list of compatible devices:
http://www.prolific.com.tw/support/files/\IDE%20Storage\PL-3507\Doc\Test%20Report\an_PL-3507%20Device%20Compatibility%20List_v1.0F.pdf
but don’t ask me what they tested …


#9

I tried using an ordinary PC power supply for the DVD-recorder, but that didn’t fix the problem (see above), so you’re right: The power supply of the enclosure is not to blame for my DAE problems.

Is your enclosure based on the PL-3507 chipset? It would be very interesting to see whether your setup deals with secure mode DAE! :slight_smile:

Thanks for pointing me to the Prolific compatibility list. I have contacted them about my DAE problem–it will be interesting to see what comes out of it!


#10

Yes, it’s a “Welland ME340U2F”. I’ll see if I can put a 755 or 760 into it in the near future and have a look at DAE.

In case some competent looking person is getting back to you: The Premium2 (and also the original Premium) has some issues with PL-3507 too ( see: http://club.cdfreaks.com/showpost.php?p=1579808&postcount=63 ). Maybe you can point them to that fact too?


#11

Ah… cancel that: http://club.cdfreaks.com/showpost.php?p=1697835&postcount=88 :eek:


#12

Ok, i can confirm the problem: http://club.cdfreaks.com/showpost.php?p=1704518&postcount=146

I mailed Plextor.be support.


#13

Did you get an answer?