D-Link Dir-655 router configuration

vbimport

#1

Hi :slight_smile:

My previous router (a Linksys WAG200G) was acting crazy recently, i.e. it crashed randomly with no apparent cause and the only way to recover it was to unplug the power because the web-interface was not accessible at all during these crashes… a device reboot then is possible only unplugging the power :doh:

After some readings I found this review. In that site there are a lot of benchmarks and based on results published there, it seems that the 655 is one of the best routers available.

I have to say that I’m not interested ad all to the wireless performance, because I don’t use it at all. I’m interested more in cabled connections, and the 655 seems capable to manage a very high number of contemporary connections (it should be useful when using the torrent). The gigabit switch is welcome too :bigsmile:

Being me a total noob, it is possible that I completely misunderstood the benchmarks, btw I bought this router and of course now problems started :doh:

First of all, after reading some information on D-Link forums (there is a subforum dedicated to this specific model… this can give an idea how problematic is the 655 :doh: ) I noticed that there is no official stable firmware available for this router. All firmwares are marked as beta. Moreover, there are different versions according to geographic region, so there is an EU version for Europe, a NA version for North America, etc. Of course, the latest (beta) versions are not available at all for the EU, but only for NA, and there is a bold statement that installing a NA firmware on the EU routers will void warranty (and probably it will destroy the device too :doh:).

The default firmware already included in the router (version 1.21EU) has a weird issue: it allow to change settings only a single time. After changing a setting, the web interface asks for a reboot. After the reboot, any change is simply ignored. The only way to remedy (according to D-Link forums, and I can confirm this) is reset to factory settings, make all changes, and reboot the device only after all changes are made.

It occurred to me 5 factory resets to finally be able to make all the needed changes, but finally it seems that everything is fine.

I don’t have the default firmware available and I have no idea how to extract it to save somewhere a .bin file on HDD, and being all firmwares available marked as beta, I’m not sure that is really a good idea to install a more recent firmware, even because on D-Link forums I read about many users complaining that the new firmwares solve an issue and create 2-3 new issues :doh:

btw, after a ton of errors and factory resets, I was finally able to set the router to work. It was not that easy to open a port for the torrent, but now everything seems working. I said seems, because the performance is not really nice for this router.

With the old linksys I was able to upload at full speed, but with the new router I can download but I can’t upload at all. The port for the torrent is open (I checked and it is working correctly), but even if the tracker (a private one) is able to see my connection I can’t seed a single byte :doh:

Any idea what can be the problem?

The only changes I made on default settings are the following:

  1. change router password
  2. disable wireless
  3. open a port for the torrent
  4. disable QoS

There are a lot of settings for this router, so if any furher information is needed, tell me and I’ll check it :slight_smile:

Thanks :slight_smile:


#2

Some routers only like IE for the interface, which browser were you using?

Make sure your torrent program has “trusted program” status with your firewall program.

Give Utorrent a try its good at punching holes in a router, its also really small and is updated regularly.


#3

Thanks Eric :bigsmile:

The saving option is a bug not related with the browser, but is in the firmware. Many other users confirmed that in D-link forums. And after resetting to factory defaults I was able to set correctly everything. The trick is to change everything before the router reboot. After the first reboot, no changes will be saved again.

I changed nothing in firewall/software configuration in my computer, only the router. With the old Linksys I had no problems at all. The upload issue appeared with the D-Link one.

In case someone is wondering how many torrents are running at the same time, the answer is 3, one downloading and two seeding. No problems in the download compartment but even if there are many leechers, no upload is done :confused:

I can upload with no problem, I used filezilla to test the upload capabilities. and with ftp I have no issues.

uTorrent is indeed the software I’m using (lighter and much simpler than vuze :iagree: )

I don’t know if it is useful, but I also ran a speedtest just after connecting the router. I know that my ISP suxx, but it is the best I can find at the moment :frowning:


#4

While the DIR-655 does have an impressive CPU it also does have its shortcommings.
The firmware seems to stabilize in some versions while being broken in others.
1.33NA seems to working well according to users in a swedish computer forum although I don’t know if it works on all revisions etc.

As for portforwarding it’s pretty much straight forward.
http://portforward.com/english/routers/port_forwarding/Dlink/DIR-655/Utorrent.htm

You should be aware though that disabling QoS is bad on an asymmetric connection such as yours. D-Link also uses something that’s called WISH which might interfere if it’s enabled. uTorrent also seems pretty bad which it comes to handling a low amount of connections since you cannot tune TCP and UDP timeouts on the DIR-655 and you cannot use UPNP and set a port (and forward) at the same time. UPNP should be avoided if it’s appliable. In the regard, Vuze/Azureus (Classic UI) is much better…

I can also tell you that some WLAN settings makes it really crawl for some odd reason.

//Danne


#5

Thanks for your answer DiiZzY :slight_smile:

So basically I choose the wrong router :doh:

I saw that “WISH” thing nowhere, maybe it is in a subsequent version of the firmware.

I have no idea also about WLAN settings :o


#6

Now, that’s definitely weird… I installed again the Linksys and I can upload again at full speed.

So there are two possibilities: or I’m setting something wrong in the D-Link, or the D-Link router is not that good as reported at smallnetbuilder.com :doh:

It is more probable that I’m doing something wrong, but the D-link firmware support certainly suxxx if I have to restore factory default every time I need to change something in settings :Z

The reason why I choose this model was this chart, according to which the 655 is able to manage up to 22,172 Maximum Simultaneous Connections… I thought that it was the most important thing when coping with torrents :doh:

I’ll read some more at D-link forums, I can’t believe that nobody was able to solve this issue :doh:

If I’ll find a solution I’ll post here of course :bigsmile:


#7

Check if you can flash, to the firmware I mentioned above. Turn off WISH and QoS.
Have in mind though that if you max your upload your download will drop considerbly.
//Danne


#8

I’ll flash to the new firmware :slight_smile:

I also noticed another thing: the modem was not set as bridged, but I was still able to connect to internet. Could it be another bad mistake made by me? :doh:


#9

You should run in bridge mode if possible, it’ll work much better that way.
//Danne


#10

Firmware updated, modem set as bridged and now connected to the net :bigsmile:

QoS is disabled but traffic shaping is still enabled. Should I disable traffic shaping too?

Upload speed is still lower compared to the linksys however :doh:


#11

If you have traffic shaping enabled you should get lower upload than theoretical max upload given that values have been set.
//Danne


#12

Traffing shape is now disabled, and also the modem has been replaced.

The reason why I changed modem is that I noticed frequent (very annoying) disconnections. Based on LED blinkings, the router seems not the culprit because all lights are not changing (like it should happen if the router reboot for some reason).

My idea is that the D-Link 320B seems very prone to loose connection (a friend already warned me about this risk with D-Link modems, but at that time it was the only alternative I had, so I was forced to buy it anyway). Luckily, however, a couple of weeks ago I found a Linksys AM200 modem in a store at a nice price (I grabbed it faster than light :p) so I can check if the modem is really the culprit. I’ll give it some time to see if I get frequent disconnections also with the linksys.

If also linksys modem shows the same behavior, then the culprit must be the D-Link router, that periodically (randomly) reboot for some reason, or my ISP that really suxxx :Z.

At the moment, Linksys modem seems more stable because there are lesser oscillations in connection speed (I can see it using the uTorrent speed graph). Upload speed is more stable and higher than when the D-Link modem was used.

Let’s see what happen after some running time :bigsmile:


#13

Oh, so you did get an AM200 modem in the end :slight_smile:
Running without QoS/Traffic Shaping will give you dips in dl when maxing out upload.
//Danne


#14

Finding the AM200 was not so easy, but luckily I found one :slight_smile:

If I found another one in a store I’ll buy it for sure :eek:

I was surprised when browsing the AM200 settings: there is a firewall in that modem :eek: I disabled it to avoid conflicts with the router however.

Currently no disconnections (about 15 hours running). I’ll check in next days, but until now everything seems very good :bigsmile:


#15

If you run in bridge mode the firewall should be disabled/inactived by default.'
Does the router still reboot?
//Danne


#16

No reboot (yet) on the router, and no disconnections too :slight_smile:

I really like the AM200 :bow:

I tried also a sort of “home-made” stress test :stuck_out_tongue:

I ran at the same time a download manager (flashget), a FTP client (Filezilla), the browser and the torrent… nothing exploded (yet) :bigsmile: