D-Link DI-524 Router wireless problems

vbimport

#1

Greetings to All. I have a D-Link DI-524 router linked to a modem. I use this router as an access point to internet. I have a desktop which is linked to the router via ethernet cable, a second desktop 3 m away and a laptop which is generally downstairs ie around 10 meters away with the floor and some furniture in between. The wireless connections to desktop and laptop
usually work properly, but sometimes one or both connections drop out. In order to reestablish the connection I try things such as restarting the router or the computer. After a number of attempts generally I manage to get the connection working. The firmware of
the router is up-to-date. I have been searching the net and the support site of D-Link until now without any success. Help from forum members is very welcome.

Thanks.


#2

Try updating the firmware of the laptop wireless device as well. Another thing to try is to put the antenna of the router in a horizontal position, since the laptop is below the router.


#3

DLink DI-524 manual.

I’ve the very same router, works okay at wireless. :wink:


#4

Old D-Links have this “issues”, if firmware update doesnt work your only way to fix it is to replace it. I’d highly recommend a Asus WL-500g Premium which you can find at eBay for 69.99. Giving it a push using third party firmware give you an excellent router with QoS (packet prioritizing) capatbility as well as very good stability. The one at my parents place has over 160 days of uptime… :slight_smile:
The main cause for these issues is overloaded CPUs and lack of memory, if you run P2P applications try to limit amount of connections but it’ll only help temporary in general. Of course having the newest drivers available for your WLAN-cards helps.
//Danne


#5

The same DLink router had such poor range right out of the box that I returned it for refund. I’ve had a Trendnet TEW-432BRP router for about 6 months now with excellent range and zero problems, and it’s only $10 after rebate from http://www.buy.com/retail/usersearchresults.asp?querytype=home&qu=trendnet+tew-432brp&qxt=home&display=col&dclksa=1.


#6

Thanks to everyone who responded with valuable advice. I bought the laptop in January 2008. Thus the drivers are up-to-date. I have put the antenna in horizontal position. The laptop sometimes detects the presence of the signal and displays it as a 90% strong signal. Other times it does not detect it all. Such behaviour looks strange to me. Comments will be highly appreciated.


#7

That’s pretty much normal, you dont normally find your AP on “all” refreshes.
//Danne


#8

Hi All.
I have a D!-524 that I am trying to install. When I go to the activation site, I can’t get past the authentication page. I type in “admin” and leave the password empty, but it simply repeats showing that box every time.
Any suggestions would be appreciated.
Thanks.


#9

Have you tried
Admin / <blank>
admin / <blank>
admin / admin
admin / password
…and if non of the combos work, tried resetting it?
//Danne


#10

Thanks Danne.
Yep, tried all of the above including resetting and trying them all again.
No luck. ???


#11

AHA!! Tried ‘user’ instead of ‘admin’ and got on to the wizard.


#12

Aaarrrgggghhhhhh! Getting on as ‘user’ doesn’t help; it won’t let me change anything.
I have to get in as ‘admin’ but even after resetting I can’t get on the ‘admin’ without a password.
This is getting frustrating …


#13

Access problem solved! I switched to IE from Firefox and had no problem with the ‘admin’ signon.


#14

Resetting it should allow you do login with default login (whatever that is, consult your manual). Otherwise its a broken/crippled firmware.
//Danne