Cypress Semiconducter Chipset + Benq Dw1655 HELP!

Hello,

Kk, so my benq DW1655 and External Enclosure from Dealsonic, The one w/ a Cypress Semiconducter Chipset in it…

This can be found here:

http://www.dealsonic.com/plpmblcousb2.html

This Enclosure was suggested to me by a user on this forum BTW named, Chas009, He told me it would work out great with the Benq DW1655

So, I’ve got the drivers installed (automatically) since I am on windows XP.

And the case all set up…

I go and burn my 1st image to disc… And burning speeds are at fucking 2x…

I put maximum burning speed in… And also tested with Nero Cd-Speed and still only 2 fucking x

This thing is slower than my MatSHITA labtop drive…

I really need some help guys… Am I missed some hardware installers… Is something not right?? Shouldn’t I be able to burn faster than 1.43 x??? I mean common that’s pathetic for benQ…

Or is this Cypress chipset just the wrong one and I need to take it back???

PLEASE HELP!

Something else is wrong here. Even if you have the wrong enclosure you should be getting better results, although BenQ is picky.

I just tore my system apart to get the 1655 into a Cypress and I can’t see why you should be having trouble. Attached are the transfer tests and the test burn at 12X, both of which indicate 8x-12X should be no trouble. Of course, as I said in the external case thread, test burns and burst rate testing is not perfect.

Are you sure you have USB 2 enabled in the BIOS?

Try a CDSpeed transfer rate test and burst rate test and post what you get. Also clear up for me; do you have the Oxford chip or the Cypress?



Hi,

please check your jumper settings. It is a good thing to have set that to “master” if the drive is used externally.

Michael

acutually you are both right… Not only that, my jumper wasn’t even connected at all cuz i didn’t know wherre the hell it went…

But, i just sent back my Enclosure to Dealsonic.com and they are sending me the one with the Prolific chipset in it… So, hopefully that should work out better…

Thanks for the help!

-David

What laptop have you got. Has it got USB2 ports as if not then you will be stuck at a very slow speed.

If you dont have USB2 ports then you can buy a USB2 PCMCIA card to use with the enclosure.

Hi,

As he has reached 2x DVD speed, there is probably an USB 2.0 interface existing. With USB 1.x even 1x speed can’t be reached.

If you dont have USB2 ports then you can buy a USB2 PCMCIA card to use with the enclosure.
According to my experience, these are not capable to provide much more that 16 MB/sec.

Michael

Hi,

It is important to have a jumper set. Otherwise your drive would really act erratic.

But, i just sent back my Enclosure to Dealsonic.com and they are sending me the one with the Prolific chipset in it… So, hopefully that should work out better…
Not if you ignore the missing jumper :bigsmile:

Michael