Cyberlink PowerDVD no audio through SPDIF/Toslink

vbimport

#1

Hi there

Not really sure where to post this, but I think it’s a software problem so here goes:
Using

  • Cyberlink PowerDVD 10 MkII Trial Version
  • Windows 7 Ulitmate 64bit
    I’ve just built a new HTPC system (spec) and I can’t get any sound out of the digital optical output (toslink/spdif) when playing Bluray. If I change the audio properties in PowerDVD to output stereo via HDMI, the sound comes out of the TV and the PC (via headphone socket) OK, but I can’t get anything out of the digital 7.1 connection. The amp is a Denon AVC-A1SE (:D) and I’ve plugged the optical cable into the socket that the DVD player used to be connected to and worked fine.

I’ve updated to the latest Realtek audio drivers etc. and checked the PowerDVD compatibility with my audio chipset (ALC888-GR); this wasn’t specifically listed, but did fall in between some of the other chipsets; does this mean that the chipset is not supported, or is there something else going on?

Any thoughts or ideas appreciated.

Slainte

midders


#2

If you want your receiver to decode the audio (I recommend this) then you need to set the encoding formats for your receiver. This lets the Realtek software know what types of audio signals (i.e. DTS, AC-3 etc.) to send RAW to the optical output. You need to find the “Realtek Digital Output Properties” dialog box and go to the “Supported Formats” and check the boxes your receiver can decode. You will also need to go the the “Realtex HD Audio Manager” and make sure the box is unchecked for “S/PDIF-In to S/PDI-Out Pass Through Mode” if this is listed as an option in your sound driver software.


#3

[QUOTE=UTR;2537059]If you want your receiver to decode the audio (I recommend this) then you need to set the encoding formats for your receiver. This lets the Realtek software know what types of audio signals (i.e. DTS, AC-3 etc.) to send RAW to the optical output. You need to find the “Realtek Digital Output Properties” dialog box and go to the “Supported Formats” and check the boxes your receiver can decode.[/QUOTE]
Yes, I found this option and set it appropriately; I think I’ve actually tried all of the options individually (!).

You will also need to go the the “Realtex HD Audio Manager” and make sure the box is unchecked for “S/PDIF-In to S/PDI-Out Pass Through Mode” if this is listed as an option in your sound driver software.
I don’t recall seeing this; I’ll have a look after work today and let you know how it goes.

Slainte

midders


#4

I couldn’t find any pass-though option at all.

I’m at a total loss here, and because it’s an optical connection, I can’t even put a multi-meter across it to see if something is coming out! (I might have a poke around inside the case and see if I can detect a signal from the digital header).


#5

http://www.realtek.com/products/productsView.aspx?Langid=1&PNid=24&PFid=28&Level=5&Conn=4&ProdID=135


#6

Thanks for the link; I’ve already tried that and downloaded the Win 7 drivers, despite the warning here. The problem is that the mobo specific drivers don’t mention Win 7; I’ve tried them anyway and I’m now waiting on a usb wi-fi dongle to try out the fox liveupdate software (came with the mobo) which should automatically download the correct drivers.

Slainte

midders


#7

Have you tried using Media Player from Windows to see if it works properly? There might be something in PowerDVD that you need to toggle.


#8

[QUOTE=UTR;2537655]Have you tried using Media Player from Windows to see if it works properly? There might be something in PowerDVD that you need to toggle.[/QUOTE]
Good idea, thx; I was locked into the blu-ray option, to test the HD Audio; I’ll stick a DVD in when I get home and try it with VLC and/or WMP.

Slainte

midders


#9

[QUOTE=midders;2537683]Good idea, thx; I was locked into the blu-ray option, to test the HD Audio; I’ll stick a DVD in when I get home and try it with VLC and/or WMP.[/QUOTE]

I don’t think VLC allows the audio to be passed through as RAW data to a receiver through SPDIF. I know WMP does.


#10

After several days of mucking around, I finally managed to sort this out by doing the following:

  1. uninstall all Realtek Audio drivers and use the MS Windows 7 ones (not sure if this is strictly necessary, but I found several threads that recommended it)
  2. download and install AC3Filter
  3. set Cyberlink to use SPDIF
  4. set ac3filter to use passthrough

AC3Filter rocks; I will be donating come payday.

Everything sprang to life instantly and I enjoyed Avatar in 1080p with DTS ES Matrix 6.1 sound (according to my amp) :smiley: :smiley:

Thanks for your input, UTR.


#11

I 'm glad it worked out for you. Now all that is left is enjoying sitting on you couch watching movies, listening to music an surfing the web.


#12

Hi Guys
New guy here… Hello…

I found this post… I have been trying to use Cyberlink Power DVD 13 for a year or more could be 2… through the digital/toslink output.

I have left many support requests with Cyberlink - still not enjoying my DVD’s

OK…looks promising.

Downloaded and installed AC3 Filter. Still nothing aside from loud high pitched white-type of noise.

I did not understand the instructions about

  1. the Realteck Audio nor
  2. the instruction about the Pass Through or
  3. Settings on AC3 Filter.

Yes I am a little thick. Can someone walk me through these

Thank you.

Dan