Cyberdrive CW078D

This is my first post… good reason why though.

I bought a retail Cyberdrive from ABSPC and well it has the original release firmware on there. There have been some firmware updates since then.

Only I can’t seem to update the burner. I download the corresponding file from http://www.cyberdrive.com.

The message I get is “Model name is mismatch!!!” while I am postive that this is a CW078D burner (40x16x48) and Windows reports it as one.

Anyone have any idea what I can do?

I have a drive manufactured by Cyberdrive, which had a similar problem when I tried to flash my firmware. For some reason I would keep getting that error mesage when I had the drive connected to my Iwill XP333-R mainboard, which has a built-in RAID controller. The drive was on the PRIMARY IDE controller, not on a RAID channel, that would have been sad! I was able to flash it only after connecting it to another motherboard. The other motherboard was an another almost identical Iwill Athlon board (XP333), but one without an integrated RAID controller. Anyway, try connecting the drive to another system and see what happens if you can.

allright I will try that later… thanks for the tip!

Would like to add that firmware 110e flashed fine… but that firmware was already applied. Strange things I tell ya :rolleyes:

Nope it didn’t work. I tried 4 different computers all the same error.
Informed Cyberdrive of it and still have yet to receive a response.

http://www.cyberdrive.com.tw/Firmware.htm
these didn’t give me model mismatch error