CRW-544A Doesn't read CD HELP!

vbimport

#1

I have a CD WR that used to work and one day it just didn’t read anything anymore. I rolled back a driver and updated a driver and this and that. The device manager says the device is working properly…but it isn’t. Why is it lying to me?! LOL!

Can someone please help me?

Thanks,
Emily


#2

Sounds like the drive is on its way out, best thing to do is try it in a different machine if possible then if it’s still the same it’s time to buy a new drive.
Is it detected in bios and windows?
Try deleting the drive and the ide channel that its on in device manager and rebooting.
Have you changed the firmware recently?
Any error messages from the drive?


#3

There could be a couple of reasons why your drive isn’t reading CDs. First, what does your drive do when trying to read a CD?


#4

I’m not getting any error messages on the actual drive. When I expand the folder in windows explorer it’s empty. I have the ROXIO program and when I try to burn a CD it tells me to put in a CD…and there is already one in there…creepy… It doesn’t even recognize that a CD is in the drive. That’s why I’m confused as to why it says it’s working properly. It’s detected in windows and I have tried to download the most recent firmware but when I try to install it, it cannot find the device to upgrade. UGH, I think I just need a new one.

Hope that helps!