Crucial releases firmware fix for M4 SSD's

vbimport

#1

The popular M4 SSD’s have started malfunctioning after 5184 hours of use. They cause a BSOD in Windows or kernal panic in Linux operating systems. There are reports of crashes in Mac OS X sytems as well.

Crucial has released a new firmware to address this problem, and recommends that it be applied to all M4 SSD’s. This will prevent the problem from occurring if you haven’t reached that amount of use on your M4 SSD.

The new firmware can be downloaded from here: http://www.crucial.com/support/firmware.aspx?AID=10273954&PID=3332167&SID=u00000626


#2

Yo Kerry-

Thank you so very much for this information-eh.


#3

Just in case anybody else had this issue:
On my win 7 64bit system, I downloaded the firmware and opened the downloaded file,then used the windows “burn to cd” function. Changed my boot sequence, and when it tried to boot, it couldn’t recognize the cd as a boot drive, and tried to run a repair.
After a few attempts, I decided to download it to my other system, and burn to cd with imgburn. Put in pc, rebooted (with asrock z68, had to hit f11 to select boot menu, and then select my cd drive). It found the firmware cd and booted properly, but then my Razr Lycosa keyboard wouldnt type to enter “yes”. Then I had to grab my old ps2 keyboard, plug it in, reboot again, then the firmware update worked like I charm…


#4

Yo-

Burned my CD-R with Active@ISO Burner program at 16x - rebooted and it slicked right in with no problems and said ‘0309’ firmware installed at the end.

Thanks again Kerry!


#5

[B][I]Moi, “ARRRGGGGHHHH…Dang it…it got me…I´m hit!!! cough cough…”

Kerry, “Whoa, Deanimator…ya hit baaard???”

Moi, “F**# you Kerry…yo eva heard of anyone gettin hit good???”[/I][/B]

Righto…I has a [B]Crucial M4 128GB SSD[/B] with 5243 hours on it…was chuggin along fine…passed the dreaded 5184 hours of use…smiled smugly (eh!) and carried on. Well…a few weeks ago, just before a job in Barvaria (it´s true, the beer is VERY good there!), it did it: [B]BSOD[/B] with "[B]missing operating system[/B]"
Restarting didn´t help.
Swapped it with the clone copy on a Vertex SSD in my lappy…same.

BUT…the Crucial booted up and ran like normal in my lappy…so seemed to eliminate an SSD failure.
Today…wriggled all the connections, took the RAM sticks out and put them back…et voilà …up and running. Just a loose connection…YAY!

Well, the devil loves a smug idiot eh!

Trying to do a bit of work and down it goes after an hour or so…re-wriggled stuff…restarted, all good…then down boy!

Methinks old Kerry may be right…worth a try anyway.

BRB…or not!

:doh:


#6

My 512gb Crucial M4 is working just fine. I’ll install the update when I get close that amount of hours.


#7

JOB DONE…EASY PEASY…they´ve set up a ZIP file, everything in it. Download, put it on the desktop, open, accept the license stuff, continue…and stand well back with a smallish beer…goes fast all by itself and restarts…says it has the latest firmware…and the world is all pretty colours again!!!


#8

It was easy ( I needed Wendy help LOL) It fecked up the alignment



#9

Mine came with the latest firmware already installed, so I didn’t have any worries at all. But then, I bought mine almost six months after the fix was released.


#10

After 12 hours, she´s still running.

I pronounce you healed…! Go in peace. :smiley:


#11

I guess you could call it a crucial update :doh:


#12

[QUOTE=deanimator;2642514]I guess you could call it a crucial update :doh:[/QUOTE]

:rolleyes: :rolleyes: :rolleyes: :rolleyes: :rolleyes: :rolleyes:


#13

The neww firmware made the drive a little faster, I wouldnt know about the hours problem as I have not reached that limit yet.:slight_smile: