Crossflashing doesn't work? *Please don't ignore*

vbimport

#1

I’m kind of embarrassed to have to write a thread about crossflashing since there are countless others out there and I’m also a forum user who helps people fix their PC’s so I know how frustrating it is to repeat that which is answered in other posts. And believe me that I have searched for the past two days in the trusty search engine and though I’ve learned a lot I’m still puzzled to why this is not working, so I beg anyone to help me out with this.

Ok I’ll try to make this simple:

I bought a 50pk Kodak DVD+R DL and have burn the disc most of the time with a Lite-On LH-20A1L (latest firmware) and the DVD writer from my HP laptop. I just fixed my main PC which has a Lite-On LH-20A1S (latest firmware) but this one won’t read the blank Kodak DVD+R DL media, although it can read them if they’re finalized.

Now, my first thought was to go to cdfreaks which I remembered from long ago and now I’ve learned that this is CDFreaks. Ok so after reading a lot I thought that maybe If I crossflashed my 20A1S to the 20A1L I could use the firmware and maybe it would read the discs since supposedly the only difference between the drives is the lightscribe which I don’t care for at all. After reading some more I found that EEPROM Utility and Flash Utility is what’s required for the crossflash.

Here’s what I did:

1) I backed up my 20A1S eeprom with the EEPROM Utility. I also backed up the eeprom with the 20A1L and copied it to a USB drive and transfered it to my main PC (the one with the 20A1S) along with its latest firmware, the BL06N.exe

2) Then I used the Crossflash tab in EEPROM Util. and used the upgrade function and followed the instruction method. I chose the correspondant model I wanted to flash to.

3) Then I went to Flash Utility and used the read flash option and chosed the latest .exe firmware (BL06N) from the 20A1L and it saved it as a readable .bin .exe file (weird I know). Then I wrote the flash and waited till the process was completed and the light stopped blinking and restarted and…

4) Nothing. The drive stayed as a 20A1S. And no matter how I do it I can’t seem to convert it to an 20A1L.

***I’ve also tried the Convert drive methods from EEPROM.
***Have also tried using the backuped EEPROM of the 20A1L to flash write it to the 20A1S using the Flash Utility.
***I’ve also tried using the Omni patcher since my objective here is to make this drive burn the kodak DVDs but the program seems obsolete? I can’t get any firmware to load, not even the modified ones.

Well since, my main objective is to burn these crappy Kodak DVD DL with my main Lite-On LH-20A1S I was wondering if the method I’m using is the correct one or if it will give me any kind of success.

From what I could gather the most promising tool for this was the Omnipatcher but I can’t seem to use it now and it hasn’t been updated in quite a while so I’ve come to the conclusion that it doesn’t work with this kind of drive.

Please help in any way possible. I won’t be using this PC for a week since I will be away but I will still check up if anyone has posted answers here.


#2

Have you tried using Flashfix? Note Flashfix doesn’t work with newer firmwares which means you’d need to flash to older firmware for it to work. There’s an older firmware for the 20A1S at http://codeguys.rpc1.org/firmwares.html.


#3

So, your burner won’t recognize the blanks.

What MID does the “50pk Kodak DVD+R DL” have?


#4

thanks for the reply bevills1. I will try to use flashfix and write back the results. Also, thank you for replying quickly chef. Unfortunately I am unable to provide that info as I am away from home and don’t have any Kodak media with me. Though I assume that the MD can be obtained with Nero Tools yes? Unfortunately I won’t be able to do anything suggested or ask until this Friday since I am away from home but I welcome any more suggestions and instructions anyone can give me Thanks.


#5

Just posts back when you have the time to get the MID info.


#6

Nero CD-DVD Speed: Disc Info
Basic Information
Disc type: : DVD+R DL
Book Type : DVD+R DL
Manufacturer: : Ricoh
MID : RICOHJPN D01 067 (43h)
Write speeds:
Blank Capacity : n/a
Extended Information
Layers : 2
Layer break : 3.74 GB
Write strategies : n/a
Disc Status : Closed
Raw Data
Physical Format Information (00h)
0000 - E1 0F 32 10 00 03 00 00 00 F8 5C 5F 00 20 E8 4F - …2…_…O
0010 - 00 00 03 52 49 43 4F 48 4A 50 4E 44 30 31 43 40 - …RICOHJPND01C@
0020 - 25 25 37 10 00 2C 6C 00 2C 6C 20 1F 0C 0C 14 14 - %%7…,l.,l…
0030 - 02 01 01 20 00 20 1F 0C 0C 14 14 02 01 01 20 00 - …

Well from what I read here RICOH is supposed to be good? The Quality score on Nero tools ended up at 99. Maybe I just had the rotten luck of incompatibility with this drive.


#7

That is no media/MID what I would call “good”.

Grab some Verbatim or Falcon media (see the media section).