Creative x-fi

got my new pc, new sound card, but only onboard sound! I just can`t get the creative sc to work, can anyone help? vista, asusp5n-e sli motherboard, new pc from pc specialist

[QUOTE=stevethepainter;1927633]got my new pc, new sound card, but only onboard sound! I just can`t get the creative sc to work, can anyone help? vista, asusp5n-e sli motherboard, new pc from pc specialist[/QUOTE]Welcome to CDF’s:

I have a Creative X-Fi card and had 1 problem with it but i am using XP Pro. Called their support and fixed it in no time.

Beings how it’s new call their support. Not that we cannot help you, i would start with support.

[QUOTE=stevethepainter;1927633]got my new pc, new sound card, but only onboard sound! I just can`t get the creative sc to work, can anyone help? vista, asusp5n-e sli motherboard, new pc from pc specialist[/QUOTE]

Did you check the motherboard BIOS to disable the on-board sound chipset? Also check your owner manual it should give you instructions as to how to disable the on-board sound chipset so you can use your creative sound card.

[QUOTE=stevethepainter;1927633]got my new pc, new sound card, but only onboard sound! I just can`t get the creative sc to work, can anyone help? vista, asusp5n-e sli motherboard, new pc from pc specialist[/QUOTE]

Hi Steve
When I got my new rig I had the same problem you may want to install the Creative sound blaster X-Fi audio driver update from the link below
http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=pv-48309-1&lc=en&cc=us&dlc=en&product=3385406&os=2093&lang=en

after you install it open Windows Media Center and setup your Speakers please post back on how things work out

Tim :cool:

Hi again Steve
here is a little bit more you may want to know , I’m not sure what your speaker setup is but should be 5.1 so you should also have the THX setup console installed may want to use it to config your speakers
You will find it on the Start Menu–> All Programs–> Creative–> Sound Blaster X-Fi

Have a nice weekend my friend

I am still going to say you need to check your BIOS to disable the on-board sound chipset. If you don’t do that your sound card won’t be enabled as they will share same IRQ leaving the on-board to take over sound. So check with your manual and disable the on-board sound chip.

[QUOTE=coolcolors;1928171]I am still going to say you need to check your BIOS to disable the on-board sound chipset. If you don’t do that your sound card won’t be enabled as they will share same IRQ leaving the on-board to take over sound. So check with your manual and disable the on-board sound chip.[/QUOTE]

I went into bios to see what you are talking about the setting for the on-board audio was on Auto so I disabled it to see if it made a differance,in sound quality not sure if it did or not, But will keep it disabled for now to test it.
Thanks for the info coolcolors :cool:

NP, this should at least fix it so the sound should go to the X-Fi card now. But all I can say is unless Soundblaster website has fixes for issues with vista you would be best to contact them for support as they most likely would know what might be the issue if you don’t get any sounds. Also what is your speaker setup as well? Also check in your device manager once you disabled the on-board sound chipset to see if vista see the sound card if it does and there is no error then it should be working…

@ coolcolors
Here is my findings on my testing
after disabling the on-board sound had volume has long as the seting was above 8 notches(around 25%) which was very very low volume :frowning: sound effects little above normal :rolleyes:
Went back into BIOS and reset the on-board sound back to "AUTO"
played the same movie with volume setting at 25% have GREAT sound effect THX entertainment mode enabled :clap: was told to turn it down :eek: anyway I will keep my on-board sound set on “AUTO” :cool: thanks for your info though:flower:

So does your vista see the x-fi sound card? Usually to be able to use the x-fi card you have to disable the on-board sound chipset.

if your using vista and a creative card your shit out of luck because creative are too stupid to write drivers that are any good for vista. They have a set of drivers here but they offer basic support, The creative forum is here where you can join thousands of others getting their posts deleted asking for some sort of support for their creative cards

[QUOTE=coolcolors;1928948]So does your vista see the x-fi sound card? Usually to be able to use the x-fi card you have to disable the on-board sound chipset.[/QUOTE]

It is listed in Device Manager along with “Realtek High Definition Audio”

If I disable the on-board sound in BIOS then the “Realtek High Definition Audio” is not listed in Device Manager only the Creative X-Fi is listed

@ Slaveking
My system is Vista and I have NO problem with the Creative sound Card or X-Fi system