Creative Labs Firmware Needed

vbimport

#1

Does anyone have the BIN of Firmware LCS6 for Creative Labs CD-RW RW1210E (re-badged Lite-On LTR-12101B)? I flashed mine to LTR-12101B, and I’d like to do some tests on whether there is really much or any difference in performance or write quality between Lite-On LS3J and Creative LCS6.


#2

I do not think that anyone will have it. I’m not sure whether backups are possible with the older, Sanyo based (not MediaTek based) drives. There is an LCS6 firmware available in this thread, but it is only a modified Lite-ON firmware, and not the real LCS6.

Would you mind trying something for me? We know that backups cannot be made for these drives with mtkflash, but I think that it may be possible with a program called wflash. If you could go here and try different ways of backing up I’d appreciate it. I was unable to make backups on my LTR-24102B or my LTR-48246S, but I could flash them.


#3

Thanks for the tip!

I just downloaded WFLASH and will try it out.

I’ll post my experiences in this thread!

Thanks again!


#4

Thank you.

I’ve been trying to find a 1B drive so I could test it myself, but I haven’t yet…


#5

I tried to backup the firmware in DOS with WFLASH. I used the commands “wflash ls3j.bin /pm /rd” and “wflash ls3j.bin /pm /rd /256” because the BIN files for this drive are 256 KB. LS3J.bin is a file that doesn’t exist; that’s where I want the firmware backup to go. Both times, WFLASH said that it didn’t recognize the command line parameter “/rd”. On “The Firmware Page”, you said

I’m not sure if it actually works, It wont on my LTR-52246S

I would like to find out if it is able to make backups of Sanyo based drive firmwares. If you have a LTR-****1B drive, please try different methods for backing up. Contact me if it works, or if you have questions about what you should try.

What happened when you tried to backup your firmware? Did I use the wrong command? My LTR-12101B is on the Primary Master of my motherboard because my hard drive is on an ATA133 PCI controller.

Thanks for your help! I am also interested in finding out how to do this.


#6

Well, again, I am not even sure if it will work or not, but if you’ve used pflash before, then you will recognize the similarity that wflash bears with it.

Since the program doesn’t mention where to put the /rd or /256 or /512 commands, I really don’t know what else to try other than maybe “wflash ls3j.bin /pm /256” without the “/rd”

I also wonder if it would work better if the drive were secondary slave like mtkflash likes sometimes.

I forget what happened when I tried to backup. I think it hung… I’m gonna go play around with it some more.


#7

Yes, I certainly recognized the similarity to pflash; it looks like the same program with a few more command line arguments to me. I’ll try your suggestions and see if I can get it to work. I’ll also try to use it to read the firmware off my 32123S.


#8

No luck here whatsoever. Maybe they never actually implemented the backup feature, but put the commands in there to tease us. I got the message about “/rd” being an invalid command too…


#9

I tried using the command “wflash ls3j.bin /pm /256”, and it said invalid file name. I then copied my bin of LS38 to “LS3J.BIN” and re-tried the command. It then acted as if it was going to flash the drive, but I pressed “Esc” when it said “press enter to continue and any other key to cancel” so that it wouldn’t be flashed. I wonder if there is a newer version of this program anywhere.


#10

WFLASH wouldn’t back up the FW on my 32123S, either.