CRC error



Until a few days ago my 1TB Western Digital external harddrive was working perfectly. I tried opening J: and I hear this faint click in the background and Windows tells me it cannot access drive J: .After another try a pop-up message tells me my drive has experienced a CRC error and then it immediately gives me the option of formatting to which i click no. I tried right clicking drive J: on my Computer but the Folder would just freeze or become very slow. After doing some research on how to tackle the problem, I ran "checkdisk J:/f which brought out an ms-dos window. Roughly about 15 minutes later an NTFS appeared below my Drive and even its Name was now showing (Kraz). However the properties menu claims the drive is empty and i still cannot access any of my important folders. Is there a way for me to fix my hard drive without deleting my files and folders. Its a new Hard drive, been only using it for 4 months tops.


I’m afraid there’s not much that can be done. Some here suggested to freeze the drive (in a zip lock freezer bag) and then try to get the data off the drive quickly. But chances are the drive is finished. There should be some data recovery companies on the net, but they won’t be cheap.