Crashed Firmware: NEC 3500AG in Lacie FW case

vbimport

#1

Oh Man,
I seriously made my drive completely unusable: I tried to update the firmware of my Lacie 16x DVD RW 4x DL external Firewire drive. It’s a NEC ND3500-AG inside. I used the program BinFlash 1.11, and it hung when updating, when it said: erasing old firmware or something similar.
Now I guess the firmware has been erased. When I switch on the drive, the led just blinks and that’s it.
The drive is not recognized anymore, neither from windows, nor from any of the flashing proggies I tried, including the Lacie updater.
I read about the DOS prompt possibility, but that does not work for external drives, does it? Especially because I have a PCMCIA Firewire card without DOS drivers.

I much appreciate any idea how I can recover my drive!

Thanks a lot, guys! Cluso.


#2

If the LED is still blinking, that means your drive is still alive.
Unfortunately something went wrong during the flash process. Usually it’s caused by external enclosures not supporting the necessary commands. You might need to attach your drive without the enclosure in some way.

You’re probably right with DOS support, but Windows should be able to find a drive, although it’s probably labelled as NEC ND3100 or something like that.

If your drive is not accessible, you might try to boot Linux. There are several images that allow booting from disc or CD. Maybe you’re lucky with that.


#3

Hm, is there any possibility without removing the drive from the case? I only have a laptop, so I cannot connect it to the IDE bus directly.


#4

Hallo again. I tried Linux. In fact, the drive is recognized! As you said, not as a 3500, but a ND 3100A drive:

ieee1394: sbp2: Logged into SBP-2 device
ieee1394: Node 0-00:1023: Max speed [S400] - Max payload [2048]
Vendor: _NEC Model: DVD+RW ND-3100A Rev: 0.01
Type: CD-ROM ANSI SCSI revision: 02

I tried the linux version of binflash. With the scan option, it seems to hang for a while, and finally finds no devices. In the system log, there appears an error message:

ieee1394: sbp2: aborting sbp2 command
Mode Sense 00 2aieee
1394: sbp2: aborting sbp2 command
Read Capacity 00 00 00 00 00 00 00 00 00
00 80 00

Is there any hope to get it fixed in Linux, or do I have to connect the drive to the IDE bus directly? Will the drive then be found by the flash software?

Thank you for your help, Cluso.


#5

Hmmm. I do not issue a “Read Capacity” command in binflash. Did you try to mount the device? (Maybe some kind of automount software?)

You could try to directly flash your drive, if you know what device the drive gets. But I don’t know if the LaCie enclosure is capable of forwarding all necessary commands to the drive.

In this case there’s no other choice that directly attaching the drive to an IDE cable. But the good news is that your drive isn’t dead (yet) :wink:


#6

Thanks a lot for your help!
Since I don’t have a desktop computer, I can’t really try the IDE way. And the LaCie case doesn’t have screws or anything, so you would probably see the scratches an I’d have no more warranty. So I rather return the drive to where I got it, hope they fix it for free.
Thanx again!