[Crash] Trouble with special, German characters

vbimport

#1

NeroLinux 2.0.0.0 crashes reproducable when renaming the name of a CD with using German Sonderzeichen like äöü. I tried to strace nero which does not work. If I try to the burn-button is grayed out. Is there any other way of debugging the application?

Gentoo Linux
Kernel 2.4.11 (vanilla)
glibc 2.3.4
$LANG = de_DE@euro


#2

When does it crash exactly ? Can you tell me the exact step to reproduce it ?


#3

Sure :slight_smile:

  1. open nero
  2. add a file (no matter what kind of)
  3. rename the cd once, after the crash the new name you have given remains
  4. push the “record” button

After pushing “record” the small burninfo-window ist opening, this is the moment it crashed all the time. The progress-bars show 0%.


#4

Can you attach your ~/.nerorc file (just remove the serial number before) ?


#5

here we go:

nerorc.txt (2.74 KB)


#6

I cannot reproduce it on my current machine. I will try to reproduce it next week on another linux distribution.


#7

Seems like a Gentoo specific problem so far. Maybe theres another user of this who can test it. :slight_smile:


#8

Maybe, it depends on the locale settings of the environment. What do you use?
It is known, that GTK1.2 does not support UTF8.


#9

‘locale’ produces the following:
LANG=de_DE@euro
LC_CTYPE=“de_DE@euro”
LC_NUMERIC=“de_DE@euro”
LC_TIME=“de_DE@euro”
LC_COLLATE=“de_DE@euro”
LC_MONETARY=“de_DE@euro”
LC_MESSAGES=“de_DE@euro”
LC_PAPER=“de_DE@euro”
LC_NAME=“de_DE@euro”
LC_ADDRESS=“de_DE@euro”
LC_TELEPHONE=“de_DE@euro”
LC_MEASUREMENT=“de_DE@euro”
LC_IDENTIFICATION=“de_DE@euro”
LC_ALL=

Is that what you mentioned? :slight_smile:


#10

It looks like he is using ISO8859-15… not UTF-8


#11

Checkey my kernel-config, my default codepage is “8859-1” as it seems. I also have “437” compiled into the kernel, but 8859-1 is the default.


#12

Can you start nero in a debug session (gdb nero -> run) and make it crash. Once it is crashed, just type bt (backtrace) and copy the output in this thread.


#13

Stupid me just startet Nero through KDE Icon and ALT+F2 “Run command…”. The result is the mentioned crash-bug. When starting through bash or xterm everything works fine, the bug has disappeared. Since my login-shell is the bash I thought that every app should source its configuration files. Tested the same Icon and ALT+F2 thing in XFCE with the very same results. KDE Version is 3.3.2, XFCE is 4.2.0, Xorg is 6.8.2.

Thanks for your help; I’ll stick with the start from the shell till next release is ready for download. If you want further testing I’ll continue to obey your orders Obi-Wan :wink: