CPU useage at 100% during DVD burn

vbimport

#1

I have an MSI K8N Neo4 Platinum board (7125 v. 1) with an AMD 3000+ Venice CPU running at 1808 MHz with 2 - 512 OCZ sticks in dual channel (200MHz). Cut to the chase is that I’m not overclocked in any fashion. I use a Toshiba TS-H552U w/Firmware US07 for DVD creation. My question is, when duping a DVD (Decrypting, analyzing, encoding and writing) my CPU is showing in Task Manager at 100% almost throughout the operation. Is this normal? Characteristically I’m using DVD Shrink. Underlying reason in asking this question is that I’m going to be installing a TV Capture card and many of the write-ups that I’ve read caution about their heavy reliance on the CPU; the hopes here were to capture (burn) direct to DVD vs. going thru the hard drive. Any thoughts re: why the 100%, recommended changes, capture card recommendations? Thanks.


#2

Mostly normal, of course. Enable DMA.


#3

Just to expand on chef’s post.

While analysing/transcoding expect a high level of CPU usage. However, when actually burning it should drop quite low. If you’ve still got high CPU usage at this stage it suggests that DMA is not enable on the burner (in particular) or possibly the source. Running in PIO mode (very bad news) causes almost 100% CPU usage.

Regarding TV capture, I’d certainly not even think about cappturing directly to DVD. Going to the HDD would be a must for me.
You need to get a TV card that does it’s own encoding rather than using the CPU. This way you avoid dropped frames etc. My Leadtex Winfast PVR2000 is a good example of one that does this.


#4

TimC and Chef - thanks for the input; was unaware that DMA could be enabled on the burner, thought that related only to HDD’s. Went to Nero Tools and DMA is off. How do I enable: went to device manger and no option is shown - how do I do this? Actually went to device manager then to 2ndary IDE Channel Properties, the Toshiba is Device 0 - Current Transfer Mode is listed as “DMA if available”; Current transfer mode is listed as “PIO Mode” the only apparent changeable option is Transfer Mode to PIO. So, am I set up right?


#5

Yo LarryAllen-

Make sure that your burner(s) are set to UDMA in the bios first - reboot then check your device manager -

If it still says ‘PIO mode’ after the bios change - uninstall the drivers in the Secondary channel where the burners are shown - reboot and allow windows to recognise the burners and the ‘new’ drivers - then recheck the device manager to see if the burners show UDMA

Mike


#6

Mike, here’s the deal. I did all that you suggested last nite w/negative results but thought I’d try again this morning. Went thru the following drill. At boot went into CMOS/BIOS, in “Standard CMOS” > “IDE Secondary Master” > TSST – only options relate to HDD settings re: LBA, etc. Next went to “Advanced BIOS”, there are no options related to drives other than “boot sequence”. Next went to “Integrated Peripherals” > “IDE Devices” > “IDE DMA Access” – this is set to “Enabled”. Continued my boot and brought up Nero Tools Info, TSST still shows as “DMA Off”.

Went to “Control Panel” > “System” > “Hardware” > “Device Manger” > “DVD/CD ROM Drives” > “TSST” > “Driver” > Uninstall. Closed and Restarted. “Found New Hardware – TSST” appeared in Taskbar Tray, and then disappeared. Went to Nero Tools Info, TSST still set to DMA Off.

Rest of the story, “Google searched for DMA enable DVD Drive” and found an ugly tidbit re: Windows XP automatically forces the device to POI after repeated CRC check failures and only way to reset is to go thru RegEdit. I hate doing this, have done it before but its an open invitation to screwing up. What I’m thinking of doing is changing cabling of the TSST and my std. CD Rom drive making the TSST the Secondary slave via hardware, what do you think or do you have a better suggestion. Thanks, LarryAllen.


#7

Yo-

Think you are onto something here - I have always used the burner as the ‘Master’ and the CD-ROM as the ‘Slave’ - making sure that the ‘Master’ is at the end of the 80 wire cable and the ‘Slave’ is in the middle and the drives are jumpered on the back accordingly (have had limited success with the ‘Cable Select’ setting)-

The 80 wire cable gives superior interference protection IMO-

Mike


#8

Mike - When in doubt, go for the easy way - I did, it worked! Swapped the cabling, TSST is now slave. Checked in Nero - “DMA On”; checked in device driver and TSST is now set to Ultra DMA2; interestingly the std. CD-ROM, now the Master was set to Ultra DMA 2 as well. So-o-o-o, no monkeying with the Registry, there is a God in heaven.

This brings me back to TimC if he’s still around. This all began with my desire to put a TV Tuner in. Now that the speed issue on burning is resolved, I’m back to card selection. Tim, you suggested a card w/hardware coding/decoding and I had researched this considerably. Bottom line was that I had reduced my selections down to just three cards - Hauppauge (150,250,500), ATI TVWonder Elite or Leadtek2000 (your card). Thing is I read a lot of user reviews on all 3 and read more negatives relative to Leadtek, particularly graininess. Fact is I don’t always believe everything I read, so let me ask you - have you experienced any shortcomings with the card or its associated software, drivers or support? My reading on Hauppauge cards seemed to indicate that most come w/a remote and this is only functional w/MCE which I don’t use (I’m XP) thus I would be paying for something I’m not going to use and further I’m not sure how well the card functions in absence of remote use. Cut to the chase is that I’ve pretty much decided, subject to input to the contrary, to go with the ATI Elite which also comes with a remote but is not dedicated to MCE and is in fact dedicated to XP. A plus benefit I think might be that fact that my graphics card is also ATI and I have much of the software associated with the card already installed (Catalyst, Splendid), further I use Cyberlink for my DVD decding software and this is the same manufacturer that is shipped w/ATI for timeshifting, etc. How about sharing your thoughts with me. Thanks - Larry Allen


#9

Larry

I must admit that I’ve not done a great deal with my Leadtek but what I have done has been fine, can’t say I’ve experienced anything like graininess.

Initially I had problems with getting audio butI emailed Leadtek & got a prompt response (after allowing for time zones) which pointed to me to new drivers and all was fine after that.

Overall I’m happy with my choice.

Tim


#10

Thanks Tim. And again thanks Mike & Chef.


#11

Got the case solved?