Couldnt flash 1633 now is dead

vbimport

#1

HI guys:
tried to flash my liteon 1633s to the newest firmware, using omnipatched firmware and couldnt do anything, then used MKTFlash and it said it updated and said to reboot machine, now dvd drive wont even turn on :frowning: I assume its dead in action. What causes this? Does it fry something, it would seem if you had a bad flash you would still have power to the dvd writer and be able to open the drawer but not so,
Just curious.


#2

To open the drawer the firmware is needed. It is almost impossible to kill the drive with flashing, so you can relax.
To start with, what have you done exactly? Did you use the dos mtkflash booting from a dos floppy or did you use mtkwinflash, which does not work with dvd burner ?
Did you flash a raw binary .bin file or did you flash the .exe file ?
Which command line parameter did you use when flashing ?


#3

after flashing i wasnt able to do anything with the drive, mainly it wouldnt open and was recognized by the bios anymore.

i used the mtkflash from a floppy

command line: mtkflash 3 w /m *.bin


#4

Which mtkflash version did you use ? Some need the /b switch. I assume your drive is secondary master ? Instead of the ‘*’ you did use the real filename prefix ?


#5

also depending on what mother board… you might have a problem flashing
in dos… or maybe even a bad cable


#6

yes i have changed cables and settings on drive, and it would seem when flashing the drive i would see some activity on the drive itself (blinking) it the flashing progress says complete but on reboot still not there, also have tried plugging in drive for hotbooting after am at dos prompt. Will go ahead and try on another mboard and if it doesnt work will try and rma it. thanks for the help guys :slight_smile:


#7

try it in another system. if it works, just format your hard disc, install windows and it will work.


#8

why in the world would I want to format my hard disc???