Cossacks - European Wars

vbimport

#1

Having read that CloneCD could be used to backup Cossacks - European Wars, I've tried but found that when reading to the image file, the CloneCD progress bar stays on 1% for a very long time (I gave up after 25 or so minutes). I'd read in an earlier posting that it could be backed up by enabling the reading subchannel data from data and audio tracks and also fast error skip, so these were the settings I tried.

The protections are apparently 'VOB' and 'Safedisc', while elsewhere I've read that it uses 'Copylok'.

Has anyone been able to backup this cd, and if so, what settings should I use? Is it just a case of waiting for a longer time until the reading finishes?

I'm using CloneCD v3.3.4.1 with a Plextor 121032A. I'd really appreciate any help or ideas.


#2

The version I have here uses Copylok or LaserLock and that takes a really long time to read depending on the device you’re using. Here’s a screenshot of a Waitec review I’ve done for CD Freaks, reading LaserLock:

Not a whole lot you can do about this. These protections simply take a long time to read. Use the right settings to speed things up a litle like Intelligent Bad Sector Scanner and Fast Error Skip.


#3

Thanks for your reply.

I’ve just tried it with intelligent bad sector scanning (I wasn’t sure how many sectors to use so I picked 10,000!) - went out for a walk with the dog. It certainly read the cd a lot faster. The copy installs but gives me the ‘program will not run without game cd’ warning when I try to run it.

I was using subchannel data (audio & data), FES on (3 retries, no correction) at max speed, along with intelligent bad sector scanning.

Do you think it’s worth trying it without intelligent bad sector scanning (ie. is this likely to make the backup work as I don’t understand how intelligent bad sector scanning works?) or is there anything else worth trying?


#4

Well I think your range of 10.000 is way to much:

Originally posted by FutureProof
[B]A working backup depends on reader/writer capabilities. There is no protection in the subchannels as the ‘signature’ on both protections is physical. Now, not everyone gets a working backup.

The recommended settings are:

Read: all off (IBSS & FES may help if your reader supports it.)
Write: default (close & just link etc)

The following quote I extracted from CloneClinic some time ago (thanks to WRFan, I think)

[quote]Intelligent Bad Sector Scan…IBSS - this feature is used only for the Laserlock and Lockblocks protections (one visible ring on the newer cds and 2 rings on the older computer games). It will influence the speed of image making, trying to read the locking sectors on the cd a little faster.
I would suggest that you set the range of 1 or 2, but not more, otherwise there is a very great danger that the programme would skip “healthy” sectors. I know, it will take more time if you set the range to such a small number, but then you can be pretty sure that the copy will work.
I had very bad experiences when I set the range to a higher number than 2 or 3. but it depends on the drive you use for reading. e.g., when I use a toshiba drive or a philips burner to read, I can set the range to 80-100 and it works fine, but when I use my plextor burner for reading, it always skips healthy sectors (60.000 sectors instead of 10.000 protected, which makes 50.000 healthy sectors being skipped). Since the plextor is such a good burner, it can skip locking sectors very fast using the hardware, without any additional help from Clonecd. but my toshiba drive and my philips burner are not so good, so they need much help from software (clonecd). so if you have a plextor burner, I would suggest that you use it with the range of 1 or 2. if not, you could try using the range of 80-100. the protected (locking) sectors are approx. between 800 and 11000, so if more is skipped, reduce the range and try again.

If your copy works, then I guess it’s ok. You have to try for yourself. If the errors don’t exceed the 3-4%, or in other words 11.000 sectors, then it’s ok. but if you get 60.000 bad sectors with plextor, like I did, while the toshiba drive finds only 11.000, then it’s clear that clonecd is not really optimised for all drives. actually the ibss is intended for bad drives, which can’t deal with laserlok sectors on their own. I set the range to 1, it’s fast enough when reading with plextor burner. if it takes too much time with your drive, increase the range and check out how many bad sectors there are in the end. if it appears to be suspiciously many ones, reduce the range and try again.

It may take some time; there is no way to speed the process so that it takes significantly less than say 40’ (the lowest time read I have seen)…it may well take several hours. [/B][/QUOTE]As you can see LaserLock or Lockblocks can take quite some time… But I can’t be sure your game has the LaserLock or Lockblocks protection. Can you post your read LOG-file here?


#5

TRY turning fast error skip on and to 3-5 tries. Error correction software… Peace


#6

Cossacks is ProtectCD by VOB - it is a dog and not all combinations can defeat it. I posted my last read log at Clone Clinic of my Toshi 1402 - it took 42’. The tests I did showed that leaving audio subs unchecked led to very faint audio in some campaigns & loss of audio while at the menu screen.

Settings:

Read: FES (default & 1); IBSS @ 1 000; both subs
Write: all off except Close & buffer underrun technology

For some readers it may take a while. My first read of Cossacks on a (Taiwan) AOpen 48x took 7 hours; set it and forget it overnight (disable scheduled services, diskkeeper etc.)


#7

Thanks for your responses - much appreciated. I will try out your suggestions and let you know how I get on.

w_bloke


#8

I tried the settings that Futureproof suggested for backing up Cossacks (FES: software and 1 retry, IBBS: 1000 sectors, data and audio subchannels checked).

Using these settings, CloneCD read the original cd in about 25 minutes this time around (whereas before the status bar hadn’t moved past 1% after 20 or so minutes).

The backup installed properly, but when I run the game from it, the cd doesn’t seem to ‘read’ properly. The game takes quite a long time to finally load - when it gives a ‘the program will not run without the cd-rom in the drive’ error.

HOWEVER, despite this, the game actually does start (eventually!) - it just lacks music. Why this is I’m not sure, but the end result is a (more or less) working backup. If anyone else has any other suggestions for Cossacks European Wars I’d be pleased to hear them.

Thanks for the advice.


#9

I have a 32x LiteOn and used the setup suggested by FutureProof. It took awhile to do the first 5% (30 mins) but the went quick. I burnt the game okay and it installed, but this is where the problems happen.

If you start the system from scratch or restart and let the disc selfload it will load and display the front page, when i select play I get a BSOD fatal exception message, i hit any key and it loads. If i try and load through the start menu I get a illegal operation message when i hit play and it resorts back to the front page. And keeps on doing so until I let it selfload from a reboot.

Any Ideas.

PS: I am also getting Illegal operation pop ups all the time since I did the Cossacks burn. eg: SqStart and Ie illegals?


#10

Originally posted by FutureProof
Cossacks is ProtectCD by VOB

[off-topic]
Maybe I missed it somewhere… (allthough I used the search function) is this a new protectionscheme? Where can I find more info on how this protection works? VOB is the company who engineered this protectionscheme?
[/off-topic]


#11

CD Media World

VOB Home
http://www.vob.de/us/index.htm - English
http://www.vob.de/de/index.htm - Deutsche

Cossacks has a large data file & when read, it resembles SD. The track data after the SD ‘like’ errors is typical of ProtectCD. There are digital signatures (contrary to my previous advice) which are not brought into the image by all devices. My Hitachi GD-7500 & AOpen CD-ROMs could not pick up some of the music data.

I 12:50:31 PM CloneCD Version 3.3.1.1 started!
I 12:50:31 PM ElbyCDIO Driver 3.3.1.1
I 12:50:31 PM ElbyCDIO.dll 3.2.3.2
I 12:50:31 PM CCDDriver.dll 3.3.1.1
I 12:50:31 PM ElbyECC.dll 3.1.0.0
I 12:50:31 PM Searching for SCSI/ATAPI devices…
I 12:50:31 PM Device Scan found 4 CD-ROMs and 2 CD-Writers!
I 12:50:31 PM Registered to: me!
I 12:51:00 PM Starting copy from TOSHIBA DVD-ROM SD-M1402 to E:\CD Images\CossacksEW.ccd
I 12:51:00 PM Read SubChannel Data from Data Tracks: Yes
I 12:51:00 PM Read SubChannel Data from Audio Tracks: Yes
I 12:51:00 PM Fast Error Skip: Yes
I 12:51:00 PM Don’t report read errors: No
I 12:51:00 PM Intelligent Bad Sector Scanner: Yes
I 12:51:00 PM CD contains CD-Text: No

I 1:37:44 PM Reading Track 1… (Blocks 0-140469)
W 1:37:48 PM If you don’t expect read errors on this CD, disable “Fast Error Skip”!
W 1:37:48 PM Failed to read Sector 2316
W 1:37:49 PM Failed to read Sector 2317
W 1:37:50 PM Failed to read Sector 2318
W 1:37:51 PM Failed to read Sector 2326…

W 1:56:25 PM Failed to read Sector 4897
W 1:56:29 PM Failed to read Sector 4898
W 1:56:32 PM Failed to read Sector 4899
I 1:56:34 PM Scanning bad sectors…

W 1:56:38 PM Writing Dummy Sectors 4900 to 4978

W 1:56:39 PM Failed to read Sector 5011
W 1:56:40 PM Failed to read Sector 5012
W 1:56:41 PM Failed to read Sector 5013

W 2:55:13 PM Failed to read Sector 10016
W 2:55:14 PM Failed to read Sector 10017
W 2:55:15 PM Failed to read Sector 10018

I 2:57:27 PM Reading Track 2… (Blocks 140469-149644)
I 2:57:40 PM INDEX 0 Track 3 LBA 149494!
I 2:57:40 PM Reading Track 3… (Blocks 149644-158990)
I 2:57:53 PM INDEX 0 Track 4 LBA 158840!
I 2:57:53 PM Reading Track 4… (Blocks 158990-168149)
I 2:58:07 PM INDEX 0 Track 5 LBA 167999!
I 2:58:07 PM Reading Track 5… (Blocks 168149-178181)
I 2:58:21 PM INDEX 0 Track 6 LBA 178031!
I 2:58:21 PM Reading Track 6… (Blocks 178181-187543)
I 2:58:35 PM INDEX 0 Track 7 LBA 187393!
I 2:58:35 PM Reading Track 7… (Blocks 187543-197221)
I 2:58:49 PM INDEX 0 Track 8 LBA 197071!
I 2:58:49 PM Reading Track 8… (Blocks 197221-206370)
I 2:59:02 PM INDEX 0 Track 9 LBA 206220!
I 2:59:03 PM Reading Track 9… (Blocks 206370-216122)
I 2:59:17 PM INDEX 0 Track 10 LBA 215972!
I 2:59:17 PM Reading Track 10… (Blocks 216122-224999)
I 2:59:30 PM INDEX 0 Track 11 LBA 224849!
I 2:59:30 PM Reading Track 11… (Blocks 224999-234120)
I 2:59:43 PM INDEX 0 Track 12 LBA 233970!
I 2:59:43 PM Reading Track 12… (Blocks 234120-243117)
I 2:59:56 PM INDEX 0 Track 13 LBA 242967!
I 2:59:56 PM Reading Track 13… (Blocks 243117-252460)
I 3:00:10 PM INDEX 0 Track 14 LBA 252310!
I 3:00:10 PM Reading Track 14… (Blocks 252460-261697)
I 3:00:23 PM INDEX 0 Track 15 LBA 261547!
I 3:00:23 PM Reading Track 15… (Blocks 261697-270776)
I 3:00:36 PM INDEX 0 Track 16 LBA 270626!
I 3:00:37 PM Reading Track 16… (Blocks 270776-280427)
I 3:00:50 PM INDEX 0 Track 17 LBA 280277!
I 3:00:51 PM Reading Track 17… (Blocks 280427-289849)
I 3:01:04 PM Duration of operation: 01:23:21
I 3:01:04 PM Reading finished!

I 3:35:59 PM Starting copy from E:\CD Images\CossacksEW.ccd to LITE-ON LTR-24102B
I 3:35:59 PM Don’t repair SubChannel Data: No
I 3:35:59 PM Amplify weak sectors: No
I 3:35:59 PM Write Simulation: No
I 3:35:59 PM Buuffer Underrun Protection: Yes
I 3:36:01 PM Writing Session 1 LeadIn…
I 3:36:23 PM Writing Session 1 image file…
I 3:39:19 PM Writing Session 1 LeadOut…
I 3:39:21 PM Flushing buffers…
I 3:39:21 PM Duration of operation: 00:03:20
I 3:39:21 PM Writing finished!

Since the last version of Clone (Jan 3), the 24102B with at least 5s07 can do Cossacks very quickly:

I 9:24:23 PM Reading Track 17… (Blocks 280427-289849)
I 9:24:28 PM Duration of operation: 00:06:23
I 9:24:28 PM Reading finished!;

unfortunately, the 1402 now takes over an hour! This swings around every few versions of Clone; I remember complaining about this last year to Olli.


#12

@FutureProof:

Great! Thanx for the info!

:smiley:


#13

OK I’m having the same problem … however when I read mine in clone cd it reads fine … it burns fine … But the version I have starts at a screen saying " SafeDisk tm " … It would be except I checked the version of safe disk and it thinks it’s ver 2.30.030 … however I cannot seem to unwrap it … the other problem is that no matter where I look someone says it has a different type of copy protection ??? Does anyone know what protection is actualy on it … I can install it from the backed up version but not play it … oh and it is a NTSC ver … however I’m not quite sure which ver 1.0 ??? Any help would be greatly appriciated :confused:


#14

copy it at the lowest speed x1 write it at 1x on tick fast error sip and nowt else… hopr this helps nosh:cool:


#15

The Cossacs version i have is not protected - just checked it with clony - and have made a successful backup several times !!! :wink:

Maybe i was just too lucky :cool: