Copytodvd burning slow all of a sudden

vbimport

#1

I have been using copytodvd for quite a while and it has worked great… until last night, when my burn speed has slowed down considerably. The average burn speed in the past has been abot 4x and now all of a sudden, the speed is a little over 1x.

I have the speed set at max in the burner settings in copytodvd. The log still shows “Writing speed requested x4.0, effective x4.0”, but then it shows something like this “Average speed x1.37 Reference x1 = 1385.00 kbps”. Does that make any sense?

I have not changed media and the burner I am using is the one factory installed in my fairly new Dell. The burner is HL-DT-ST DVD+RW GRA-4120B

I have attached my copytodvd log and would be extremely appreciative for any help on this. The slowness is killing me…

Thanks a ton

–JB


#2

From your log…

12/29/2004 7:39:57 PM info DMA Disabled
12/29/2004 5:47:52 PM info DMA Disabled

Enable DMA.
Also, try selecting specific burn speed rather than ‘MAX’.


#3

Hey RS2… thanks for the reply.

I have no idea why those couple of sessions from my log show DMA disables. I never changed anything. I went to the device manager and I think everything looks ok. I have attached a snapshot of the device manager settings for DMA.

I tried changing the burn speed to 8x and 4x instead of max and it has not changed anything.

I have attached my lasted log and if anyone can take a look, I would really appreciate it… Could my burner possibly be screwed up and it now will only burn at a little over 1x speed?? I’m almost thinking of getting a new burner to see if that changes anything, but something tells me that its gotta be something that can be fixed… ughhhhhh

Thanks,
JB

DMAsnapshot.doc (50.5 KB)

C2CDlog.txt (57.7 KB)


#4

In Device Manager/IDE controllers, does your system show Primary
AND Secondary IDE channels? If so, what transfer mode is indicated
in Secondary IDE Channel Properties?


#5

RS2 -

The only things listed under IDE/ATA ATAPI controllers is:

Intel® 82801FB/FBM Ultra ATA Storage Controllers - 266F
Intel® 82801FB/FR SATA AHCI Controller
Primary IDE Channel

The 2 burns on 12/29 are the only ones that say DMA Disabled in the log. I didn’t change anything in the device manager for the Primary IDE Channel, because the Transfer Mode was set at DMA if available. Looking at the copytodvd log, I don’t see any more reports of DMA Disabled…

This slow burning is killing me…

Thanks again for your help, I really appreciate it.

–JB


#6

That is because those two burns were with a newer version that includes transfer mode detection, the other versions you have been using (3.0.22 and 3.0.23) do not include this.

You need to check what it has for the “Current Transfer Mode”, it should be Ultra DMA Mode 2 for your writer, if it has “PIO Mode” then you will need to fix it.
See Wombles most excellent post here for a guide to checking/enabling DMA transfers.


#7

Portmac,

Thanks for the post… I actually came back to post that I have managed to solve my problem.

It seems that my computer switched to PIO mode and would not let me change it to DMA. Even when I chose “DMA if available”, the transfer mode was still PIO.

I found the following webpage that explained this and how to reset drive DMA capabilities :
http://www.michna.com/kb/WxDMA.htm

I followed the regedit instructions and when I rebooted and checked Device Manager, I now have “Ultra DMA Mode 2” and everything works as it should.

Thanks for your help.

Here is the text from the webpage I found in case the link fails:

DMA reverts to PIO

DMA is an abbreviation for Direct Memory Access, an access method for external devices where the data transfer is not done by the central processor, but by a small special processor called DMA controller. It uses a procedure called cycle stealing, where the central processor memory access cycles are delayed for very short times to intersperse DMA controller memory access cycles. Some newer, faster DMA modes are called UDMA (Ultra DMA).

The alternative, slow and inefficient data transfer mode is called PIO, Programmed Input-Output, where the central processor transfers data byte for byte or word for word. This requires many processor commands for each data word and therefore causes a high and unwanted processor load.

Windows contains a trap in which quite a few computers seem to get caught sooner or later. The trap is described in the following article (and also in another one mentioned below):

DMA Mode for ATA/ATAPI Devices in Windows XP
http://www.microsoft.com/whdc/hwdev/tech/storage/IDE-DMA.mspx

The crucial paragraphs are:

PIO mode is enabled by default in the following situations:

For repeated DMA errors. Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.

In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.

Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).

Of course, drive firmware being quite complex and certainly containing programming defects of its own, it is not all that difficult to produce such errors. In my case a scratched DVD and later also an unreadable (overburned) CD did the trick, got the drive to choke and Windows to disable DMA for good. Later my hard disk hiccupped just once and also went back to PIO for good.

I had been using my laptop for DVD viewing for years, until I inserted a borrowed and heavily scratched DVD. The player and apparently even the DVD drive choked on it, and when I finally got the DVD to play, I found that playing was jerky and processor load was 100%, roughly half of which was system overhead.

This indicated that the drive had reverted from the usual UDMA (Ultra Direct Memory Access) mode 2 to PIO (Programmed Input Output) mode. No amount of resetting or changing the relevant registry parameters from 1 (try DMA) to 2 (force DMA) helped. Stubbornly the drive kept using PIO mode, and Windows even changed these settings back to 0 (use PIO only).

The following text will refer to the secondary IDE port because that is more often affected, but essentially the same also holds for the primary IDE port, to which the main hard disk is connected in most computers.

Before you begin to work on the problem, log on as Administrator or as a user with administrator rights.

Check Your IDE Port Mode
First check what mode your secondary IDE port is currently working in. Go to Device Manager: right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and check whether it is set to DMA when available. Directly underneath that setting is a grey field that shows the actual working mode of your IDE channel. You want the highest possible DMA or Ultra DMA mode there, and you definitely don’t want PIO mode.

Normally you don’t have to use the registry editor for this, because the normal settings are also available through the properties dialog for the IDE port, but if you want to look at it anyway, the parameter for the secondary IDE port can be found through regedit.exe at

HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1

It is named Scsi only for historic reasons. Scsi Port 0 is the primary IDE port, to which presumably your hard disk is connected.

After trying various remedies—in vain—I found the abovementioned article and went to work again. I uninstalled the DVD drive in Device Manager and rebooted, but that did not help either.

So I searched for more and better information, then I went on and did the following.

Re-enable DMA using the Registry Editor
My thanks go to my fellow MVP Alexander Grigoriev who taught me this method.

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can’t actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you’ve made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port

  1. Uninstall the secondary IDE port
    To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

  1. Reactivate DMA
    But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

  1. Driver is not intended for this platform
    If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that’s not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer’s IDE Channels
There’s a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn’t solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
http://support.microsoft.com/?kbid=817472

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you’ve done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive


#8

Good to hear your problem is resolved :slight_smile:


#9

Hey…

I have run into a new problem. Ever since I have fixed my DMA problem, every DVD copy I make is a coaster. They freeze and skip 3/4 through the disc.

I have read all over the place about this happening when using cheap media. I had this happen when I first started making copies way back and was using Philips media. I then changed to Ritek 4X DVD+R’s and they have worked flawlessly. So, I have stuck to these trusted Ritek’s and never had any problems with them until I fixed this DMA problem. Now every burn resultss in a coaster with the freezing problem. I am using a 100 pack of Ritek 4X DVD+R,s where I have gone through about half the pack before the DMA problem without a problem. Now, using the same pack of discs, I get coasters every time…

I have tried setting copytodvd to burn at max and also at 4x and still coasters.

I have searched for a firmware upgrade to my burner HL-DT-ST DVD+RW GRA-4120B, but do not find anything. There are firmware upgrades to the GSA-4120B, but the readme file says that it should not be used for DELL factory installed LG drives, which this HL-DT-ST DVD+RW GRA-4120B drive is.

Does anyone have any idea why this would happen all of a sudden and is there any thoughts or ideas on what I can do to solve this. I this a crappy burner and maybe I should change it to a better one??

Thanks for any help!!

JB (frustrated) :sad:


#10

Freezing ans skipping normally indicates a media problem, try writing a disc a 2x and see if that helps.