CopyDVD - Error Code 06 29 00

I have recently brought a NEC 3520A dvd writer and i am having a lot of trouble burning. I have tried writing dvd’s using CopytoDVD but it crashes about 20% in and the following message come’s up

Code 06 29 00 [Unit attention, Power On or Bus device reset occured

I have the dvd driver connected up externally through my pcmcia card as my laptop (Compaq Presario 2100) only has USB 1 ports and I need USB2.0. As i have already said i get the error a couple minutes into the copying but I have had it at 71% complete too. So far I have only managed to copy dvd’s which are 6 minutes long and this isn’t guaranteed every time.

I have checked the hibernate settings and they are all turned off, I disabled Norton when I go to make the copy and I don’t seem to find anything else which conflicts with it although obviously there is something.

I am using Ritek DVD’s (-R) to try and copy. I have also tried Philips +RW but they just seem to make my laptop hang and the only way the laptop will work again is if i turn the dvd writer off.

Does anyone have any ideas on how to solve this little mystery? I’d be extremely grateful for any advice. Thanks in advance…