Copies set subtitles to ON?

I’m using DVDFab to create “movie only” copies, removing all extras to provide room to allow the best quality posible. It seems that all of these copies will, when played in any dvd player, set the hardware to “subtitles on”.

What can I do to fix this??

Thanks,
Jester

Are you unchecking the appropriate boxes in the “Subpicture” area?

Also make sure the green default arrow (see the Main Movie page in the Tutorial) does not appear if you want to include the subtitles but not have them forced on.

I noticed this happening on a recent backup - It never used to happen with v3 - is this another instance of the programs defaults settings altering between versions ?

Ps it’s not a big deal if the movie starts with subtitles ON, as they can still be turned OFF with the DVD playback controls, in the usual way.

I’ve done 2 backups with 4.0.1.6, one main movie and one customize. The subtitles were correct (available but not forced on) on both. The green default arrow is hard to see if the subpic is highlighted. I don’t think the default behaviour of this has changed (or would be).

I’m not fully understanding this green arrow setting, even with the tutorial,

sometimes when I insert a disc to backup I don’t see a green arrow against any of the sub-picture options, but sometimes I do. Any idea why ?

[QUOTE=cybmole;1945297] I don’t see a green arrow against any of the sub-picture options, but sometimes I do. Any idea why ?[/QUOTE]

This only seems to work under certain rip modes. Other times , it has taken me a few extra clicks to get the arrow to show next to the sub-picture selection to force the subtitles on.

Another idea would be to not allow a preselection of any sub-pictures via common settings— then you will never see a green arrow until you click to place it when you want it.

to clarify- with some DVDs I can see the green arrow & I can move it about or make it vanish completelt, no problems

but with other dvds, in the same rip mode ( main movie), I can’t get the green arrow to appear at all !

Is that to do with how each DVDs subtitles are encoded or is it a bug in dvdfab ? do you have to hit an exact pixel somewhere in the windowto turn it on ??

Hi cybmole. The green default arrow will not appear unless you have the corresponding subpic box checked . It also will not appear in Customize mode unless you select the No Menus option. You are right that the selection area is fairly small and easy to miss.:slight_smile:

[QUOTE=signals;1945364]Hi cybmole. The green default arrow will not appear unless you have the corresponding subpic box checked . It also will not appear in Customize mode unless you select the No Menus option. You are right that the selection area is fairly small and easy to miss.:)[/QUOTE]

OK so I copied a disc to my hard drive today using customise + preserve menus + remove warnings + jump to 1st menu.
no green arrow is visible as per your post above, but when I open the copy on PC with PowerDVD I find that subtitles are on.

( & i’m pretty sure that powerDVD usually starts with subtitles off - there’s no setting in powerdvd to have subtitles on by default ).
so maybe the latest version is sometimes enabling subtitles by default ?

can you reproduce that result ?

[quote=cybmole;1946740]OK so I copied a disc to my hard drive today using customise + preserve menus + remove warnings + jump to 1st menu.
no green arrow is visible as per your post above, but when I open the copy on PC with PowerDVD I find that subtitles are on.

( & i’m pretty sure that powerDVD usually starts with subtitles off - there’s no setting in powerdvd to have subtitles on by default ).
so maybe the latest version is sometimes enabling subtitles by default ?

can you reproduce that result ?[/quote]Sorry, I use WinDVD. You can test the copied files with DVDSubEdit, a free application by jeanl. This is a great tool to have anyway. Just install it and then open (File->Open full domain, navigate to VOB). It will begin to analyze. When it finishes, it should be displaying a picture with subtitles in the playback window. Just to the right of the window is a box marked “Only show forced subpics”. When you click that, the playback window should turn black (if there are no forced subpics) or will show the first frame of video and text from a forced subpic (there should not be any based on what you said).
WinDVD will sometimes start with subtitles on if I had them on for some reason the last time I watched part of the movie (which is why I use DVDSubEdit for testing). I will edit in a download link if the forum doesn’t have one automatically.
//EDIT// DVDSubEdit download: http://download.videohelp.com/DVDSubEdit/

well this is very strange - I have windvd on my PC though I don’t normally use it, so I opened the same movie as beofre but this time in WinDVD 8 & subtitle option is greyed out _ I can’t get the subtitles to display in WINDVD no matter what I do. Flip back to powerDVD, & re-test the same movie still & it still starts with subtitles on.

so I download dvdsubedit & open a random VOB & I see a frame subtitle, which as per your post means that they are forced on ?

SO - conclusions ?

  1. FAb HAS forced subtitles on when making the copy, even though there was no green arrow
  2. It’s also done something non-standard which has confused windvd, or I have a bugged copy of Windvd or I don’t understand how to use windvd properly ( take your pick! )

MY test movie happens to be one of the X-fiiles series and my customise mode selects english only out of the many languages on the disc. It shouldn’t really matter what movies is being used for testing though. I’m sure this has been happening recenly with other movies.

PS I fiddled around some more in winDVD - now the subtitles on stuck at ON & i can’t toggle them of via the right click menu - the subtitles option there is still greyed out.

I’m gonna leave this as a possible bug for others to work on & just go back to powerdvd which is software I understand. I can put subtitles on/off in that with one botton press on the remote so it’s not a big problem for me.

( BUt my money is on there being a subtitles bug in fabv4)

Could be. I have not done many (3 or 4) backups yet with 4.0.1.6 but have not had any problems. Re: DVDSubEdit–did you put a check in the box that said show only forced subpics?

[QUOTE=signals;1946812]Could be. I have not done many (3 or 4) backups yet with 4.0.1.6 but have not had any problems. Re: DVDSubEdit–did you put a check in the box that said show only forced subpics?[/QUOTE]

err - hang on I’ll try it again— NO when I thick that box the window goes black. So the subtitles are not “forced”, they are just “on” by default ( but can be switched off)

so let’s rephrase the origianl thread starter problem to:

older fab version copies had subtitles off as default, newer ones seem to have subtitles on by default - but not “forced” - if that makes sense.

i.e. burn the copy, pop movie into standalone & it starts with subtitles being displayed. then you grab the remote & turn them off.

what used to happen (fabv3) was burn the copy, pop movie into standalone & it starts with subtitles off, but you could then grab the remote & turn them on

OK - I couldn’t leave this be so I did some more tests.
Same movie - copied across network., different PC, winDVD7 - subtitles still stuck at ON - subtitle control greyed out , and can’t turn them off with any of the windvd7 controls

Then selected a different movie on this PC its subtitles behave OK in WInDVD.

So I reckon its a dvdfab bug that occurs when you select a particular combination of rip options. - the other movie which worked ok did not use customise+preserve menus+remove warnings+jump to first menu. It was a simple main movie rip. I guess that when fab customised the IFos it somehow turned on the subtitles in such a way that winDVD can’t turn them off ( but powerdvd can)