ConvertXtoDVD Version 6

With the release of the latest VSO ConvertXtoDVD release of Version 7, VSO software disabled Version 6. VSO in emails to me claimed they were working on the problem. They didn’t respond further. I contacted them again and they apologized for not letting me know that they could not fix the problem. It would be too costly for them to work on earlier versions.

I discovered that VSO was intentionally disabling the use of Version 6. This occurs at the initiation of the Version 6 software to use it. By using functions of my system’s firewall, I found that VSO software immediately connects to panpan.vso-software.com (referred to later as the link) on program initiation. That connection causes Version 6 to be disabled, either because their authentication server cannot handle the connection properly or because the server intentionally returns a disabling response.

If you have a firewall that allows you to block connections to named URLs, add the link to the blocked URLs. You can also add the link to the Windows host table. You could also block 59.178.76.80 in the Windows firewall.

Users of ConvertXtoDVD, like myself, may prefer Version 6, instead of Version 7, because the resulting output rendering is better. Version 7 significantly compresses input media during conversion, outputting files with over-lossy results.

In my opinion, VSO has been dishonest about the blocking of Version 6 conversions. As with other software companies, it is attempting to force customers to pay for newer versions, even when the customer purchased a perpetual license.

1 Like

I haven’t used the software in some time but I have v7 installed. I installed v6.0.0.90, started it, and did a test conversion without any issues.

I fail to see how VSO is preventing the use of v6.

First, try Version 6 again–if you still have it. I have all the versions and I choose the version that provides the best results.

I also have Version 7. I have used it. VSO modified the conversion engine in Version 7 to compress output with lossy results. I prefer the conversions by Version 6–with no lossy results. (Read the VSO email after my reply for confirmation of my description.) When VSO changed servers, Version 6 failed because of the change. I insisted that there was no problem with Version 6, and I was right. VSO does not deny the changes and the inability to validate Version 6. You may not even know that every time you initiate Version 7, it connects to a VSO server. It does the same for Version 6.

After 30 years as a software engineer and systems auditor, I can say that VSO is acting for itself. What they aren’t telling customers is that the server software they put into place is defective. They could have rolled back to the earlier server release and then fixed the problem. In this case they are not acting to right a wrong done to a large customer base. By the way, I always have used the Best Video Quality option, in all releases. It doesn’t matter in Version 7. It still outputs lossy conversions. For many customers it may not matter. For me it does.

Email from VSO:

Hello,

We understand your frustration, this is directly offered you to switch to ConvertXtoDVD 7, the updated version.
(see attached screenshot for the “best video quality” option).
VSO Software changed the huge file/no loss quality of ConvertxtoDVD 6 because it was a request of the large majority of our users.

You are right for one thing, it is probably coming from our server update.
However, I can guarantee you VSO Software did not purposely block ConvertXtoDVD 6. We clearly have plenty of other things to do!
The new server could be unable to communicate with old request protocols, that’s the hypothesis our Tech team has, they won’t go any further on the investigation.
We will not fix anything on the old versions and we are sorry for the inconvenience it caused for you.

Again, we are sorry you feel this way about VSO Software.
We stay available if needed.

Kind regards,

Mélinda,
VSO Team


I responded:

Tell your customers to block connections to panpan.vso-software.com if they complain about the inability to use Version 6. I am now using it again. Blocking connection is easy for any Windows user: update the HOSTS file in C:\Windows\System32\drivers\etc with NOTEPAD to include “120.0.0.1 panpan.vso-software.com” in the domain name resolution list. Otherwise update the Windows firewall to block access to the URL or its IP address. Such a solution will restore function to Version 6.

It is not Version 6, and therefore your claim that you cannot fix problems in older releases is bogus. The problem is on your side and is because you have inept, poorly trained server technicians. Furthermore, it is quite evident that your server update tests failed and your quality assurance is narrowly defined and does not account for the broad base of your users, not to mention their right to use software they paid for with no expectation that it would suddenly fail to work.

You have also removed quality from the output of conversions by caving in to a bunch of people who want small files. There are many of us who prefer lossless DVD conversions. Given that you also make ConvertXtoHD, you would have continued to support lossless output in ConvertXtoDVD–as an option! Add that feature to your next release to make Version 7 or subsequent versions whole. Yes, you have a lot to do. You are still being dishonest to your customers. You are not telling them the full truth. Tell it! Give them back Version 6 functionality by explaining how to do it. I did it. You can tell them!

Le 02/03/2020 à 19:59, E. a écrit :

1 Like

I installed v6 and registered it using my license for it. Restarted CX2DVD and it prompts me to upgrade to v7 which I decline by clicking on the “Not Now” button and move on. I added two items to a compilation and ran the conversion. It completed.

I’m not debating the technical merits of v6 vs v7. It’s irrelevant. I’m merely commenting on how I am able to install, register, and use v6 to create and complete a project without doing anything special.

It’s a mystery. If Version 6 works on your system with no issues, then there is a difference in our systems or in the Internet connections–though IP protocols for V4 are implemented the same across Windows operating systems. The first occurrence of the problem was during or after a VSO server conversion (that I wasn’t aware of and they did not publish). I started Version 6 and it issued a message that I was using a trial version. I was unable to register Version 6 again using the license key. I was able to use Version 5. I used VSO automated support to retrieve the Version 6 key again. Version 6 would still not register, and although I could set up a conversion, the conversion button would not activate. I sent an email to VSO, and they responded that they were working on the problem. That suggested to me that I was not the only user experiencing the issue. They wrote:

Hello,

First thing first, thanks a lot for your message.
Since this morning we are indeed struggling with multiples online-check issues for our software.
We did a migration to a brand new server but it seems to be a missing link. Our team is currently on it, but we need all the info we can get to solve this asap.
This is why your emails are very welcome, thank you for your precision.

Could you please let me know the exact version of ConvertXtoDVD 6 you tried?
Could we organise a TeamViewer session?

Looking forward to your answer

Regards,

Maggie,
VSO Team


I sent all the information they requested. That is where communication ended. I uninstalled and reinstalled Version 6 multiple times. I even removed all references to Version 6 from the Windows registry before re-installing. I sent another email to VSO and they responded that they were not pursuing the problem further and provided a key to Version 7. That was pointless, however, since I already had purchased and installed Version 7. I should also note that Version 6 would initiate properly if I turned off the Internet router–which led to my changing the firewall to request approval of application connections to the Internet.

Since your system is unaffected, other users are likely able to use Version 6 for the same reason–unless VSO has installed a fix. But, as you can read in the VSO emails, they were aware of an issue after my first email about it. The connection approval function exposed the connection to VSO at initiation, which immediately after caused Version 6 to freeze and require termination through the task manager. My fix for the problem was to prevent the connection to the activation server–which worked. Voilà, there is no problem with Version 6. So, go figure. All systems are not created equal.

1 Like

I very much appreciate your effort to test the issue on your system. I am reminded of the blind men who describe an elephant. It exonerates VSO from being devious. (Remember how devious Apple has been, got caught, and is paying $500M fine.) If another Version 6 user has a problem, they might encounter our dialogue. I don’t know if VSO will suggest my solution to anyone.

1 Like

I am a VSO Goldmember and I have all the programs they make. They are all extremely functional and a pleasure to work with. I have been using VSO software for almost 15 years, maybe more, When we hosted their software here, ( we were CDFreaks ) there was a support member from VSO here all the time, his name was Ken, screen name Portmac. The software is as solid as it always was. Thanks for visiting.